X11 startet und stürzt dann ab.

Dieses Thema im Forum "Mac OS X - Unix & Terminal" wurde erstellt von Mauki, 03.01.2005.

  1. Mauki

    Mauki Thread Starter MacUser Mitglied

    Beiträge:
    14.739
    Zustimmungen:
    138
    MacUser seit:
    24.07.2002
    Habe mir mal wieder Fink installiert und wollte mal die KDE-Pims mir anschauen. hab das ganze installiert und wollte es nun über X11 starten.

    Nur wenn ich X11 anklicke, erscheint es im Doch, die Menüleiste ist 2 sek sichtbar und das wars ? Was kann hier das Problem sein. Ich habe festgestellt,d as irgendwie von nem alten Test noch icewm als Windowmanager eingestellt war,d er ist aber nicht mehr drauf. Hab dann wieder auf Quartz WM umgestellt, aber trotzdem Absturz :confused:

    Achja wenn X11 wieder läuft, wie kann ich den KMail oder KOrganizer starten ?
     
  2. Sir_RamDac

    Sir_RamDac MacUser Mitglied

    Beiträge:
    1.138
    Zustimmungen:
    12
    MacUser seit:
    04.11.2003
    Also das sieht so aus als ob die xinitrc ne Macke hat. Liegt in /Public/etc/X11/xinit/.
    Evtl mal schauen ob das was nicht stimmt. Allerdings gibt es alle KDE Anwengungen
    auch nativ unter OS X (mit Qt) und benötigen kein X11 da sie sich nahtlos in die
    Aqua Oberfläche einbinden (das hab ich zwar mit x11 halbwegs hinbekommen
    aber ganz so hübch ists halt nich)
    Wenn X11 läuft dann ziehst du einfach das entprechende Programm aus /sw/bin in
    deinen "Programme" Ordner und verpasst dem noch nen schönes Icon und Name und
    dann startet das so wie jedes andere OS X Programm auch. Alternativ kann man
    das auch im xterm mit /sw/bin/./programmname starten.

    So gäääääähn *schlafengeh*

    MfG S.
     
  3. saki

    saki MacUser Mitglied

    Beiträge:
    335
    Zustimmungen:
    2
    MacUser seit:
    10.09.2004
    Schau mal nach ob irgendwo unter Deinem user eine (.)xerror in Deinem home oder unter /usr/X11R6/lib/X11 zu finden ist.

    Alternativ einfach an der Konsole den Server mit "X" starten ob das klappt und was dort ausgegeben wird wenn nicht. Wenn das klappt auf jeden Fall mal in der xinitrc nachsehen (/usr/X11R6/lib/X11/xinit/xinitrc; wie schon oben beschrieben).

    Gruß
    Sascha
     
  4. Mauki

    Mauki Thread Starter MacUser Mitglied

    Beiträge:
    14.739
    Zustimmungen:
    138
    MacUser seit:
    24.07.2002
    das würde ich gerne am liebsten nutzen und habe das auch schon entsprechend ausprobiert. Allerdings frieren die Programm, wenn man sie anklickt sofort ein und man kann Sie nicht nutzen. Vielleicht sind die einfach noch ein wenig Buggy. Mir wäre diese Variante aber am liebsten.

    ne xerror habe ich nirgends gefunden. Den Server habe ich mal auf der Konsole gestartet, hoffe das war so richtig.

    Last login: Mon Jan 3 00:03:25 on ttyp1
    Welcome to Darwin!
    x
    noname:~ Mauki$ x

    XFree86 Version 4.3.0 / X Window System
    (protocol Version 11, revision 0, vendor release 6600)
    _XSERVTransmkdir: Owner of /tmp/.X11-unix should be set to root
    sudo x
    [DRI] screen 0 installation complete
    Screen 0 added: 1024x768 @ (0,0)


    Wie komme ich den zu /usr/X11R6/lib/X11/xinit/xinitrc ? Muß ich da ins terminal ?
     
  5. saki

    saki MacUser Mitglied

    Beiträge:
    335
    Zustimmungen:
    2
    MacUser seit:
    10.09.2004
    Erstmal : Ja, shell wäre nicht schlecht, da sieht man einfach mehr :)

    Der Ausgabe nach scheint der X-Server selber zu funktionieren (wenn da nicht noch mehr kommt oder danach direkt wieder der Prompt erscheint).

    In der Shell mal die xinitrc ansehen - die letzte Zeile startet bei mir den quartz-wm :

    # start the window manager

    exec quartz-wm

    Könnte sein das die deinstallation des icewm nicht geklappt hat und dort versucht wird diesen zu starten - das würde zu dem geschilderten Symptom passen.

    Gruß
    Sascha
     
  6. Mauki

    Mauki Thread Starter MacUser Mitglied

    Beiträge:
    14.739
    Zustimmungen:
    138
    MacUser seit:
    24.07.2002
    mh komisch, es stand noch icewm drin. Hab da mal geändert auf folgenden Stand:

    # start some nice programs

    xterm &

    # start the window manager

    exec /sw/bin/quartz-wm

    Allerdings klappt das mit X11 immer noch nicht ? Muß ich irgendwas neu starten ?
     
  7. saki

    saki MacUser Mitglied

    Beiträge:
    335
    Zustimmungen:
    2
    MacUser seit:
    10.09.2004
    Geht denn das Termininal auf??
     
  8. Mauki

    Mauki Thread Starter MacUser Mitglied

    Beiträge:
    14.739
    Zustimmungen:
    138
    MacUser seit:
    24.07.2002
    nö, sollte es das ?

    P.S. Hast du AIM/ICQ ?
     
    Zuletzt bearbeitet: 03.01.2005
  9. saki

    saki MacUser Mitglied

    Beiträge:
    335
    Zustimmungen:
    2
    MacUser seit:
    10.09.2004
    Yep, sollte es - "xterm &".

    Hast 'ne PM wg. AIM.

    Gruß
    Sascha
     
  10. -Nuke-

    -Nuke- MacUser Mitglied

    Beiträge:
    2.135
    Zustimmungen:
    15
    MacUser seit:
    13.09.2003
    Soweit ich weiß liegt quartz-wm nicht in /sw/bin.

    Sollte in /usr/X11R6/bin liegen, oder so. Einfach mal nur mit exec quartz-wm probieren.
     
Die Seite wird geladen...
Ähnliche Themen - X11 startet stürzt
  1. bruderlos
    Antworten:
    0
    Aufrufe:
    316
    bruderlos
    10.12.2015
  2. svenbode
    Antworten:
    2
    Aufrufe:
    902
    svenbode
    17.05.2012
  3. vib
    Antworten:
    2
    Aufrufe:
    966
    promille
    19.05.2011
  4. macks
    Antworten:
    1
    Aufrufe:
    610
    macks
    30.06.2005
  5. lena-nova
    Antworten:
    3
    Aufrufe:
    414
    n0ll4k
    29.03.2005