X.4.3 - keine StartupItems?

Dieses Thema im Forum "Mac OS X - Unix & Terminal" wurde erstellt von anfo, 01.11.2005.

  1. anfo

    anfo Thread Starter MacUser Mitglied

    Beiträge:
    54
    Zustimmungen:
    0
    MacUser seit:
    16.03.2005
    Hallo, ich habe gerade auf 10.4.3 upgedated.

    Seit dem Update (habe schon mehrmals durchgestartet) werden meine Batches aus /Library/StartupItems nicht mehr geladen - gibt's hier einen Trick?

    Danke & Gruß anfo
     
  2. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    Kannst Du die StartupItems denn mit dem Kommando SystememStarter noch starten?

    Grundsätzlich würde ich ab 10.4 ohnehin dazu raten launchd zu verwenden, da StartuItems als veraltet gelten.
     
    Zuletzt bearbeitet: 01.11.2005
  3. anfo

    anfo Thread Starter MacUser Mitglied

    Beiträge:
    54
    Zustimmungen:
    0
    MacUser seit:
    16.03.2005
    Ja, per SystemStarter funktioniert es.
     
  4. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    Dann fällt mir nur noch ein, die Datei "/etc/hostconfig" zu überprüfen, ob der entsprechende Dienst (worum geht es eigentlich?) auch auf -YES- steht, vorausgesetzt, das StartupItem ist entsprechend angelegt.
     
  5. anfo

    anfo Thread Starter MacUser Mitglied

    Beiträge:
    54
    Zustimmungen:
    0
    MacUser seit:
    16.03.2005
    Sorry - alles retour (warum auch immer)!

    Nachdem nichts gestartet wurde, habe ich squid (darum gehts, übrigens ... ;-) ) als Startobjekt in Systemeinstellungen/Benutzer eingetragen, worauf squid dann nach dem 2. Reboot meldete, es laufe schon ein squid?!?!

    Wie auch immer, das Cache-Directory liegt auf einer externen Platte und seit dem Update wird diese nicht vor, sondern während/nachdem squid läuft gemounted (trotz "requires disk"-Parameter) - so sieht's im Moment aus.

    Ich lasse squid erstmal in den Systemeinstellungen als Startobjekt und habe ihn von /Library/StartupItems entfernt, werde in einer freien Minute mal einen Blick auf launchd werfen.
     
  6. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    Alternativ könntest Du in Dein StartupItem eine Schleife mit einer if Abfrage einbauen, die prüft, ob die externe Platte schon gemountet ist - wenn nicht, sleep 15 oder so.
     
  7. anfo

    anfo Thread Starter MacUser Mitglied

    Beiträge:
    54
    Zustimmungen:
    0
    MacUser seit:
    16.03.2005
    Wär auch ne möglichkeit!

    Wie ich inzwischen feststellen musste, geht nach wie vor kein automatischer deep-sleep solange squid läuft... (hab deswegen schon mal hier gepostet)
     
Die Seite wird geladen...
Ähnliche Themen - StartupItems
  1. crop
    Antworten:
    6
    Aufrufe:
    2.455

Diese Seite empfehlen