WoltlabBurning Board + MAMP = Geht nix!

Diskutiere mit über: WoltlabBurning Board + MAMP = Geht nix! im Web-Programmierung Forum

  1. Anaki

    Anaki Thread Starter MacUser Mitglied

    Beiträge:
    2.087
    Zustimmungen:
    11
    Registriert seit:
    24.04.2006
    Hallo Leute,

    Ich will gerade in MAMP die Forumsoftware Burning Board von Woltlab anpassen, habe in phpmyadmin eine neue Datenbank erstellt und alles richtig eingegeben. Das Script schreibt auch die ersten 8 Tabellen bricht dann jedoch mit folgender Meldung ab:

    Code:
    Database error in WoltLab Burning Board: Invalid SQL: CREATE TABLE bb1_object2board ( boardid mediumint(8) unsigned NOT NULL default '0', objectid int(10) unsigned NOT NULL default '0', mod tinyint(1) NOT NULL default '0', boardpermission tinyint(1) NOT NULL default '0', startpermission tinyint(1) NOT NULL default '0', replypermission tinyint(1) NOT NULL default '0', KEY boardid (boardid) ) TYPE=MyISAM; 
    mysql error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'mod tinyint(1) NOT NULL default '0', boardpermission tinyint(1) NOT NULL defa' at line 4 
    mysql error number: 1064 
    Date: 08.03.2007 @ 19:36 
    Script: /Forum/wbboard/install.php 
    Referer: http://localhost:8888/Forum/wbboard/install.php?mode=1&step=3
    Woran liegts?

    Anaki :o
     
  2. Anaki

    Anaki Thread Starter MacUser Mitglied

    Beiträge:
    2.087
    Zustimmungen:
    11
    Registriert seit:
    24.04.2006
    Kann mir da echt keiner helfen? :confused:
     
  3. wegus

    wegus MacUser Mitglied

    Beiträge:
    15.029
    Zustimmungen:
    1.314
    Registriert seit:
    13.09.2004
    Der Fehler entsteht durch:

    warum ist mir noch nicht ganz klar, da eine einfache Umbenennung ( aus mod mach mod1), hilft nehme ich an mod ist ein reserviertes Wort in mysql!
     
  4. Darii

    Darii MacUser Mitglied

    Beiträge:
    2.066
    Zustimmungen:
    110
    Registriert seit:
    24.02.2004
    Geht eigentlich problemlos. Hast du die jeweils neuste Version vom wbb und MAMP?
     
  5. Anaki

    Anaki Thread Starter MacUser Mitglied

    Beiträge:
    2.087
    Zustimmungen:
    11
    Registriert seit:
    24.04.2006
    Danke für eure Hilfe. Hat sich erübrigt, habe mir die neuste LiteVersion gezogen und alles klappt. :)
     
Die Seite wird geladen...
Ähnliche Themen - WoltlabBurning Board MAMP Forum Datum
PHP Update auf 5.6 im Terminal für Localhost (MAMP und Laravel) Web-Programmierung 12.09.2014
PHP 5.3 mit MAMP 2.1.4 Web-Programmierung 04.07.2013
composer.phar für MAMP verfügbar machen Web-Programmierung 29.11.2012
Mamp Pro Admin-Rechte permanent autorisieren Web-Programmierung 26.04.2012
Foren-Software: "phpBB" und "IP-Board" Web-Programmierung 12.02.2008

Diese Seite empfehlen

Benutzerdefinierte Suche