wieso zeigt nur opera diese site korrekt an?

Dieses Thema im Forum "Web Page Design" wurde erstellt von garraty47, 20.01.2005.

  1. garraty47

    garraty47 Thread Starter MacUser Mitglied

    Beiträge:
    545
    Zustimmungen:
    5
    MacUser seit:
    18.11.2004
    firefox verschiebt alles, safari und ie zeigen eine leere seite an
    HTML:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
        "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html lang="de">
    <head>
    <title>-=::=-</title>
    
    
    <meta http-equiv="content-type" content="text/html; charset=iso-8859-1" />
    <style type="text/css" media="screen,projection">@import url(mysite.css);</style>
    
    <style type="text/css">
    </head>
    
    <body>
    
    
    <div id="nav-menu">
    <div class="menu">
    
    <ul>
    
    <li><a href="test1.html">test1</a>
     <ul>
    
          <li><a href="#">Subitem 1</a></li>
    
          <li><a href="#">Subitem 2</a></li>
    
          <li><a href="#">Subitem 3</a></li>
    
        </ul></li>
        
    
    <li><a href="test2.html">test2</a>
     <ul>
    
          <li><a href="#">Subitem 1</a></li>
    
          <li><a href="#">Subitem 2</a></li>
    
          <li><a href="#">Subitem 3</a></li>
    
        </ul>
    
    
    </li>
    
    <li><a href="test3.html">test3</a></li>
    
    </ul>
    
    </div>
    
    
    
    </body>
    </html>
     
    Zuletzt bearbeitet: 20.01.2005
  2. Maulwurfn

    Maulwurfn MacUser Mitglied

    Beiträge:
    12.868
    Zustimmungen:
    490
    MacUser seit:
    06.06.2004
    Hast du mal versucht den <head>-Tag irgendwo zu schließen und den <body>-Tag wiederum erst mal zu öffnen, bevor du ihn schließt? ;)
     
  3. garraty47

    garraty47 Thread Starter MacUser Mitglied

    Beiträge:
    545
    Zustimmungen:
    5
    MacUser seit:
    18.11.2004
    uups. danke

    aber leider ändert das auch nix an der situation
     
  4. ?=?

    ?=? MacUser Mitglied

    Beiträge:
    941
    Zustimmungen:
    14
    MacUser seit:
    09.02.2004
    Abgesehen von Micks Diagnose: Was sagt der W3C Validator dazu?


    Gruß,

    ?=?


    edit: Bringt mit dem ursprünglichen Text 20 Fehler (wahrscheinlich viele Folgefehler, aber trotzdem ....)
     
    Zuletzt bearbeitet: 20.01.2005
  5. garraty47

    garraty47 Thread Starter MacUser Mitglied

    Beiträge:
    545
    Zustimmungen:
    5
    MacUser seit:
    18.11.2004
    das sagt er:
    Code:
    Line 13, column 6: end tag for "style" omitted, but OMITTAG NO was specified
    
    </head>
    
    You may have neglected to close a tag, or perhaps you meant to "self-close" a tag; that is, ending it with "/>" instead of ">". 
    
    ✉ 
    
    Line 11, column 0: start tag was here
    
    <style type="text/css">
    
    Line 40, column 6: end tag for "div" omitted, but OMITTAG NO was specified
    
    </body>
    
    ✉ 
    
    Line 15, column 0: start tag was here
    
    <div id="nav-menu">
     
  6. ?=?

    ?=? MacUser Mitglied

    Beiträge:
    941
    Zustimmungen:
    14
    MacUser seit:
    09.02.2004
    also frisch ans Werk und korrigieren.
    Die Meldungen versteh' sogar ich als bekennender nicht-HTMLer ;)


    Gruß,

    ?=?
     
Die Seite wird geladen...

Diese Seite empfehlen