Wie BSD-Subsystem installieren?

Dieses Thema im Forum "Mac OS X" wurde erstellt von Canadian, 07.04.2005.

  1. Canadian

    Canadian Thread Starter MacUser Mitglied

    Beiträge:
    71
    Zustimmungen:
    0
    MacUser seit:
    11.05.2004
    Hallo,

    ich will mein iBook mit dem Programm OnyX etwas entrümpeln, weil mir das empfohlen wurde. Nach der Installation kommt folgende Fehlermeldung:

    Das BSD-Subsystem ist nicht installiert...

    ... gefolgt von ...

    Um das BSD-Subsystem zu installieren, legen Sie die Mac OS X-Installations-CD ein, öffnen Sie den Ordner 'Option Installs' und klicken Sie auf das Paket 'BSD-Subsystem'.

    So weit, so gut. Nur finde ich auf keiner meiner drei mit dem iBook gelieferten Installations-CDs einen solchen Ordner "Option Installs".

    Wer kann mir weiterhelfen?

    Viele Grüße und besten Dank!
    Niklas
     
  2. tau

    tau MacUser Mitglied

    Beiträge:
    9.831
    Zustimmungen:
    185
    MacUser seit:
    06.01.2004
    Hallo,
    leg die DVD 1 ein, starte neu mit der gedrückten c taste und warte den Installer ab. Nach den Lizenzbedingungen kommt ein Fenster, auf dem rechts unten „anpassen“ steht.

    Das ist der Button, der gemeint ist.



    [edit] alternativ kannst Du auch mal das Tool „pacifist“ probieren, damit kann man die versteckten Pakete einzeln installieren.
     
    Zuletzt bearbeitet: 07.04.2005
  3. Canadian

    Canadian Thread Starter MacUser Mitglied

    Beiträge:
    71
    Zustimmungen:
    0
    MacUser seit:
    11.05.2004
    Danke. So weit komme ich. Problem ist aber, dass ich scheinbar eine komplette Neu-Installation durchführen muss, um das BSD-Subsystem zu installieren, wenn ich DVD 1 einlege, neu starte und "c" gedrückt halte. Kann ich das BSD-Subsystem auch direkt von der DVD installieren - über den Finder zum Beispiel? Ich finde es da leider nicht.
     
  4. tau

    tau MacUser Mitglied

    Beiträge:
    9.831
    Zustimmungen:
    185
    MacUser seit:
    06.01.2004
    Das wäre dann die Neuinstallation „archivieren und installieren“



    Aah ich hab mal meine DVD eingelegt:

    Der Ordner ist versteckt.

    Such mal via Apfel-f im Finder nach BSD mit der Option sichtbare und unsichtbare Dateien einblenden.

    Dann bekommst Du das BSD.pkg zu Gesicht.

    Das liegt in Installations DVD 1/System/Installation/Packages

    :cool:
     
  5. Canadian

    Canadian Thread Starter MacUser Mitglied

    Beiträge:
    71
    Zustimmungen:
    0
    MacUser seit:
    11.05.2004
    Auch mit Pacifist komme ich nicht weiter... :(

    In einem anderen Forum wird gesagt, man soll folgendes Paket öffnen:
    Install-CD/System/Installation/Packages/bsd.pkg

    Ich finde aber den ersten Ordner (weder Install-CD noch System) auf meiner Installations-CD. Und die ist ein Original von Juni 2004. Auf der gibt es leider nur folgende Ordner:

    - etc
    - tmp
    - var

    Dazu einzelne Dateien, von denen aber keine BSD.pkg ist. Wo kann ich denn einstellen, dass auch versteckte Dateien angezeigt werden sollen?


    Niklas
     
  6. tau

    tau MacUser Mitglied

    Beiträge:
    9.831
    Zustimmungen:
    185
    MacUser seit:
    06.01.2004
    Machs wie ich oben gesagt habe:

    Apfel F und diese Option mit dem +Zeichen anwählen:

    Sichtbarkeit: Sichtbare und unsichtbare Objekte.
     
  7. DopeJP

    DopeJP MacUser Mitglied

    Beiträge:
    73
    Zustimmungen:
    0
    MacUser seit:
    04.04.2005
    Ne Frage, ist damit Xcode also die Developer Tools gemeint?

    Ich hab diese Meldung nämlich nicht erhalten und hatte aber vorher XCode und Fink installiert.

    Gruß
    JP
     
  8. tau

    tau MacUser Mitglied

    Beiträge:
    9.831
    Zustimmungen:
    185
    MacUser seit:
    06.01.2004
    Nein.

    Wenn Du XCode und Fink installiert hast, dann war Dein BSD Subsystem schon drauf.
     
  9. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    JFTR
    XCode ist nur ein Bestandteil der DeveloperTools (eine IDE), der aber natürlich auf dem BSD Subsystem aufsetzt und auch von anderen DevTools abhängig ist
     
Die Seite wird geladen...

Diese Seite empfehlen