wenn dann

Diskutiere mit über: wenn dann im Office Software Forum

  1. ms510

    ms510 Thread Starter MacUser Mitglied

    Beiträge:
    431
    Zustimmungen:
    0
    Registriert seit:
    02.10.2003
    kurze frage zu excel

    zelle a hat 11 verschiedene werte(char)

    wenn funktion soll so aussehen
    wenn a=01 oder 02 oder 03 oder 04 oder 06 oder 07 dann 12 sonst 13

    mit wenn(A1=(ODER("01";.....;"07");"12";"13") geht nicht
    verschachtel schon, also

    WENN(B2="01";"12";WENN(B2="02";"12";WENN(B2="03";"12";13))) usw

    rafft excel oben das nicht oder gehts auch kürzer?
     
  2. Jabba

    Jabba MacUser Mitglied

    Beiträge:
    4.465
    Zustimmungen:
    109
    Registriert seit:
    21.11.2003
    Hai ms510,

    Erstes Problem: Excel mag 01 nicht... wenn, dann musst Du die Zelle als Text formatieren, damit Du den Wert "01" auch abfragen kannst.
    Zweites Problem:
    Du hast Die ODER Funktion falsch angewendet... muss lauten:

    =WENN(ODER(A1="01";A1="02"; etc. );"12";"13")

    Die ODER Funktion hat auch den Vorteil, dass Du 30 Bedingungen einknüpfen kannst, und zudem die Klammerorgie der WENN Funktion umgehst.

    So gehts.
    (drittes Problem: Hat sicher erledigt, da Du die Wenn Verschachtelung jetzt nicht mehr benötigst... gehen eh nur max. 7 WENNs)

    HTH
     
Die Seite wird geladen...
Ähnliche Themen - wenn dann Forum Datum
Numbers - Wenn dann Summe basierend auf String Office Software 22.09.2014
Excel Formel Wenn Feld X dann Feld Y Office Software 18.07.2013
Numbers, Reisekostenberechnung, Wenn "Wahr" dann, ....... Office Software 19.07.2011
Excel 2008 | Wenn Dann Funktion Office Software 03.11.2009
EXCEL: Wenn, dann Office Software 19.03.2007

Diese Seite empfehlen

Benutzerdefinierte Suche