warum kann ich keine debian 3.0 cd booten ?

Dieses Thema im Forum "Linux auf dem Mac" wurde erstellt von und3r, 15.07.2004.

  1. und3r

    und3r Thread Starter MacUser Mitglied

    Beiträge:
    22
    Zustimmungen:
    0
    MacUser seit:
    08.01.2004
    hi,

    hab ein ibook g4,

    die debian cd hab ich mir bei linuxiso.org und eine direkt bei debian gezogen, natürlich für die ppc architektur, nun habe ich das iso mit Toast gebrannt. Die cd eingelegt und die taste "c" beim booten gedrückt, doch nichts passiert, warum ? brauch ich irgendwelche "speziellen isos" oder mach ich was anderes falsch.. das cd/dvd laufwerk funktionniert, hab die apple cd mal zum testen eingelegt,

    bitte helft mir, danke
     
  2. cla

    cla MacUser Mitglied

    Beiträge:
    2.958
    Zustimmungen:
    128
    MacUser seit:
    24.10.2003
    Kannst du denn auf die gebrannte CD im Finder zugreifen, und sind dort viele Dateien und Verzeichnisse vorhanden?
     
  3. kermit

    kermit MacUser Mitglied

    Beiträge:
    997
    Zustimmungen:
    28
    MacUser seit:
    26.05.2003
    Hast du vielleicht das iso File als Datei und
    nicht als Image gebrannt?

    kermit
     
  4. und3r

    und3r Thread Starter MacUser Mitglied

    Beiträge:
    22
    Zustimmungen:
    0
    MacUser seit:
    08.01.2004
    hab das prooblem in den griff bekommen, lag einfach nur an der rohling, aber jez hab ich auch schon das nächste:

    den benh (2.4.25-ben1) kernel hab ich genau nach anleitung der ct' kompiliert, alles funktioniert wunderbar, nur meine wunderbare airport karte nicht. beim booten kommt folgendes:

    -------------------
    airport /lib/modules/2.4.25-ben1/kernel/drivers/net/wireless/airport.o: init_module: No such device
    Hint: insmod error can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
    /lib/modules/2.4.25-ben1/kernel/drivers/net/wireless/airport.o: insmod airport failed
    -------------------

    das module hab ich selbstverständlich in /etc/modules eingetragen und als modul installiert, die datei airport.o ist auch vorhanden.

    und in diesem benh kernel sollen doch meine tasten vom Ibook funktionnieren, davon merk ich leider wenig, muss ich das noch irgendwie aktvieren ?

    wäre wirlich dankbar für eure hilfe, danke
     
  5. moongate

    moongate MacUser Mitglied

    Beiträge:
    206
    Zustimmungen:
    0
    MacUser seit:
    02.03.2004
    Wenn es sich um die Airport Extreme Karte handelt, kannst du es leider vergessen. Es gibt immer noch keine Treiber dafür, da Broadcom weder Quellcode noch Spezifikationen rausrückt. Abgesehen davon würde ich zum neusten 2.6er Kernel raten, da dieser das G4-iBook am Besten unterstützt.
     
  6. und3r

    und3r Thread Starter MacUser Mitglied

    Beiträge:
    22
    Zustimmungen:
    0
    MacUser seit:
    08.01.2004
    ne, oder ? und die normale airportkarte "ohne extrem" wird unterstüzt ? kann ich die auch in mein ibook bauen oder ist das neue g4 nur für extrem gebaut ?

    welchen kernel soll ich nun nehmen ? meinst du den benh2.6er oder den "normalen2.6er" wäre für link dankbar,


    nochmals danke für eure hilfe, echt nen super forum
     
  7. moongate

    moongate MacUser Mitglied

    Beiträge:
    206
    Zustimmungen:
    0
    MacUser seit:
    02.03.2004
    Doch, leider. Hab auch Debian drauf und hab nen USB-WLAN-Stick trotz eingebauter Airport Extreme. Nein, die Airport kannste leider nicht ins G4 einbauen. Hätte ich sonst auch getan (ist billiger und Linux-kompatibel).
    Nimm den neusten normalen "Vanilla"-Kernel von kernel.org. Seit der Version 2.6.x (weiß leider nicht mehr genau) sind die benh-Patches mit im Standard-Kernel drin.
    Kannste alles in der zur Zeit besten iBook-G4-Debian-Anleitung nachlesen: link

    Gruß,
    moongate
     
  8. und3r

    und3r Thread Starter MacUser Mitglied

    Beiträge:
    22
    Zustimmungen:
    0
    MacUser seit:
    08.01.2004
    oke, hab noch ein paar usb wlan adapter rumfliegen ( mit prism chipsatz ), funktionieren die auch aufwandfrei oder muss ich mir da was spezielles zulegen ?

    ich wäre dir seh dankbar wenn du mir mal deine x86config hier posten würdest, da ich noch ein paar lcd probleme habe (es flimmert ein wenig), danke

    mfg. manuel
     
  9. CapFuture

    CapFuture MacUser Mitglied

    Beiträge:
    1.777
    Zustimmungen:
    1
    MacUser seit:
    23.01.2004
    Schau doch mal bei der Gentoo Distro vorbei... könntest dort vielleicht mehr glück haben als mit Debian...
     
  10. moongate

    moongate MacUser Mitglied

    Beiträge:
    206
    Zustimmungen:
    0
    MacUser seit:
    02.03.2004
    Ich hab den D-Link DWL-122 am Laufen, welcher wunderbar funtioniert und auch den Prism2-Chipsatz hat. Anleitung: link


    Hier ne XF86Config:

    Section "ServerLayout"
    Identifier "XFree86 Configured"
    Screen 0 "Screen0" 0 0
    InputDevice "Mouse0" "CorePointer"
    InputDevice "Keyboard0" "CoreKeyboard"
    EndSection

    Section "Files"
    RgbPath "/usr/X11R6/lib/X11/rgb"
    ModulePath "/usr/X11R6/lib/modules"
    FontPath "/usr/X11R6/lib/X11/fonts/truetype"
    FontPath "/usr/X11R6/lib/X11/fonts/misc/"
    FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
    FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
    FontPath "/usr/X11R6/lib/X11/fonts/CID/"
    FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
    FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
    EndSection

    Section "Module"
    Load "extmod"
    Load "dri"
    Load "dbe"
    Load "record"
    Load "xtrap"
    Load "glx"
    Load "speedo"
    Load "type1"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "keyboard"
    Option "XkbLayout" "macintosh/de_new"
    EndSection

    Section "InputDevice"
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "IMPS/2"
    Option "ZAxisMapping" "6 5"
    Option "Device" "/dev/input/mice"
    EndSection

    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Monitor Vendor"
    ModelName "Monitor Model"
    UseModes "Modes0"
    #HorizSync 30-70
    #VertRefresh 50-160
    EndSection

    Section "Device"
    ### Available Driver options are:-
    ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
    ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
    ### [arg]: arg optional
    Identifier "Card0"
    Driver "radeon"
    VendorName "ATI Technologies Inc"
    BoardName "Radeon 9200 Mobility"
    Option "UseFBDev"
    Option "AGPMode" "4"
    Option "EnablePageFlip" "On"
    ChipID 0x514d
    Option "CloneMode" "1024x768"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Card0"
    Monitor "Monitor0"
    DefaultDepth 16
    SubSection "Display"
    Depth 1
    Modes "1024x768" "640x480" "800x600"
    EndSubSection
    SubSection "Display"
    Depth 4
    Modes "1024x768" "640x480" "800x600"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1024x768" "640x480" "800x600"
    EndSubSection
    SubSection "Display"
    Depth 15
    Modes "1024x768" "640x480" "800x600"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1024x768" "640x480" "800x600"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1024x768" "640x480" "800x600"
    EndSubSection
    EndSection

    Section "DRI"
    Mode 0666
    EndSection

    Section "Modes"
    Identifier "Modes0"
    # mode generated by Xeasyconf
    #Modeline "1024x768" 100.000 1024 1040 1048 1064 768 784 792 808 -HSync -VSync
    Modeline "1024x768" 75.000 1024 1040 1048 1064 768 784 792 808 -HSync -VSync
    EndSection
     

Diese Seite empfehlen