Vi / Vim und Pfeiltasten - geht nix?

Dieses Thema im Forum "Mac OS X - Unix & Terminal" wurde erstellt von ForceFox, 26.08.2004.

  1. ForceFox

    ForceFox Thread Starter MacUser Mitglied

    Beiträge:
    145
    Zustimmungen:
    0
    MacUser seit:
    18.03.2004
    Hiho;

    habe heute versucht, mit vim kurz ein paar Seiten Quellcode einer html-Datei zu ändern. Was mir dabei auffiel, war, daß ich mit den Pfeiltasten nicht nach unten im Text steuern konnte. Ich konnte nur Zeichenweise nach rechts/links durch den Text navigieren, was ziemlich nervig war.

    (Command war "vi Datei.html", woraufhin ich offenbar in VIM gelandet bin.)

    Von der SSH-console kenne ich das so, daß man mit den Pfeiltasten den Cursor beliebig durch die Gegend manövrieren kann.

    Kann mir jemand was dazu sagen?

    Tx und Gruß, FF
     
  2. canfAN

    canfAN MacUser Mitglied

    Beiträge:
    66
    Zustimmungen:
    0
    MacUser seit:
    06.02.2003
    Standardmäßig navigiert man im VIM mit h(links), j(runter), k(hoch), l(rechts).
     
  3. ente

    ente MacUser Mitglied

    Beiträge:
    243
    Zustimmungen:
    2
    MacUser seit:
    19.07.2004
    man vim -> informationen ohne ende ;)
     
  4. ForceFox

    ForceFox Thread Starter MacUser Mitglied

    Beiträge:
    145
    Zustimmungen:
    0
    MacUser seit:
    18.03.2004
    Dankeschön, werd ich gleich mal testen :)

    Das Problem an "man vim" ist in der Tat, daß es Informationen OHNE ENDE gibt :D Dennoch gute Idee, hätte ich auch mal dran denken können.

    Gruß FF

    Edit: H und L für Links und Rechts funzt, aber J und K für Rauf und Runter nicht. :(

    Und man vim hat beim ersten durchschauen auch nichts parat über die Navigation in der Datei, nur über die Parameter wie -r etc.
     
  5. chrisb101

    chrisb101 MacUser Mitglied

    Beiträge:
    264
    Zustimmungen:
    5
    MacUser seit:
    02.04.2003
  6. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    Bei mir funktionieren auch die Pfeiltasten zur Navigation im vim.
    allerdings nur solange bis ich aus Versehen "ctrl-R" oder so was ähnliche enigebe. Dann erscheinen nur noch komische zeichen mit eckigen Klammern in der "last-line". Ich starte dann den vim neu und alles ist wieder gut.

    Eine IMHO sehr gute und relativ knappe Einführung in den vim (mit vielen sehr guten Erläuterungen zu den Navigationshilfen) bietet auch das Kommando "vimtutor"
     
  7. ForceFox

    ForceFox Thread Starter MacUser Mitglied

    Beiträge:
    145
    Zustimmungen:
    0
    MacUser seit:
    18.03.2004
    Also ich kapier es nicht, ich habe auch brav im vimtutor nachgeschaut, da steht es ja gleich explizit: "J" für runter und "K" für rauf. Funzt auch im vimtutor!

    Aber wenn ich "vi text.txt" mache, dann kann ich weder im INSERT Modus, noch im NORMAL Modus mit J und K navigieren.

    Muß ich vielleicht "vim text.txt" eingeben statt "vi text.txt" ???

    Danke für die Tips soweit schonmal! Gruß FF
     
  8. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    Nein, daran kann es nicht liegen, da vi nur ein Standard-alias für vim ist.

    Dass die Pfeiltasten funktionieren ist keine Standardfunktion des vi bzw. vim, sondern wird afair irgendwo in den Konfigurationsdateien eingestellt; ich weiss aber nicht wo.

    Auf welchem System arbeitest Du eigentlich ?; hast Du die config-Dateien irgendwie geändert ?
     
  9. ForceFox

    ForceFox Thread Starter MacUser Mitglied

    Beiträge:
    145
    Zustimmungen:
    0
    MacUser seit:
    18.03.2004
    Ich habe OSX 10.3.5 laufen - habe an den configs nicht geschraubt. Witzigerweise funktionieren ja H un L für links und Rechts, nur rauf und runter geht nicht.

    :noIdea:

    Gruß FF
     
  10. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    Gut, dass Du den Humor noch nicht verloren hast.
    Hast Du schon mal versucht, den vim mit einem anderen Benutzer zu testen?
    Falls das auch nicht hilft, könnte ich Dir anbieten meine config-Datei zu senden; ob´s was bringt weiss ich nicht, aber einen Versuch wäre es Wert (vielleicht ist ja doch irgendwas beschädigt worden)
     
Die Seite wird geladen...