Umlaute von übertragenen Dateien

Dieses Thema im Forum "Mac OS X" wurde erstellt von Fritzek, 07.08.2006.

  1. Fritzek

    Fritzek Thread Starter MacUser Mitglied

    Beiträge:
    33
    Zustimmungen:
    0
    MacUser seit:
    07.02.2006
    Hallo
    wenn ich per FTP Textdateien auf den Mac übertrage (ASCII) und sie mit z.B. SubEtha bearbeite, gehen mir die Umlaute und Sonderzeichen flöten. Gleiches passiert auch, wenn ich im Terminal mich per Telnet auf eine UNIX-Büchse verbinde und dort direkt eine Textdatei bearbeite. D.h. irgendwie laufen mir die Zeichensätze auseinander. Wie kann ich das synchronisieren oder was muss ich machen, dass ein Text auch so dort ankommt, wie ich ihn geschrieben habe?
    Danke im Voraus
     
  2. joachim14

    joachim14 MacUser Mitglied

    Beiträge:
    7.295
    Zustimmungen:
    433
    MacUser seit:
    08.02.2005
    Entweder nur Zeichen bis ASCII 128 benutzen oder mit Programmen weitergeben, die verschiedene Plattformen unterstützen und die unterschiedlichen Kodierung anpassen.
     
  3. Thorne^

    Thorne^ MacUser Mitglied

    Beiträge:
    2.616
    Zustimmungen:
    49
    MacUser seit:
    31.05.2004
    Hallo

    Ich gehe davon aus das die ASCII Texte auf einem Windows PC erstellt wurden, vermutlich mit Notepad.
    Mit dem Shareware Programm Ultraedit müsste man das vermeiden können.
    In den Einstellungen kann man festlegen ob neue Dateien im DOS, Unix oder Mac Format angelegt werden.

    Für Umlaute im Terminal habe ich in einem anderen Forum folgenden Tipp gelesen:

    Du musst in deinem Home-Verzeichnis die Datei .inputrc mit den folgenden drei Zeilen anlegen, dazu bietet sich Pico an (Terminal öffnen und so eingeben: pico .inputrc

    Nun folgenden Text eingeben und im Anschluss mit der Tastenkombi ctrl+o speichern, dann mit ctrl+x Pico beenden.

    set meta-flag on
    set convert-meta off
    set output-meta on

    Dann das aktive Terminal Fenster schliessen und ein neues öffnen, in dem sollten dann auch Umlaute erscheinen.
    Ob das auch bei Telnet Verbindungen hilfreich ist, bezweifle ich jedoch. Umlaute im Terminal und in Telnet sind
    unter Unix/Linux unüblich.
     
  4. oneOeight

    oneOeight MacUser Mitglied

    Beiträge:
    46.804
    Zustimmungen:
    3.632
    MacUser seit:
    23.11.2004
    übertrag doch mal binär und guck, ob die umlaute dann erhalten bleiben ;)
     
  5. Fritzek

    Fritzek Thread Starter MacUser Mitglied

    Beiträge:
    33
    Zustimmungen:
    0
    MacUser seit:
    07.02.2006
    @joachim14
    nur us-ascii-7 lässt sich in D mit deutschen Kunden nicht durchhalten - was Scripts betrifft ja, aber die Kommentare nicht immer.
    @Thorne^
    nein, der Text ist nicht mit notepad erstellt, neben ultraedit gibt es auch noch andere win editoren, die richtig arbeiten können (z.B. TextPad)
    die von dir angesprochenen SystemProbleme betreffen in der Regel nur CRLF
    die Sache mit der .inputrc habe ich auch ausprobiert - wirkt sich (wie vermutet) nur auf Terminal und nicht auf telnet aus
    @oneOeight
    binär übertragen kommen nur die ASCII-Codes rüber (zumindest ist der Rücktransfer dann auch sauber und ich sehe die Umlaute wieder)

    Alle Versuch, mit den verschiedenen Zeichensätzen zu arbeiten oder Terminal-Typen einzustellen, waren erfolglos (jedenfalls wenn der UNIX-Server mit 'nem ISO Zeichensatz läuft; wenn der Server auf UTF eingestellt ist, funktioniert es halbwegs, aber darauf habe ich keinen Einfluss)

    Danke trotzdem allen, die geholfen haben

    PS: mich wurmt es trotzdem, dass das mit mit 'nem Win-Rechner problemloser funktioniert :-(
     
Die Seite wird geladen...

Diese Seite empfehlen