Umlaute falsch in iWeb

Dieses Thema im Forum "Web-Editoren" wurde erstellt von Froschkönig, 01.04.2006.

  1. Froschkönig

    Froschkönig Thread Starter MacUser Mitglied

    Beiträge:
    163
    Zustimmungen:
    0
    MacUser seit:
    05.01.2005
    Hallo,

    habe ruckzuck eine paar Web-Seiten mit Hilfe von iWeb gebastelt und bin mit dem Ergebnis auch zufrieden, aber wenn man sie mit einem PC anschaut, fehlen die Umlaute und das Esszett in den Texten (kurioserweise nicht in den Headlines).
    Wie also bekomme ich Umlaute in iWeb so hin, dass sie ein/e Win-UserIn ansehen kann?

    TIA!

    Froschkini
     
  2. randolph34

    randolph34 MacUser Mitglied

    Beiträge:
    281
    Zustimmungen:
    26
    MacUser seit:
    20.07.2005
    Heya!

    Ich hatte das gleiche Problem, hab's aber vorhin hingekriegt.

    Ich veröffentliche mein iWeb nicht bei .mac, sondern hab bei einem Freund ein bisschen Webspace gekriegt. Herbei handelt es sich wohl um einen Linux-Server, der eine andere Zeichencodierung eingestellt hat.

    Man muss nur eine .htaccess Datei ins Hauptverzeichnis seines Webspaces legen, die dann bestimmt, dass die Website in UTF-8 codiert ist. Die .htaccess Datei beeinhaltet nur folgende Line:
    AddDefaultCharset utf-8

    Also einfach eine Textdatei erstellen, ohne txt-Endung mit dem Namen "htaccess". Den Punkt musst du erst nachher hinmachen, da die Datei sonst als Systemdatei erkannt wird und nicht mehr sichtbar ist.
    Die Datei dann per FTP hochladen, Punkt vorne dran setzen und schon funzt alles.

    Du kannst auch die angehängte Datei verwenden.

    Die Quellen:


    Hoffentlich funktioniert's bei dir auch.

    Grüße Randolph
     
  3. kleinerBaum

    kleinerBaum MacUser Mitglied

    Beiträge:
    1
    Zustimmungen:
    0
    MacUser seit:
    12.02.2006
    Hallo Froschkönig,
    ich hatte das gleiche Problem - allerdings nicht in allen Textfeldern. Nun habe ich festgestellt, dass das Problem nur auftaucht, wenn die Ausrichtung für das Textfeld auf "oben" eingestellt ist, außerdem ist die Schrift dann auch etwas fetter. Bei Ausrichtung nach "unten" verschwinden beide Probleme. Ich nehme an, das ist ein Bug im Programm.

    Vielleicht bringt dich das weiter?

    kleinerBaum
     
  4. Difool

    Difool Frontend Admin

    Beiträge:
    8.154
    Medien:
    29
    Zustimmungen:
    859
    MacUser seit:
    18.03.2004
    ...ich schieb den Thread mal in Web-Editoren. :)
     
  5. JazzmanBlue

    JazzmanBlue MacUser Mitglied

    Beiträge:
    281
    Zustimmungen:
    3
    MacUser seit:
    24.03.2004
    Ich kann das bestätigen, aber mich nervt das ziemlich, da der Text standardmäßig oben ausgerichtet ist. Ist das denn bei jedem so? Gibt es da irgendwie Abhilfe?
     
  6. JazzmanBlue

    JazzmanBlue MacUser Mitglied

    Beiträge:
    281
    Zustimmungen:
    3
    MacUser seit:
    24.03.2004
    Ich weiß jetzt, warum sich das Problem löst, wenn man die Ausrichtung ändert, gleichzeitig wird nämlich der Text als Grafik umgewandelt, was ja auch viele Leute an iWeb bemängeln. Und logischerweise gibt es natürlich bei der Grafik dann keine Probleme mit der Zeichencodierung. Aber alles was auch als Text im HTML-Code gekennzeichnet ist, wird auch weiterhin die bekannten Probleme aufweisen.
    Dass die Schrift etwas fetter wird, liegt daran, dass bei der Umwandlung in Grafik die Schriftglättung von Quarz angewandt wird, und wenn der Text vom jeweiligen Browser generiert wird, sieht es logischerweise immer anders aus, je nachdem, wie die Schriftglättung auf dem Anzeigesystem eingestellt ist und was man für einen Browser benutz.
     
  7. simmie

    simmie MacUser Mitglied

    Beiträge:
    826
    Zustimmungen:
    2
    MacUser seit:
    18.11.2005

    Das hat mir ehrlich gesagt nicht geholfen.... --> www.simon-waldbroel.de.vu
     
  8. JazzmanBlue

    JazzmanBlue MacUser Mitglied

    Beiträge:
    281
    Zustimmungen:
    3
    MacUser seit:
    24.03.2004
    Ich weiß woran es liegt, iWeb ist nicht der Fehler, es verhält sich nur etwas komisch sobald man die Textausrichtung ändert, denn dann Wird der Text entweder als reiner Text oder als Grafik gespeichert. Eine .htaccess-Datei im Hosting-Verzeichnis kann helfen, muss aber nicht, es liegt nämlich schlicht und einfach an der Art des Webspace. Mein Vater hatte wenig Webspace bei seinem Internetanbieter, er hatte genau das gleiche Problem, auch die .htaccess hat nichts geholfen, der Provider wollte und konnte daran auch nicht ändern. Bei meinem Provider hatte ich schließlich das gleiche Problem, auch .htaccess angelegt und es hat nichts geholfen. Dann habe ich aber beim Provider angerufen und nachgefragt ob er den Webspace bitte auf UTF8 umstellen könnte, das haben sie gemacht. Und siehe da, plötzlich befand sich eine .htaccess-Datei auf meinem Webspace, von meinem Provider dort abgelegt. Nachdem ich dann aber Probleme mit Webseitenmaterial von einem anderen Webeditor hatte, habe ich mit der htaccess rumgespielt, sie kurz entfernt und wieder hingetan und plötzlich hat es nicht mehr funktioniergt, offenbar hatte nur der Provider ordnungsgemäßen Zugriff auf die Datei. Er hat es zwar verneint und sagte, dass ich die Datei auch selber anpassen könnte, aber es wollte absolut nicht funktionieren.
    Irgendwann hat es mir gereicht und ich habe mir für etwa 10 Euro 100 MB Webspace bei Alfahosting gekauft und siehe da, alles funktioniert und das sogar ohne .htaccess, trotzdem kann ich mit der Datei alles machen, wofür man sie sonst noch verwenden kann. Also liegt es definitiv am Server, offensichtlich sind die Server für diesen kostenlosen Webspace für die Internet-Kunden irgendwie komisch, anders kann ich es mir nicht erklären. Probiert es mal aus, wie gesagt bei Alfahosting habe ich absolut keine Probleme, sowohl mit iWeb-Seite als au8ch alles andere, egal welche Zeichenkodierung.
     

Diese Seite empfehlen