Tomcat Web Application Manager startet nicht: (/manager/html/ was not found)

Dieses Thema im Forum "Web-Programmierung" wurde erstellt von mgeisser, 01.06.2006.

  1. mgeisser

    mgeisser Thread Starter MacUser Mitglied

    Beiträge:
    12
    Zustimmungen:
    0
    MacUser seit:
    01.06.2006
    Hallo,
    ich habe den Apache web server bei mir (OS-X 10.3.9) laufen und er funktioniert auch, wie ich auf http://localhost/ sehe.

    Jetzt habe ich gelesen, dass der Tomcat Web Application Manager mit http://localhost/manager/html/ aufgerufen werden kann. Ich bekomm dann aber nur ne Fehlermeldung: "Not Found -- The requested URL /manager/html/ was not found on this server."

    Auch mit Portangabe, also http://localhost:80/manager/html/, geht es nicht. Und bei http://127.0.0.1/manager/html/ kommt auch die gleiche Fehlermeldung.

    Kann mir jemand sagen, ob ich den Tomcat Web Application Manager erst noch irgendwo installieren/aktivieren/konfigurieren muss?

    Vielen Dank schon mal,
    Michael
     
  2. gishmo

    gishmo MacUser Mitglied

    Beiträge:
    812
    Zustimmungen:
    23
    MacUser seit:
    16.03.2004
  3. mgeisser

    mgeisser Thread Starter MacUser Mitglied

    Beiträge:
    12
    Zustimmungen:
    0
    MacUser seit:
    01.06.2006
    bin weiter, aber noch nicht am ziel...

    danke für die antwort!
    habe den tomcat jetzt installiert, davor nur den web server...
    jetzt komm ich auch auf die seite
    [DLMURL]http://127.0.0.1:8080/[/DLMURL]

    wenn ich aber auf den manager gehe ([DLMURL]http://127.0.0.1:8080/manager/html)[/DLMURL], und als user 'tomcat' sowie als passwort 'tomcat' eingebe, bekomme ich folgende fehlermeldung:

    ============================
    HTTP Status 403 - Access to the requested resource has been denied

    type: Status
    report: message Access to the requested resource has been denied
    description: Access to the specified resource (Access to the requested resource has been denied) has been forbidden.

    Apache Tomcat/5.5.17
    ============================

    meine tomcat-users.xml schaut so aus:

    <?xml version='1.0' encoding='utf-8'?>
    <tomcat-users>
    <role rolename="tomcat"/>
    <role rolename="role1"/>
    <role rolename="manager"/>
    <role rolename="admin"/>
    <user username="tomcat" password="tomcat" roles="tomcat"/>
    <user username="both" password="tomcat" roles="tomcat,role1"/>
    <user username="role1" password="tomcat" roles="role1"/>
    <user username="admin" password="admin" roles="manager,admin"/>
    </tomcat-users>


    Kannst Du (oder jemand anderes) mir sagen, woran das liegt?

    Schon mal Danke,
    Michael
     
  4. mgeisser

    mgeisser Thread Starter MacUser Mitglied

    Beiträge:
    12
    Zustimmungen:
    0
    MacUser seit:
    01.06.2006
    lösung gefunden

    It would be quite unsafe to ship Tomcat with default settings that allowed anyone on the Internet to execute the Manager application on your server. Therefore, the Manager application is shipped with the requirement that anyone who attempts to use it must authenticate themselves, using a username and password that have the role manager associated with them. Further, there is no username in the default users file ($CATALINA_HOME/conf/tomcat-users.xml) that is assigned this role. Therefore, access to the Manager application is completely disabled by default.

    To enable access to the Manager web application, you must either create a new username/password combination and associate the role name manager with it, or add the manager role to some existing username/password combination.


    (aus der Tomcat-Doku)
     
  5. mgeisser

    mgeisser Thread Starter MacUser Mitglied

    Beiträge:
    12
    Zustimmungen:
    0
    MacUser seit:
    01.06.2006
    ach scheiße...

    ach scheiße... ich dachte, das wär die lösung... aber ne, es funktioniert bei mir nicht.

    meine tomcat-users.xml schaut so aus:
    <?xml version='1.0' encoding='utf-8'?>
    <tomcat-users>
    <role rolename="tomcat"/>
    <role rolename="role1"/>
    <role rolename="manager"/>
    <role rolename="admin"/>
    <user username="tomcat" password="tomcat" roles="tomcat"/>
    <user username="role1" password="tomcat" roles="role1"/>
    <user username="both" password="tomcat" roles="tomcat,role1"/>
    <user username="test" password="123" roles="manager"/>
    <user username="admin" password="admin" roles="manager,admin"/>
    </tomcat-users>

    aber ich kann mich bei [DLMURL]http://127.0.0.1:8080/manager/html[/DLMURL] mit dem user 'test' und dem passwort '123' nicht anmelden :-(

    ich bin schon fast am verzweifeln, kann doch nicht so schwer sein?!?

    kann mir bitte noch mal jemand auf die sprünge helfen?
     
  6. mgeisser

    mgeisser Thread Starter MacUser Mitglied

    Beiträge:
    12
    Zustimmungen:
    0
    MacUser seit:
    01.06.2006
    habe eben herausgefunden, dass sich der admin anmelden kann. nur der test-user noch nicht... weiß jemand, warum?
     
Die Seite wird geladen...
Ähnliche Themen - Tomcat Web Application
  1. KennyZorro
    Antworten:
    3
    Aufrufe:
    857
    KennyZorro
    11.03.2013
  2. Jakob
    Antworten:
    3
    Aufrufe:
    1.199
    Jakob
    04.02.2008
  3. bleistift6B

    apache tomcat

    bleistift6B, 01.10.2007, im Forum: Web-Programmierung
    Antworten:
    7
    Aufrufe:
    1.101
    Sojus
    04.10.2007
  4. nazih
    Antworten:
    2
    Aufrufe:
    839
    wegus
    31.05.2007
  5. Michelle84
    Antworten:
    0
    Aufrufe:
    510
    Michelle84
    24.04.2007