Tastaturprobleme MAC -> SSH -> OpenSuse 10.0

Dieses Thema im Forum "Mac OS X - Unix & Terminal" wurde erstellt von svenloth, 13.11.2006.

  1. svenloth

    svenloth Thread Starter MacUser Mitglied

    Beiträge:
    167
    Zustimmungen:
    0
    MacUser seit:
    17.09.2004
    Guten Morgen!

    Wenn ich mich im iTerm oder Terminal per SSH auf ne OpenSuse 10.0 Möhre einlogge, dann geht im Yast die Shift-Taste, Backspace und alt nicht.

    Das ist natürlich ganz doof, weil ich mich schonmal gern vertipp und auch die Shortcuts in yast benutzen will.

    Hat jemand ne Ahnung was das wieder sein könnte? Hier mal das env vom Server:

    Code:
    LESSKEY=/etc/lesskey.bin
    NNTPSERVER=news
    INFODIR=/usr/local/info:/usr/share/info:/usr/info
    MANPATH=/usr/share/man:/usr/local/man:/usr/X11R6/man:/opt/gnome/share/man
    HOSTNAME=h1079863
    GNOME2_PATH=/usr/local:/opt/gnome:/usr
    XKEYSYMDB=/usr/X11R6/lib/X11/XKeysymDB
    HOST=h1079863
    TERM=vt100
    SHELL=/bin/bash
    PROFILEREAD=true
    HISTSIZE=1000
    SSH_CLIENT=86.62.210.134 50168 22
    SSH_TTY=/dev/pts/1
    GROFF_NO_SGR=yes
    USER=root
    LS_COLORS=no=00:fi=00:di=01;34:ln=00;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31:ex=00;32:*.cmd=00;32:*.exe=01;32:*.com=01;32:*.bat=01;32:*.btm=01;32:*.dll=01;32:*.tar=00;31:*.tbz=00;31:*.tgz=00;31:*.rpm=00;31:*.deb=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.zip=00;31:*.zoo=00;31:*.z=00;31:*.Z=00;31:*.gz=00;31:*.bz2=00;31:*.tb2=00;31:*.tz2=00;31:*.tbz2=00;31:*.avi=01;35:*.bmp=01;35:*.fli=01;35:*.gif=01;35:*.jpg=01;35:*.jpeg=01;35:*.mng=01;35:*.mov=01;35:*.mpg=01;35:*.pcx=01;35:*.pbm=01;35:*.pgm=01;35:*.png=01;35:*.ppm=01;35:*.tga=01;35:*.tif=01;35:*.xbm=01;35:*.xpm=01;35:*.dl=01;35:*.gl=01;35:*.wmv=01;35:*.aiff=00;32:*.au=00;32:*.mid=00;32:*.mp3=00;32:*.ogg=00;32:*.voc=00;32:*.wav=00;32:
    XNLSPATH=/usr/X11R6/lib/X11/nls
    HOSTTYPE=i386
    FROM_HEADER=
    PAGER=less
    XDG_CONFIG_DIRS=/usr/local/etc/xdg/:/etc/xdg/:/etc/opt/gnome/xdg/
    MINICOM=-c on
    MAIL=/var/mail/root
    PATH=/sbin:/usr/sbin:/usr/local/sbin:/opt/gnome/sbin:/root/bin:/usr/local/bin:/usr/bin:/usr/X11R6/bin:/bin:/usr/games:/opt/gnome/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin
    CPU=i686
    INPUTRC=/etc/inputrc
    PWD=/root
    LANG=POSIX
    TEXINPUTS=:/root/.TeX:/usr/share/doc/.TeX:/usr/doc/.TeX
    SHLVL=1
    HOME=/root
    LESS_ADVANCED_PREPROCESSOR=no
    OSTYPE=linux
    LS_OPTIONS=-a -N --color=tty -T 0
    WINDOWMANAGER=
    LESS=-M -I
    MACHTYPE=i686-suse-linux
    LOGNAME=root
    XDG_DATA_DIRS=/usr/local/share/:/usr/share/:/etc/opt/kde3/share/:/opt/kde3/share/:/opt/gnome/share/
    LC_CTYPE=de_DE.UTF-8
    ACLOCAL_FLAGS=-I /opt/gnome/share/aclocal
    SSH_CONNECTION=86.62.210.134 50168 85.214.41.72 22
    PKG_CONFIG_PATH=/opt/gnome/lib/pkgconfig:/opt/gnome/share/pkgconfig
    LESSOPEN=lessopen.sh %s
    INFOPATH=/usr/local/info:/usr/share/info:/usr/info:/opt/gnome/share/info
    LESSCLOSE=lessclose.sh %s %s
    G_BROKEN_FILENAMES=1
    COLORTERM=1
    _=/usr/bin/env
    Vielen Dank schonmal!

    Sven
     
  2. H3x

    H3x MacUser Mitglied

    Beiträge:
    305
    Zustimmungen:
    20
    MacUser seit:
    12.11.2006
    Morgen!

    Ich habe hier zwar Debain, aber die genannten Tasten funktionieren in curses.
    Bei mir steht da "TERM=xterm-color", wäre ja einen Versuch wert.
    Ach ja, ich würde mich nicht als root einloggen, sondern lieber mit su/sudo arbeiten.

    H3x
     
Die Seite wird geladen...

Diese Seite empfehlen