swat / xinit.d

Diskutiere mit über: swat / xinit.d im Mac OS X - Unix & Terminal Forum

  1. ingo_72

    ingo_72 Thread Starter MacUser Mitglied

    Beiträge:
    1
    Zustimmungen:
    0
    Registriert seit:
    20.02.2005
    Hallo,
    ich habe seit dem letzten Update (10.3.8) ein Problem mit SWAT / bzw. mit xinet.d

    Folgende Konfiguration wurde/wird genutzt:

    /etc/xinetd.d/swat

    service swat
    {
    port = 901
    socket_type = stream
    wait = no
    only_from = localhost
    user = root
    server = /usr/sbin/swat
    log_on_failure += USERID
    groups = yes
    disable = no
    }


    /etc/services

    #smpnameres 901/udp # SMPNAMERES
    #smpnameres 901/tcp # SMPNAMERES
    swat 901/tcp # SWAT fuer Samba

    Zum Abschluss wurde xinetd.d beendet und neu gestartet. Wenn ich swat nutzten möchte erhalte ich nur >>user oder password incorrect<<.

    Grüße und Danke für die Hilfe

    Ingo
     
    Zuletzt bearbeitet: 20.02.2005
  2. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    Registriert seit:
    24.09.2003
    Erstmal: Willkommen bei MacUser!

    SWAT funktioniert AFAIK nur mit aktiviertem root account und als Benutzer 'root'
     
  3. glotis

    glotis MacUser Mitglied

    Beiträge:
    553
    Zustimmungen:
    7
    Registriert seit:
    18.05.2004
    Hi
    hier noch was zum Thema.
     
  4. KoppC

    KoppC MacUser Mitglied

    Beiträge:
    34
    Zustimmungen:
    0
    Registriert seit:
    07.01.2004
    hallo,

    ich habe genau diese eintäge vorgenommen und auch der root-user ist aktiviert, wenn ich jetzt allerdings den namen und das kennwort im browser eingebe dann bekomme ich immer die meldung "kennwort oder name ist nicht korrekt".

    kann mir jemand helfen

    gruß
    koppc
     
  5. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    Registriert seit:
    24.09.2003
    Welchen Namen und welches Kennwort gibst Du denn ein?
     
  6. KoppC

    KoppC MacUser Mitglied

    Beiträge:
    34
    Zustimmungen:
    0
    Registriert seit:
    07.01.2004
    Benutzer: root
    Passwort: xxxxxx

    habe auch schon das Passwort geändert und dann nochmal versucht aber ohne Erfolg!
     
  7. elninio

    elninio MacUser Mitglied

    Beiträge:
    53
    Zustimmungen:
    2
    Registriert seit:
    25.02.2005
    Ich vermute das sich swat nicht beim system anmeldet sondern bei der smbpasswd

    Einen Root-Account muss man dort erst anlegen.
    Dazu im Terminal eingeben (als root):
    smbpasswd -a username
     
  8. KoppC

    KoppC MacUser Mitglied

    Beiträge:
    34
    Zustimmungen:
    0
    Registriert seit:
    07.01.2004
    ich hoffe dies ist so i.o.

    smb:~ root# smbpasswd -a root
    New SMB password:
    Retype new SMB password:
    dyld: smbpasswd Undefined symbols:
    /etc/pdb/opendirectorysam.so undefined reference to _get_opendirectory_authenticator expected to be defined in the executable
    Trace/BPT trap

    leider hat dies auch nicht funktioniert
     
  9. OLFB

    OLFB MacUser Mitglied

    Beiträge:
    1
    Zustimmungen:
    0
    Registriert seit:
    31.10.2005
    Unter 10.4.2 ist das Anlegen einer PAM-Datei unter /etc/pam.d erforderlich.

    Die Datei muss samba heissen. Du kannst z.B. die ftpd kopieren, damit
    läuft es bei mir.

    Da ich mich mit PAM nicht auskenne, habe ich nach abgeschlossener Administration die Datei zur Sicherheit wieder gelöscht.

    Gruß

    OLFB
     
Die Seite wird geladen...
Ähnliche Themen - swat xinit Forum Datum
berechtigungen /etc/X11/xinit/xinitrc Mac OS X - Unix & Terminal 06.09.2004

Diese Seite empfehlen

Benutzerdefinierte Suche