Suche Qt4 ohne Framework support

Dieses Thema im Forum "Andere" wurde erstellt von Scyx, 19.05.2006.

  1. Scyx

    Scyx Thread Starter MacUser Mitglied

    Beiträge:
    133
    Zustimmungen:
    0
    MacUser seit:
    26.02.2004
    Hallo,
    um ein Programm zu kompilieren bräuchte ich Qt4 _ohne_ Framework-support.
    Ich hab mir das Qt4 Binary von ATG runtergeladen und installiert, dieses hat jedoch den Framework-support unglücklicherweise schon drin.
    Das selbst-kompilieren von Qt-4.1.2 funktioniert leider auch nicht, es bricht immer nach ewigen Zeiten "make" ab mit dem folgenden Fehler:
    make[3]: *** [../../lib/libQtGui_debug.4.1.2.dylib]

    Hat irgendjemand vllt. eine Idee wo man ein Binary ohne Framework-support findet, oder wie ich den Fehler beim selbst-kompilieren beheben kann? Das würde mir riesig helfen.

    Mein Mac OS X ist 10.3.9 mit Xcode Tools, X11/Apple, kein fink oder darwinports.

    MfG

    Scyx
     
  2. oneOeight

    oneOeight MacUser Mitglied

    Beiträge:
    46.804
    Zustimmungen:
    3.632
    MacUser seit:
    23.11.2004
    lass dir doch mal die configure optionen ausgeben und ändere die...
     
  3. Scyx

    Scyx Thread Starter MacUser Mitglied

    Beiträge:
    133
    Zustimmungen:
    0
    MacUser seit:
    26.02.2004
    Welche configure Optionen meinst Du denn? Und wie kann ich mir die ausgeben lassen?

    MfG
    Scyx
     
  4. oneOeight

    oneOeight MacUser Mitglied

    Beiträge:
    46.804
    Zustimmungen:
    3.632
    MacUser seit:
    23.11.2004
    um es selbst zu kompilieren rufst du doch ./configure im terminal auf...
    die optionen kriegst du mit ./configure --help
     
Die Seite wird geladen...

Diese Seite empfehlen