ssh -X - kein glx

Dieses Thema im Forum "Mac OS X - Unix & Terminal" wurde erstellt von firefoxuser, 30.12.2005.

  1. firefoxuser

    firefoxuser Thread Starter MacUser Mitglied

    Beiträge:
    437
    Zustimmungen:
    1
    MacUser seit:
    27.04.2005
    Hallo,
    Ich kann mit ssh -X auf meinen Linxu server zugreifen, xlogo läuft und sogar kde lässt sich remote starten, nur glx programme wie "glxgears" machen ärger.
    Ich hab in der xorg.conf des servers nachgeguckt, dort steht korrekterweise 'Load "glx"' .
    Wie kann ich jetzt glx auf meinem Mac aktivieren?
    (ich hab nälich nicht die xfree konfig datei |hab Apples X11|)
    Oder was muss ich sonst tun, damit glxgears über ssh -X läuft?

    Danke!
    P.S. Von anderen Linux machinen (und sogar Windows mit Winaxe) geht das..
     
  2. oneOeight

    oneOeight MacUser Mitglied

    Beiträge:
    46.831
    Zustimmungen:
    3.633
    MacUser seit:
    23.11.2004
    also glx müsste eigentlich schon geladen sein, jedenfalls kann man glxgears ohne probleme im lokalen os x X11 aufrufen...
     
  3. El Jarczo

    El Jarczo MacUser Mitglied

    Beiträge:
    558
    Zustimmungen:
    9
    MacUser seit:
    07.07.2004
    Wenn ich das richtig in Erinnerung habe, hängt das von den Fähigkeiten des XServers auf der Clientseite ab, ob GLX auch für entfernt laufende Programme geht. Die Nvidia Treiber für Linux,FreeBSD und Solaris unterstützen das glaube ich.
     
  4. firefoxuser

    firefoxuser Thread Starter MacUser Mitglied

    Beiträge:
    437
    Zustimmungen:
    1
    MacUser seit:
    27.04.2005
    Ja, das dachte ich auch.
    Und auf der Client seite geht ja auch GLX Gears...
    Was soll ich denn nun machen?
    Einen Ati Treiber für Mac OS installieren? (Ati Redeon 9200 @ 64MB VRAM)
     
  5. oneOeight

    oneOeight MacUser Mitglied

    Beiträge:
    46.831
    Zustimmungen:
    3.633
    MacUser seit:
    23.11.2004
    das sollte nicht am ATI treiber liegen.
    kannst ja mal einen anderen xserver probieren via fink/darwinports...
    oder das demo von eXodus...
     
  6. Azathoth

    Azathoth MacUser Mitglied

    Beiträge:
    475
    Zustimmungen:
    9
    MacUser seit:
    20.09.2004
    also ich habs gerade probiert.
    Apple X Server lokal
    Remote per "SSH -XC" [edit] auf eine Standard Debian Sarge install
    glxgears läuft ohne probleme
     
    Zuletzt bearbeitet: 30.12.2005
  7. firefoxuser

    firefoxuser Thread Starter MacUser Mitglied

    Beiträge:
    437
    Zustimmungen:
    1
    MacUser seit:
    27.04.2005
    mhmhm, auf meinem Serer läuft OpenSuSe 10...
    was bedeutet das -c?
    und auf dem Server läuft glxgears auch...
     
  8. oneOeight

    oneOeight MacUser Mitglied

    Beiträge:
    46.831
    Zustimmungen:
    3.633
    MacUser seit:
    23.11.2004
    er meinte wohl eher -C für compression ;)
    -c ist cipher...
     
  9. Azathoth

    Azathoth MacUser Mitglied

    Beiträge:
    475
    Zustimmungen:
    9
    MacUser seit:
    20.09.2004
    sorry, vertippt. meinte natürlich -C für compression
    ...verwende das immer für X-fowarding, sollte dann "ein wenig" schneller gehen
     
  10. firefoxuser

    firefoxuser Thread Starter MacUser Mitglied

    Beiträge:
    437
    Zustimmungen:
    1
    MacUser seit:
    27.04.2005
    Was für ein Terminal hast du denn benutzt?
    Das xterm von x11?
    Welche shell?
    Danke!
     

Diese Seite empfehlen