Spracherkennung funktioniert überhaupt nicht

Dieses Thema im Forum "Mac OS X" wurde erstellt von Clemo, 07.07.2006.

  1. Clemo

    Clemo Thread Starter MacUser Mitglied

    Beiträge:
    38
    Zustimmungen:
    0
    MacUser seit:
    03.01.2004
    Ich dreh hier noch durch.
    Ich gehe in die Systemeinstelungen und gehe auf "Sprache" dort auf "Spracherkennung" und schalte "Speakable Items" auf "Ein" wähle mein internes Micro und konfiguriere es so das die Befehle die auf der Seite aufgelistet sind blinken wenn ich sie ausspreche, demnach gehe ich davon aus das er erkennt was ich fasele. (was weis ich "what time is it" oder "switch to finder") so meine taste zum erkennen is f13, gibt auch keine probleme, ich drück drauf und das kleine runde ding zeigt mir an das des Micro Geräusche wahrnimmt.... nur jetz erkennt es keinen einzigen ******* Befehl *aufreg*
    un ich hab mitlerweile ca. 30000 mal sämtliche Beispielsprüche die da standen durchversucht nich einer wurde auch nur einmal erkannt, obwohl es eigentlich bei den Beispielen in der Kalibrierung gefunzt hat... was is da los?!

    aso wenn ich auf "speech commands" gehe (bei dem kugelteil der untere pfeil) is die liste komplett leer... hängt das dmit zusammen? un wenn ja wie bekomme ich zum Teufel wenigstens die original mac os x Befehle zurück auf meinen rechner?!

    schonmal im vorraus danke für eventuelle tips : )
     
  2. Andi

    Andi MacUser Mitglied

    Beiträge:
    7.843
    Zustimmungen:
    653
    MacUser seit:
    16.05.2002
    ...

    Hallo Clemo,

    welche Systemversion verwendest du denn? Unter Systemeinstellungen>Spracherkennung>Befehle müssen die Befehlsarten angehakt sein. Die tauchen dann im Speech Commands Window auf.

    Warum es bei dir nicht funktioniert:
    ähm - Es ist für Amerikaner oder Japaner? gedacht.
    Das System erkennt den sächsischen bzw. mindestens deutschen Akzent nicht gut. Ich komme ursprünglich aus Bayern und bei mir funktioniert es zwar, aber nicht so gut, dass ich es verwenden könnte.

    Du kannst folgendes versuchen:
    Markiere einen Befehlssatz siehe oben und geh da auf Konfigurieren. Jetzt deaktiviere die Funktion "Die Namen der Befehle genauso aussprechen, wie sie geschrieben werden" Jetzt kannst du anstatt "What Time is it" auch "Tell me the Time" sagen. Eventuell wirst du besser verstanden.

    Speakable Items lassen sich auch anpassen. Die liegen in ~/Library/Speech/Speakable Items. "alternativeSpokenFeedback" etwas anderes Eintragen, was dann besser erkannt wird. Die Befehle an sich sollten sich ändern lassen, indem du den Dateinamen des Befehls änderst. z.B "What Time ist it?" in "Time" das Fragezeichen wird vermutlich auch interpretiert.

    Weitere Möglichkeit ist, sich den Befehl vorsprechen zu lassen. Scripteditor öffnen

    say "What Time is it"

    eintragen und auf Ausführen klicken. Eventuell ist das eine kleine Hilfe.

    Wäre mal interessant, wie andere MacUser zurecht kommen. Wie gesagt ich muss manche Befehle öfters aussprechen, damit sie erkannt werden.
    z.B welchen Witz erzählt der Rechner bei "Tell me a Joke" ist nicht schwer aber er versteht mich nicht...
    Kommt eine Reaktion, wenn man den Rechner beleidigt? usw.

    Sollte es nicht am schlechten Englisch liegen, kannst du in ~/Library/Preferences/ alle .plist Dateien in denen "speech" vorkommt löschen und Speakable Items neu aktivieren.

    Gruß Andi
     
  3. Red Delicious

    Red Delicious Banned

    Beiträge:
    1.291
    Zustimmungen:
    0
    MacUser seit:
    29.05.2006
    auf "tell me a joke" antwortet der mac mit "knock knock" ;)
    na? mal mit "whos there?" geantwortet? und dann mit "xx who?"

    war die ersten 2 tage meines maclebens ganz lustig, habs dann aber wegen sinnlosigkeit und effektivlosigkeit wieder abgestellt.
     
  4. Andi

    Andi MacUser Mitglied

    Beiträge:
    7.843
    Zustimmungen:
    653
    MacUser seit:
    16.05.2002
    ...

    Hallo Clemo,

    ich habe inzwischen den möglichen Fehler gefunden.
    Ist im Adressbuch ein Kontakt, den du als Firma definiert hast aber keinen Namen vergeben hast, bleibt das Speech Commands Window leer.

    Überprüfe daher unter Systemeinstellungen>Sprache>Spracherkennung>Befehle>Adressbuch>Konfigurieren, ob du einen Eintrag (null) hast und dieser Markiert ist.

    Der Fehler tritt wohl in 10.4 auf.

    @Red Delicious Jetzt ist mir auch aufgefallen, dass es einen Befehl gibt "Switch to Vorschau" und "Switch to Systemeinstellungen"
    Den Witz bekomm ich immer noch nicht erzählt. Hattest du bei deinem Erfolgreichen Versuch das System vielleicht auf Englisch eingestellt?

    Gruß Andi
     
  5. Red Delicious

    Red Delicious Banned

    Beiträge:
    1.291
    Zustimmungen:
    0
    MacUser seit:
    29.05.2006
    nein, aber ich bilde mir ein recht gut englisch sprechen zu können.
     
  6. Clemo

    Clemo Thread Starter MacUser Mitglied

    Beiträge:
    38
    Zustimmungen:
    0
    MacUser seit:
    03.01.2004
    vielen dank andi, ich hab den eintrag "null" ööh... entmarkiert und jetz funktioniert alles perfekt, er erkennt die befehle gleich beim ersten mal ^^ dankedanke

    edit: un die Witze sin garnich mal so schlecht :D
     
    Zuletzt bearbeitet: 07.07.2006
  7. Andi

    Andi MacUser Mitglied

    Beiträge:
    7.843
    Zustimmungen:
    653
    MacUser seit:
    16.05.2002
    ...

    Hallo Clemo,

    muss ich wohl mit leben, dass ich nicht mal "tell me a joke" richtig aussprechen kann :rolleyes:

    Ich hab den Witz vom iMac meiner Frau erzählt bekommen. Das Micro der iSight scheint nicht unbedingt dafür geeignet zu sein. Kann das Jemand bestätigen? Mit dem iMac funktioniert es erstaunlich gut. Ich nehme alles zurück wegen der Akzente...

    Gruß Andi
     
  8. StruppiMac

    StruppiMac MacUser Mitglied

    Beiträge:
    2.835
    Zustimmungen:
    39
    MacUser seit:
    18.05.2006
    Die Betonung ist wichtig - die macht ein nicht-ammi generell immer falsch, weil sie für Europäer eher als "falsch" angesehen wird
     
  9. Andi

    Andi MacUser Mitglied

    Beiträge:
    7.843
    Zustimmungen:
    653
    MacUser seit:
    16.05.2002
    ...

    Hallo StruppiMac,

    glaube ich nicht.

    Höchstwahrscheinlich ist das Mikrofon entscheidend. Ich habe neben dem iSight Mikro noch ein Bluetooth Headset getestet. Das geht alles nicht so gut wie ein Internes Mikro.

    @Clemo, gut, dass es ein Sachse vormacht... :cool: - der Dank geht zurück.

    Gruß Andi
     
  10. PeterLustig

    PeterLustig MacUser Mitglied

    Beiträge:
    145
    Zustimmungen:
    3
    MacUser seit:
    03.01.2006
     
Die Seite wird geladen...
Ähnliche Themen - Spracherkennung funktioniert überhaupt
  1. myblogtrainer
    Antworten:
    3
    Aufrufe:
    784
  2. thf
    Antworten:
    0
    Aufrufe:
    315
  3. aparde
    Antworten:
    19
    Aufrufe:
    637
  4. ridda
    Antworten:
    4
    Aufrufe:
    902
  5. KaiAmMac
    Antworten:
    11
    Aufrufe:
    2.720