Spotlight Privatsphäre ohne Funktion

Dieses Thema im Forum "Mac OS X" wurde erstellt von Schleuderbogge, 01.03.2007.

  1. Schleuderbogge

    Schleuderbogge Thread Starter MacUser Mitglied

    Beiträge:
    961
    Zustimmungen:
    72
    Registriert seit:
    10.11.2004
    Moin,

    ich möchte meine externe Festplatte (Backupmedium) mit SuperDuper bestücken, allerdings möchte ich keine Indizierung.

    Grund: sobald ein Volume indiziert ist, habe ich im Kontext-Menü ständig doppelte Einträge, die ich erst wieder mit einem Script entfernen muss :mad:

    Soweit, so schlecht.

    In den Systemeinstellungen für Spotlight sollte man entweder durch Auswahl oder per Zieh- und Plumpsen ein Medium als Privatsphäre anmelden können. Das funktioniert bei mir aber nicht. Zwar wird bei drag´n drop das Fenster markiert (gehighlightet :D ), aber ein Eintrag findet definitiv nicht statt.

    System 10.4.8 PB 15" G4 und nein, keine Hacks oder sonstigen Sachen im System...:nono:

    Wer hilft mit einer Lösung?

    So long, Thomas
     
  2. Mai_Ke

    Mai_Ke unregistriert

    Beiträge:
    5.518
    Zustimmungen:
    588
    Registriert seit:
    29.09.2006
    Ich hatte das gleiche Problem mit einer externen Platte an meinem iBook.

    Aus lauter Verzweiflung hab ich gestern mal die externe Platte mit dem Festplattendienstprogramm neu formatiert und jetzt klappt das wieder mit der Privatsphäre. Einfach vom Desktop in das Feld bei den Systemeinstellungen reingezogen und danach das Backup mit SuperDuper erledigt.
     
  3. flosse

    flosse unregistriert

    Beiträge:
    4.085
    Zustimmungen:
    322
    Registriert seit:
    27.05.2006
    Versuch mal die Datei <com.apple.spotlight.plist> zu löschen. Bei mir hat das geholfen.
     
  4. Schleuderbogge

    Schleuderbogge Thread Starter MacUser Mitglied

    Beiträge:
    961
    Zustimmungen:
    72
    Registriert seit:
    10.11.2004
    Hatte ich vergessen zu erwähnen, sorry!

    Das war meine erste Aktion. Naja, erst einmal zum Dienst, heute Nachmittag lege ich dann los. Vielleicht hilft ja auch ein Neustart nach dem Löschen :confused:

    So long, Thomas
     
  5. Blain

    Blain MacUser Mitglied

    Beiträge:
    1.321
    Zustimmungen:
    28
    Registriert seit:
    06.07.2006
    Das liegt normalerweise daran, dass die Indizierung auf Deiner Externen Festplatte nicht eingeschaltet ist. Ich hatte das gleiche problem.


    Du musst als SuperUser folgenden Befehl ausführen:

    mdutil -i on /Volumes/Volumname

    also in Deinem Fall

    sudo mdutil -i on /Volumes/meineexternefestplatte

    siehe auch: http://www.apfelwiki.de/Main/Spotlight
     
    Zuletzt bearbeitet: 01.03.2007
  6. Schleuderbogge

    Schleuderbogge Thread Starter MacUser Mitglied

    Beiträge:
    961
    Zustimmungen:
    72
    Registriert seit:
    10.11.2004
    Hm,

    ich bin mal als Admin in das Terminal gegangen, welches übrigends ein Buch mit 777 Siegeln für mich ist, und habe Deine Lösung eingegeben.

    Danach bekam ich folgende Meldung (hier ohne meine Zugangdaten?), keine weitere Eingabe z.B. für das Passort war dann noch möglich:

    sudo mdutil -i on /Volumes/Backup

    We trust you have received the usual lecture from the local System
    Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

    Password:


    Aber gebracht hat es nichts...:confused:

    Hast Du noch einen Tipp?

    So long, Thomas
     
  7. Switcher5

    Switcher5 MacUser Mitglied

    Beiträge:
    497
    Zustimmungen:
    24
    Registriert seit:
    09.01.2005
    Wenn du das Backup-Volume in Spotlight nicht in die "Privatsphäre" eingeben kannst, wirst du die lästige Spotlight-Indexierung des Backup-Volumens mit dem SuperDuper-Script "Disable_Spotlight" los. Das File runterladen, auspacken und in den Programme-Ordner kopieren. Dann in SuperDuper unter "Options/Advanced" die erste Option ("Run shell script bevor copy starts") aktivieren und den Pfad zur DAtei "disable_spotlight" angeben. Nach dem Start von SuperDuper wird damit das Indexieren unterbunden.

    Download beim Entwickler von SuperDuper:
    http://www.shirt-pocket.com/forums/showthread.php?t=361&highlight=disable_spotlight
     
  8. Der_Hollaender

    Der_Hollaender MacUser Mitglied

    Beiträge:
    908
    Medien:
    1
    Zustimmungen:
    61
    Registriert seit:
    08.09.2004
    Die Passworteingabe zeigt keine Sternchen oder sowas an, dass der Bereich hinter "Password:" frei bleibt, ist also normal. Einfach das Admin-PW eingeben und <enter> drücken.

    Gruß

    Der_Hollaender.
     
  9. An-Jay

    An-Jay MacUser Mitglied

    Beiträge:
    2.202
    Zustimmungen:
    128
    Registriert seit:
    10.06.2004
    Ich kenne das Problem. Wenn ich meinem User-Account jedoch temporär Admin-Rechte zuweise (normalerweise aus), dann klappt es. Sprich ich kann das Laufwerk dann per Drag&Drop in die Privatsphären-Liste schieben. Klappt aber manchmal erst nach zweitem, oder drittem Versuch... :kopfkratz:

    Insgesamt schon etwas nervig.

    Auch neigt das System (zumindest bei mir) dazu, diese Einstellungen zu vergessen, sprich irgendwann indexiert er wieder munter, obwohl das Laufwerk vor Tagen (mal wieder) in die Liste geschoben wurde. :confused:

    Ich hatte mir das bisher damit erklärt, dass Superduper ja die Systemplatte klont und das Vergessen daher kommt, dass ja die Externe beim Backup quasi mit der Systemplatte überschrieben wird und dann Spotlight wieder aktiviert ist, weil Spotlight ja an der Systemplatte aktiv ist. Hoffe, ihr versteht mich... :D

    Ich werde mal das Skript vom SuperDuper-Menschen probieren.

    so oder so, Spotlight mit der Privatsphäre wirkt auf mich aufgrund des sporadischen Gelingens des Drag&Drop irgendwie buggy. Hier gibts Nachholbedarf, spätestens für Leopard.

    Ach ja, nochwas: Die Privatssphären-Liste klappt definitiv NICHT bei Laufwerken, die mit FAT32 formatiert sind!
     
  10. Schleuderbogge

    Schleuderbogge Thread Starter MacUser Mitglied

    Beiträge:
    961
    Zustimmungen:
    72
    Registriert seit:
    10.11.2004
    die finale Lösung ;-)

    So,

    für das Terminal bin ich zu blöde :o , das Script hat mir auch nicht geholfen.

    Daher habe ich jetz folgendes gemacht:

    - Löschen der externen Festplatte mit dem FP-Dienstprogramm
    - entfernen der doppelten Einträge mit dem Script LSD :D :cool:
    - Spotlight Privatsphären in den Systemeinstellungen aufgerufen
    - externe HD reingezogen

    Siehe, es funktionuckelt, scheinbar gibt es nur Probleme, wenn sich schon Daten auf einer HD oder Sonstwas befinden. Nachdem ich meine Paranoia besiegt hatte (1 Std. ohne bootfähiges Backup) ist bei mir alles in Butter.

    Danke an alle, die sich an der Lösung beteiligt haben,

    so long, Thomas
     
Die Seite wird geladen...

Diese Seite empfehlen