Samba Verbindung mit Linux will nicht klappen...

Diskutiere mit über: Samba Verbindung mit Linux will nicht klappen... im Internet- und Netzwerk-Hardware Forum

  1. LnXrooT

    LnXrooT Thread Starter MacUser Mitglied

    Beiträge:
    1.121
    Zustimmungen:
    7
    Registriert seit:
    31.05.2003
    Hallo! Ich hab auf meinem DesktopPC jetzt Windows gelöscht und nun nornoch Mandrake 9.1 drauf laufen. Läuft auch super, nur ein Problem habe ich, nämlich folgendes:
    In KDE doch ähnlich wie unter Win einen Ordner im Netzwerk freigeben, was ich gemacht habe. Die Ordner heissen Verzeichnis und Verzeichnis2...

    Wenn ich mich mit Gehe zu>Mit Server verbinden>smb://192.168.0.4 (IP von LinPC) verbinden will, findet er zwar die beiden Ordner, doch nachdem ich den Benutzernamen und das Passwort des PCs eingegeben habe, kommt ziehmlich schnell Fehler Fehler = -5023

    Weiss jemand was das bedeutet. Ich habe nirgends (Google/Forum) diese Zahl in Zusammenhang mit MacOS und Samba gefunden...

    Achja, pingen funktioniert, Auch filesharing über ftp, was ich aber jetzt nicht so toll finde...

    Ok, danke im Vorraus, Ludwig
     
  2. Schendi

    Schendi MacUser Mitglied

    Beiträge:
    11
    Zustimmungen:
    0
    Registriert seit:
    12.07.2002
    wie die kde dateifreigabe detailliert funkioniert weiß ich nicht (läuft die tatsächlcih unter samba??????)

    besser wäre du siehst dir mal die smb.conf an (btw. wenn du von osx aus zugreifst kannst du das ganze auch über NFS regeln, dann brauchs du nicht mti SMB/CIFS rumspielen).
     
  3. LnXrooT

    LnXrooT Thread Starter MacUser Mitglied

    Beiträge:
    1.121
    Zustimmungen:
    7
    Registriert seit:
    31.05.2003
    Hmm, keine Ahnung ob das über Samba läuft... Ich schau mir diese conf mal an.
    Ehm nfs ist dann wohl sowas ähnliches für UnixSysteme. Aha... Wie funktioniert dass in Mac-os-x?

    gehe zu>server>nfs://192.168.0.3/ bringt nichts! Da zeigt er nur ewig den Statusbalken an!

    grüsse
     
  4. Schendi

    Schendi MacUser Mitglied

    Beiträge:
    11
    Zustimmungen:
    0
    Registriert seit:
    12.07.2002
    wie das unter osx detailiert funkioniert weiß ich nicht (fehlendes gerät um es zu probieren).

    egal ob du es über smb oder nfs machst, du musst erst serverseitig konfiguriern.

    der vorteil an nfs ist, du ersparst dir im netzwerk die netbios broadcasts die du unter samba/cifs hättest.

    einfach mal man nfs in die konsole, da erfährst mehr darüber.
     
  5. roox

    roox MacUser Mitglied

    Beiträge:
    13
    Zustimmungen:
    0
    Registriert seit:
    01.10.2003
    Salute!

    Gib in der Shell "man smb.conf" bzw. "man samba" ein und du bekommst das passenden Howto zu diesem thema!

    unter /etc/samba/smb.conf oder unter /etc/smb.conf kannst du alles weiter einstellen!

    Gruß roox
     
  6. hatty

    hatty MacUser Mitglied

    Beiträge:
    286
    Zustimmungen:
    0
    Registriert seit:
    08.04.2003
    hi LnXroot,
    habe folgendes gefunden:
    error -5023 afpUserNotAuth: No AFPLogin call has successfully been made for this session.
    Und dann noch das:
    I get this problem all the time when setting up plain old Samba sharing connections. Exact same error. Here's my workaround:
    When it displays the address of the machine it's about to connect to (smb://192.168.0.1), change it to:
    smb://username:password@192.168.0.1/sharename
    (replace all the words with their appropriate values, of course) .
    Ich hoffe, dass hilft weiter.
     
  7. Schendi

    Schendi MacUser Mitglied

    Beiträge:
    11
    Zustimmungen:
    0
    Registriert seit:
    12.07.2002
     

    in dem fall wäre es wohl sinnvoller, samba zu aktualisieren,
    da sonst das einbinden von netzlaufwerken ziemlich unflexibel wäre (gehört habe ich das bis heute ohnehin noch nicht, da alle samba 2.2.x untereindander kompatibel sind).
     
  8. LnXrooT

    LnXrooT Thread Starter MacUser Mitglied

    Beiträge:
    1.121
    Zustimmungen:
    7
    Registriert seit:
    31.05.2003
    Sorry für die lange Sendepause! Ich hab es dank euere Hilfe hinbekommen und zwar so:

    Hab einfach in der smb.conf auf dem lin-rechner

    encrypted passwords = no

    Dann hats funktioniert!

    :)

    Danke nochmal!
     
Die Seite wird geladen...
Ähnliche Themen - Samba Verbindung Linux Forum Datum
NAS Fileserver mit Samba, FTP oder NFS? Internet- und Netzwerk-Hardware 19.03.2010
der NAS / Linux Server / AFP / Samba Thread Internet- und Netzwerk-Hardware 03.12.2009
Win7 Beta Zugriff auf Samba Freigabe Internet- und Netzwerk-Hardware 07.02.2009
Probleme mit Samba zugriff auf APExtrem Internet- und Netzwerk-Hardware 29.12.2008
Samba stabieler als AFP bei verbindungen zur APextream ? Internet- und Netzwerk-Hardware 28.12.2008

Diese Seite empfehlen

Benutzerdefinierte Suche