Safari und Umlaute -- falsche Darstellung!

Dieses Thema im Forum "Internet- und Netzwerk-Software" wurde erstellt von Luke1, 30.03.2005.

  1. Luke1

    Luke1 Thread Starter MacUser Mitglied

    Beiträge:
    550
    Zustimmungen:
    37
    MacUser seit:
    29.09.2004
    Ich habe hier ein grundsätzliches Problem mit der Darstellung von Umlauten bei Daten aus dem Internet.

    Also, wenn ich z.B. im Berlin-brandenburgischen Bibliotheksverbund-Katalog (www.kobv.de) mit Safari eine Recherche durchführe, dann werden die Treffer jeweils in 10er-Sätzen angezeigt. Mann kann aber die einzelnen Treffer auswählen und nach dem Durchsehen aller 10er-Sätze gibt es die Möglichkeit die ausgewählten Treffer zu speichern. Wenn ich von den beiden Speicheroptionen des kobv-OPACs "Standard" wähle (die andere ist ein EndNote-Format) dann erhalte ich in Safari eine Seite, welche mir die bibliographischen Daten der ausgewählten Treffer anzeigt. Optisch sieht das aus wie reiner Text. So weit so gut.

    Nun kommt aber mein Problem. Immer wenn ich versuche, die Daten mit dem Safari-Befehl "Sichern unter" zu speichern, um eine editierbare Text-Datei zu erhalten, bekomme ich eine Datei auf mein iBook, die mit .exl endet. Was auch immer das für eine Endung sein mag, ich kann sie zwar mit TextEdit und auch mit Word öffnen. Allerdings: Die Umlaute werden mit seltsamen Zeichen dargestellt (Prozent-, Promillezeichen, irgendwelche Haken usw.).

    Was läuft hier falsch? Ein workaround ist es zwar, den Text in Safari zu markieren (Befehl-A) und anschließend mit paste und copy in ein leeres TextEdit-Dokument zu kopieren. Die Umlaute bleiben dabei auch erhalten. Ich wüsste aber dennoch gerne, warum das über den Sichern-unter-Befehl von Safari nicht geht. Und zwar deshalb, weil das Problem mit den Umlauten und Daten aus dem Internet immer wieder auftaucht. So etwa mit dem Speichern von Suchergebnissen des im WWWOPAC des Max-Planck Instituts für Völkerrrecht (http://www.virtual-institute.de/index.cfm). Dort öffnet sich nämlich keine Safari-Seite aus der ich mittels paste und copy die Daten übernehmen könnte. Ich erhalte nach dem betätigen des OPAC-eigenen Speichern-Befehls eine Datei, diesmal .sav. Mit der ich es sich genauso verhält wie mit der .exl-Datei vom kobv.

    Ist das ein Win-Mac Plattformproblem oder warum klappt das nicht? :(

    Danke schon mal vorab,
    Luke1
     
    Zuletzt bearbeitet: 30.03.2005
  2. lundehundt

    lundehundt MacUser Mitglied

    Beiträge:
    19.461
    Zustimmungen:
    881
    MacUser seit:
    22.02.2003
    was da gespeichert wird sind entities - die werden benutzt um in html Sonderzeichen darzustellen. Sie beginnen mit einem & und enden mit einem ; - die Zeichenfolge dazwischen bestimmt den Buchstaben. Wenn die Datei als ASCII gespeichert (.sav ist entweder ASCII oder binary) wird siehst du diese Zeichen, die von html als Sonderzeichen interpretiert werden.

    Der suffix .exl muss ein sehr prorpietaerer sein. Habe dazu nicht mal was auf die schnelle bei google gefunden.

    Auf einem PC sehen die Dateien genauso aus. Das Problem laesst sich umgehen wenn man beim codieren der Seiten unicode verwenden wuerde.

    Cheers,
    Lunde
     
  3. joachim14

    joachim14 MacUser Mitglied

    Beiträge:
    7.295
    Zustimmungen:
    433
    MacUser seit:
    08.02.2005
    Soweit ich das bis jetzt nachvollzogen habe, bekommst Du ganz normale ASCII Dateien, bei denen die Sonderzeichen ä, ü, usw. als andere Sonderzeichen, die von Dir beschriebenen % Zeichen u.a. dargestellt werden.
    Mit der richtigen Umcodierung können Browser die Dateien wieder richtig darstellen.

    So weit, so wenig hilfreich.

    Es ist aber nur insofern ein Browserproblem, als Safari nicht beim Speichern eine Umcodierung anbietet. Das ist bei Firefox übrigens nicht anders. Mit IE kann man die gespeicherten Dateien nicht mal mehr öffnen.

    Manuell kann man natürlich solche Dateien mit Suchen/Ersetzen bearbeiten. Ich habe auch in sehr dunkler Erinnerung, dass für solche Probleme mindestens ein Programm zur Zeichenkonvertierung existiert. Leider, Name ?

    Wenn das also nicht solche Ausmaße annimmt, dass die Programmsuche oder die Eigenprogrammierung lohnt, wähle wie bisher aus Safari kopieren und woanders einsetzen.
     
  4. norbi

    norbi MacUser Mitglied

    Beiträge:
    3.506
    Zustimmungen:
    22
    MacUser seit:
    14.01.2003
    versuch mal, an die zu sichernde Datei manuell ein ".html" dranzuhängen.

    Links unten im Sicherungsdialog dazu das "suffix ausblenden" abhaken.

    No.
     
  5. Luke1

    Luke1 Thread Starter MacUser Mitglied

    Beiträge:
    550
    Zustimmungen:
    37
    MacUser seit:
    29.09.2004
    Ich danke Euch beiden für die ausführliche und gute Erklärung. Wenigstens weiß ich jetzt, worum es sich hier handelt, auch wenn eine Lösung nicht so recht in Sicht ist.
    Ist schon komisch. Man würde doch meinen, dass es für diesen ASCII oder binary Code eine "Übersetzung" geben müsste. Zumal das Problem ja offenbar nicht Mac-spezifisch ist.

    Falls noch jemand eine Idee hat, bin ich für jede Hilfestellung dankbar. Denn der beschriebene Workaround funktioniert halt nicht immer.

    Nochmals danke an Euch zwei,
    Luke1
     
  6. Luke1

    Luke1 Thread Starter MacUser Mitglied

    Beiträge:
    550
    Zustimmungen:
    37
    MacUser seit:
    29.09.2004
    @norbi
    Hab ich auch schon versucht. Das Ergebnis sieht dann aber ganz anders aus: Keine Formatierung mehr und die Umlaute sind immer noch nicht da.

    Danke trotzdem für die Idee :D
     
  7. lundehundt

    lundehundt MacUser Mitglied

    Beiträge:
    19.461
    Zustimmungen:
    881
    MacUser seit:
    22.02.2003
    Veersuch doch mal die Dateien mit einer anderenen Textverarbeitung zu oeffnen (aofel+i - oeffnen mit. Word zum Beispiel kann html darstellen - ich weiss aber nicht wie es mit entities in einer ASCII Datei umgeht.

    Cheers,
    Lunde
     
  8. Luke1

    Luke1 Thread Starter MacUser Mitglied

    Beiträge:
    550
    Zustimmungen:
    37
    MacUser seit:
    29.09.2004
    Klappt leider auch nicht, die Umlaute fehlen nach wie vor. Das einzige, was halbwegs funktioniert, ist die Umbenennung der herunter geladenen Datei in ein Html-Dokument durch ändern des suffixes in .html. Beim Öffnen in Safari fehlen zwar sämtliche Formatierungen und ich habe nur einen einzigen Textblock vor mir. Aber mit Umlauten!!!

    Danke,
    Luke1 :D
     
Die Seite wird geladen...
Ähnliche Themen - Safari Umlaute falsche
  1. msg
    Antworten:
    1
    Aufrufe:
    82
  2. El-Gerto
    Antworten:
    5
    Aufrufe:
    83
    noodyn
    01.12.2016
  3. zarah123
    Antworten:
    9
    Aufrufe:
    1.036
    zarah123
    23.12.2012
  4. F. Katharina
    Antworten:
    1
    Aufrufe:
    567
    F. Katharina
    27.05.2007
  5. freakman
    Antworten:
    2
    Aufrufe:
    450
    heldausberlin
    24.10.2006