Safari/Shiira und japanische Schriftzeichen

Dieses Thema im Forum "Internet- und Netzwerk-Software" wurde erstellt von Ranmaru, 03.02.2006.

  1. Ranmaru

    Ranmaru Thread Starter MacUser Mitglied

    Beiträge:
    765
    Zustimmungen:
    29
    Registriert seit:
    08.10.2005
    Servus,

    ich habe folgendes Problem: wenn ich in Safari oder Shiira über die japanische Sprachunterstützung bei Unicode-Kodierung ein Schriftzeichen eingebe (zum Beispiel in ein Forum) und das Formular absende, dann kommt hinterher nur eine Aneinanderreihung von Fragezeichen heraus. Es kann kein Mensch nachher lesen, egal wie dessen Kodierung ist.
    Wenn ich auf Shift-JIS umstelle und dann abschicke, dann kommen zwar Zeichen zustande, die aber nur Leute lesen können, die ebenfalls Shift-JIS als Kodierung gewählt haben. Alle anderen sehen nur ASCII-Salat.
    Mit Camino hingegen funktioniert das Einwandfrei auch im Unicode. Eintippen, abschicken und hinterher sieht es jeder.

    Hier mal ein Test …
    ?????????????????????

    Weiß jemand, woran das liegen könnte und was ich dagegen tun kann?

    Danke,
    Ranmaru.
     
  2. Ranmaru

    Ranmaru Thread Starter MacUser Mitglied

    Beiträge:
    765
    Zustimmungen:
    29
    Registriert seit:
    08.10.2005
    Hier zum Vergleich einmal mit Camino.
    今日は2006年2月3日です。
     
  3. Ranmaru

    Ranmaru Thread Starter MacUser Mitglied

    Beiträge:
    765
    Zustimmungen:
    29
    Registriert seit:
    08.10.2005
    Die Hoffnung stirbt zuletzt.

    *schieb*
     
  4. mikne64

    mikne64 MacUser Mitglied

    Beiträge:
    3.097
    Zustimmungen:
    92
    Registriert seit:
    02.04.2004
    Hi,

    ich kenne Shiira nicht, ist dieser Browser Unicode-fähig? Zumindest Camino ist Unicode-fähig.

    Viele Grüße
     
    Zuletzt bearbeitet: 24.08.2006
  5. Tobfun

    Tobfun MacUser Mitglied

    Beiträge:
    1.372
    Zustimmungen:
    0
    Registriert seit:
    06.05.2004
    Sicherlich ist Shiira auch Unicode-fähig...
    Shiira = Safari...

    Welche Textcodierung hast du denn bei Shiira (eigentlich Standard)?
    Ich hatte am Anfang bei der Darstellung der Umlaute und „ß“ auch immer Probleme...
     
  6. Herr Chow

    Herr Chow Gast

    Frag' mal Mariala! Sie ist Japanologin und hat vielleicht mittlerweile eine Lösung gefunden.
     
  7. Ranmaru

    Ranmaru Thread Starter MacUser Mitglied

    Beiträge:
    765
    Zustimmungen:
    29
    Registriert seit:
    08.10.2005
    Ich habe Unicode (UTF-8) als Standard-Kodierung eingestellt. Allerdings funktioniert's auch nicht, wenn die umstelle. Außer wie gesagt mit Shift-JIS, dann allerdings sind die Kanji auch nur in Shift-JIS lesbar und nicht in Unicode oder einer anderen Kodierung.

    Umlaute und das ß werden bei mir allerdings problemlos dargestellt.
     
Die Seite wird geladen...

Diese Seite empfehlen