Riesenärger mit NetInfo und root-Passwort

Diskutiere mit über: Riesenärger mit NetInfo und root-Passwort im Mac OS X Forum

  1. der_Kay

    der_Kay Thread Starter MacUser Mitglied

    Beiträge:
    1.693
    Zustimmungen:
    7
    Registriert seit:
    02.09.2004
    Hi,

    brauchte heute "mal eben" zum erstenmal den root-account. Dabei ist mir folgendes passiert:

    1.) NetInfo gestartet, erfolgreich identifiziert, root-account aktiviert.

    2.) beim Passwort-Dialog "OK" gedrückt. Wirklich nichts versehentlich eingegeben!

    3.) "su" im Terminal fehlgeschlagen.

    4.) Im NetInfo "Root Passwort ändern" gewählt -> "Altes Passwort:" freigelassen und 2 mal neues (Trivial-)Passwort eingetragen

    5.) ...und nichts geht mehr: kann kein root-Passwort setzen, kein "su" im Terminal, root-account ist "unerreichbar"!

    Mit der Boot-CD oder im Single-User-Mode kann man das wohl wieder hinbiegen, wie Google sagt, aber meine Frage wäre, ob das normal ist? Mein Arbeitsaccount (= der einzige account im System) hat nämlich auch kein Passwort.

    Ich muß hinzufügen: Mac Os X 10.3.7 auf PearPC Emulation!

    Ratlose Grüße,

    Kay
     
  2. pique

    pique Gast

    akzeptiert root überhaupt "kein" passwort?
     
  3. dannycool

    dannycool MacUser Mitglied

    Beiträge:
    1.485
    Zustimmungen:
    34
    Registriert seit:
    02.02.2005
    Erstens brauchst Du den root-Account nicht und das bringt mich auch schon zu zweitens, geht es mit sudo noch? Weil su darf auf Mac OS per default eh kein User.
     
  4. wegus

    wegus MacUser Mitglied

    Beiträge:
    15.032
    Zustimmungen:
    1.314
    Registriert seit:
    13.09.2004
    Doch, das kann es geben! Versuch mal bei mysql mittels sudo an die DB-Dateien heranzukommen. Als User mit admin-Rechten kann man sehrwohl per su in einen freigeschalteten root-account wechseln.Kein Paßwort ist leider auch immer etwas mißverständliches ( kann ja auch ein Leerzeichenstring sein der dann zum passw. verschlüsselt wird). Irgendetwas sollte man daher besser immer angeben und sei es '12345'. Wie man das jetzt per PearPC löst, weiß ich leider auch nicht.
     
  5. der_Kay

    der_Kay Thread Starter MacUser Mitglied

    Beiträge:
    1.693
    Zustimmungen:
    7
    Registriert seit:
    02.09.2004
    @ travelstar: Es wird gar nichts mehr akzeptiert: Weder leere Zeichenketten noch das Trivialpasswort (das ich gar nicht setzen konnte...). (Und mein account ist ein admin-account.)

    @dannycool: Der account ist freigeschaltet. Ich kann ihn auch problemlos wieder deaktivieren. Bei erneuter Aktivierung ist wie gehabt kein Rücksetzen/Ändern des pw mehr möglich

    @wegus: Klar das das intiale Weglassen des root-pw eine Schludrigkeit meinerseits ist, aber ich bin der Meinung, daß das System so nicht reagieren darf. Jede Linux-Distro verbietet entweder leere root-pws oder verkündet sonstwie ihren Unmut darüber...

    Das externe Zurücksetzen des root-pw ist auch nicht das Problem aber ich werde mal ausprobieren, ob sich dieses Verhalten reproduzieren läßt...

    Gruß,

    Kay
     
    Zuletzt bearbeitet: 23.02.2005
  6. dannycool

    dannycool MacUser Mitglied

    Beiträge:
    1.485
    Zustimmungen:
    34
    Registriert seit:
    02.02.2005
    Eben nur, wenn er freigeschaltet ist...

    Aber sudo su geht immer.

    Wo ist bei MySQL eigentlich das Problem?
     
  7. wegus

    wegus MacUser Mitglied

    Beiträge:
    15.032
    Zustimmungen:
    1.314
    Registriert seit:
    13.09.2004
    dannycool:
    das wußte ich nicht! Dann gibt es kein Problem mit ./mysql/data/*
     
Die Seite wird geladen...
Ähnliche Themen - Riesenärger NetInfo root Forum Datum
UID Verstellen - Netinfo Manager verschwunden? Mac OS X 29.10.2008
Benutzerkonten und fehlender NetInfo Manager Mac OS X 30.10.2007
Netinfo Manager Infos jetzt wo? Mac OS X 28.10.2007
Fragen zu FileVault und NetInfo Manager Mac OS X 16.04.2007
Verstehe Netinfo Manager nicht! Mac OS X 02.11.2006

Diese Seite empfehlen

Benutzerdefinierte Suche