Probleme mit Tunnelblick, verbinden geht aber sonsts nichts

Dieses Thema im Forum "Internet- und Netzwerk-Hardware" wurde erstellt von Scaryman, 11.10.2006.

  1. Scaryman

    Scaryman Thread Starter MacUser Mitglied

    Beiträge:
    48
    Zustimmungen:
    1
    MacUser seit:
    07.11.2003
    Hallo,
    ich habe einige Probleme mit Tunnelblick. Die Verbindung Funktioniert zwar aber im Log sind Fehler zu finden und ich kann auch keine Webseite aufrufen oder einen Server anpingen.

    Hier erst mal die Config dateien.
    Code:
    client
    pull dhcp-options
    up /Users/mp/Library/openvpn/client.up.osx.sh
    down /Users/mp/Library/openvpn/client.down.osx.sh
    dev tap
    proto udp
    remote 10.10.0.1 1194
    nobind
    persist-key
    persist-tun
    mute-replay-warnings
    ca ca.crt
    key privatekey
    cert mp1s.crt
    ns-cert-type server
    cipher BF-CBC
    comp-lzo
    verb 3
    remap-usr1 SIGTERM
    auth-user-pass
    
    Nun das Log aus dem Tunnelblick 3.0 Fenster
    Code:
    Wed 10/11/06 12:46 PM: IMPORTANT: OpenVPN's default port number is now 1194
    Wed 10/11/06 12:46 PM: WARNING: file 'privatekey' is group or others accessible
    Wed 10/11/06 12:46 PM: LZO compression initialized
    Wed 10/11/06 12:46 PM: Control Channel MTU parms [ L:1574 D:138 EF:38 EB:0 ET:0 EL:0 ]
    Wed 10/11/06 12:46 PM: Data Channel MTU parms [ L:1574 D:1450 EF:42 EB:135 ET:32 EL:0 AF:3/1 ]
    Wed 10/11/06 12:46 PM: Local Options hash (VER=V4): 'd79ca330'
    Wed 10/11/06 12:46 PM: Expected Remote Options hash (VER=V4): 'f7df56b8'
    Wed 10/11/06 12:46 PM: UDPv4 link local: [undef]
    Wed 10/11/06 12:46 PM: UDPv4 link remote: 10.10.0.1:1194
    Wed 10/11/06 12:46 PM: TLS: Initial packet from 10.10.0.1:1194
    Wed 10/11/06 12:46 PM: VERIFY OK: depth=1
    Wed 10/11/06 12:46 PM: VERIFY OK: nsCertType=SERVER
    Wed 10/11/06 12:46 PM: VERIFY OK: depth=0
    Wed 10/11/06 12:46 PM: Data Channel Encrypt: Cipher 'BF-CBC' initialized with 128 bit key
    Wed 10/11/06 12:46 PM: Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
    Wed 10/11/06 12:46 PM: Data Channel Decrypt: Cipher 'BF-CBC' initialized with 128 bit key
    Wed 10/11/06 12:46 PM: Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
    Wed 10/11/06 12:46 PM: Control Channel: TLSv1
    Wed 10/11/06 12:46 PM: [server] Peer Connection Initiated with 10.10.0.1:1194
    Wed 10/11/06 12:46 PM: SENT CONTROL [server]: 'PUSH_REQUEST' (status=1)
    Wed 10/11/06 12:46 PM: PUSH: Received control message: 'PUSH_REPLY
    Wed 10/11/06 12:46 PM: OPTIONS IMPORT: timers and/or timeouts modified
    Wed 10/11/06 12:46 PM: OPTIONS IMPORT: --ifconfig/up options modified
    Wed 10/11/06 12:46 PM: OPTIONS IMPORT: route options modified
    Wed 10/11/06 12:46 PM: OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified
    Wed 10/11/06 12:46 PM: gw 10.10.0.1
    Wed 10/11/06 12:46 PM: TUN/TAP device /dev/tap0 opened
    Wed 10/11/06 12:46 PM: /sbin/ifconfig tap0 delete
    Wed 10/11/06 12:46 PM: NOTE: Tried to delete pre-existing tun/tap instance -- No Problem if failure
    Wed 10/11/06 12:46 PM: /sbin/ifconfig tap0 10.241.0.124 netmask 255.255.0.0 mtu 1500 up
    Wed 10/11/06 12:46 PM: /Users/mp/Library/openvpn/client.up.osx.sh tap0 1500 1574 10.241.0.124 255.255.0.0 init
    Wed 10/11/06 12:46 PM: /sbin/route add -net 0.0.0.0 10.241.0.1 128.0.0.0
    Wed 10/11/06 12:46 PM: /sbin/route add -net 128.0.0.0 10.241.0.1 128.0.0.0
    Wed 10/11/06 12:46 PM: Initialization Sequence Completed
    
    Und zu guter Letzt die Console.log
    Code:
    ===== Mittwoch, 11. Oktober 2006 12:46 Uhr Europe/Berlin =====
    kextload: extension /Applications/Tunnelblick.app/Contents/Resources/tap.kext is already loaded
    kextload: extension /Applications/Tunnelblick.app/Contents/Resources/tun.kext is already loaded
    2006-10-11 12:46:32.842 Tunnelblick[10983] Problem with notification token. Please check!
    2006-10-11 12:46:35.343 Tunnelblick[10983] Problem with notification token. Please check!
    Oct 11 12:46:37 mark-pocherts-computer mDNSResponder: Repeated transitions for interface en1 (10.10.244.224); delaying packets by 5 seconds
    2006-10-11 12:46:48.426 Tunnelblick[10983] Problem with notification token. Please check!
    2006-10-11 12:46:55.968 Tunnelblick[10983] Problem with notification token. Please check!
    Oct 11 12:46:57 mark-pocherts-computer mDNSResponder: Repeated transitions for interface en1 (10.10.244.224); delaying packets by 5 seconds
    
    Ich habe nun noch die 2 Scripte angehängt die beim Starten und Beenden geladen werden, den Namen habe ich in txt geändert damit das Hochladen Funktioniert. Hat vieleicht einer von euch eine Idee warum das Verbinden Funktioniert jedoch keine Verbindung zu irgend einem Server klappt? Ich habe den Mac noch nicht all zu lange darum sagt mir der Logausschnitt recht wenig also bitte nicht böse sein wenn die Antwort auf der Hand liegt.

    Danke
     
  2. m-schmidt

    m-schmidt MacUser Mitglied

    Beiträge:
    364
    Zustimmungen:
    1
    MacUser seit:
    18.01.2006
    hast du einen intel Mac? Denn auf meinen Intel Macs hab ich Tunnelblick irgendwie nicht zum laufen bekommen und musste nach einem Verbindungsaufbau die abstrusesten Effekte beobachten ....
     
  3. Scaryman

    Scaryman Thread Starter MacUser Mitglied

    Beiträge:
    48
    Zustimmungen:
    1
    MacUser seit:
    07.11.2003
    Ja ist ein neues MacBook
     
  4. m-schmidt

    m-schmidt MacUser Mitglied

    Beiträge:
    364
    Zustimmungen:
    1
    MacUser seit:
    18.01.2006
    nun ja, dann würde ich sagen, ist dies der Grund für deine Probleme. Denn ich hab da auch viel rumgespielt und das hat mich schon etwas in den Wahnsinn getrieben muss ich sagen. Bei den Windows Kisten gab es keinerlei Probleme mit OpenVPN, aber auf dem Mac hab ich das Zeugs einfach nicht zum Laufen bekommen. Meine Schlussfolgerung war dann, dass zwar anscheinend Tunnelblick auf den Intel-Macs läuft, jedoch OpenVPN, welches von Tunnelblick ja einfach nur angesteuert wird, wohl irgend wie noch nicht so richtig Intel Mac fähig ist. Also warte ich, bis sich dies ändert und baue OpenVPN Verbindungen mit dem in Parallels laufenden Windows auf ....

    Falls es doch schon jemand geschafft hat, OpenVPN bzw. Tunnelblick auf einem Intel Mac zu betreiben, kann er dies ja mal hier kund tun.
     
  5. Scaryman

    Scaryman Thread Starter MacUser Mitglied

    Beiträge:
    48
    Zustimmungen:
    1
    MacUser seit:
    07.11.2003
    Also wenn ich mit Parallels eine VPN Verbindung aufbaue kann ich auch unter Mac OS Surfen und Arbeiten?
     
  6. m-schmidt

    m-schmidt MacUser Mitglied

    Beiträge:
    364
    Zustimmungen:
    1
    MacUser seit:
    18.01.2006
    nun ja, also wenn du bei dir unbedingt ein VPN benötigst um ins Internet zu kommen, dann wird dir wohl nix anders übrig bleiben ...

    also Parallels installieren, dann ein Windows drauf und dort OpenVPN installieren. Bei mir funzt das, allerdings nutze ich das nicht um ins Internet zu kommen, sondern um einen VPN-Tunnel in das Firmennetzwerk eines Kunden aufzubauen.

    Das einziege Problem was ich bei dir sehe sind diese Scripts, also z.B. client.up.osx.sh. Denn du kannst ja nun unter Windows kein sh-Skript ausführen. Daher musst du zusehen, dass du noch irgendwie ein Skript für Windows bekommst (z.B. ein Bat- oder Cmd-File).

    Ist das bei dir ein Uni-Zugang oder sowas?
     
  7. Scaryman

    Scaryman Thread Starter MacUser Mitglied

    Beiträge:
    48
    Zustimmungen:
    1
    MacUser seit:
    07.11.2003
    Ja ich brauche das für die UNI. Also ich kann zwar an der FH Surfen aber wenn ich das mache kann jeder mithören und das ich nicht das gelbe vom ei. Und was noch viel schlimmer ist ich muss mich jedes mal auf eine Webseite beim Hotspot anmelden wenn ich 20 min inaktiv war
     
  8. vland

    vland MacUser Mitglied

    Beiträge:
    2
    Zustimmungen:
    0
    MacUser seit:
    28.10.2006
    Hast du mittlerweile eine Lösung gefunden? Ich habe EXAKT dasselbe Problem mit der gleichen Fehlermeldung.

    Unter Parallels funktioniert es problemlos mit Tunnelblick bekomme ich die Meldung:
    Code:
    Problem with notification token. Please check!
    Die Verbindung scheint aber aufgebaut worden zu sein...
     
Die Seite wird geladen...
Ähnliche Themen - Probleme Tunnelblick verbinden
  1. Mia1
    Antworten:
    2
    Aufrufe:
    162
    Olivetti
    18.09.2016
  2. soul2soul
    Antworten:
    1
    Aufrufe:
    213
    rechnerteam
    20.07.2016
  3. xxNEOxx
    Antworten:
    4
    Aufrufe:
    301
    xxNEOxx
    19.04.2016
  4. JuicyMacintosh
    Antworten:
    0
    Aufrufe:
    190
    JuicyMacintosh
    18.04.2016
  5. Maren
    Antworten:
    4
    Aufrufe:
    261
    Matrickser
    04.03.2016