Probleme mit Java bei Safari und Firefox

Dieses Thema im Forum "Internet- und Netzwerk-Software" wurde erstellt von CarolaK, 24.07.2006.

  1. CarolaK

    CarolaK Thread Starter MacUser Mitglied

    Beiträge:
    42
    Zustimmungen:
    1
    MacUser seit:
    07.06.2006
    Hallo,

    ich möchte in einem CMS-System mit einem HTML-Editor Inhalte bearbeiten, für den Java SE 1.4 notwendig ist.

    Doch weder mit Safari, noch mit Firefox, funktioniert der Editor. Bei Firefox (Version 1.5.04) kommt die Meldung, dass Firefox nicht unterstützt wird, und dass auf Mac OS X (Version 10.4.7) nur Safari (Version 1.2 oder höher) unterstützt wird. Ich besitze Safari Version 2.0.4, doch auch hier öffnet sich der HTML-Editor nicht.

    Auf meinem MacBook sind aber sowohl Java 1.3.1, als auch Java 1.4.2 und sogar Java 5.0 (1.5) installiert.

    In beiden browsern habe ich in den Einstellungen Java und Java Script aktiviert und das Blockieren von popups deaktiviert.

    Ich blicke da nicht mehr durch. Kann mir jemand helfen?

    Wie bekomme ich den HTML-Editor in diesem CMS-System zulaufen, der Java voraussetzt?

    Viele Grüße,
    carola :)
     
  2. wegus

    wegus MacUser Mitglied

    Beiträge:
    15.041
    Zustimmungen:
    1.316
    MacUser seit:
    13.09.2004
    ZunächsT: Du mischt Java und Javascript! Editoren benötigen meist nur Javascript, Deine Java-Version ist ergo egal. Safari ist nicht 100%ig Savascript-tauglich, das ist bekannt. FireFox, Camino oder Opera sollten es jedoch tun. Bei Firefox gibt es eine Javascript-Console, was gigt die denn aus, wenn DU die Seite aufrufst?
     
  3. CarolaK

    CarolaK Thread Starter MacUser Mitglied

    Beiträge:
    42
    Zustimmungen:
    1
    MacUser seit:
    07.06.2006
    Entschulidung, ich habe absolut keine Ahnung von Java und Javascript und so. Ich benötige das für meine Arbeit, bin da aber selbst nicht versiert drin.

    Was ist denn eine Javascript-Console? Muss man das extra öffnen? Wenn ich die Seite in Firefox aufrufe, kommt eine Meldung, dass ich einen nicht-unterstützten browser benutze und nur Safari ab Version 1.2 auf Mac OS unterstützt wird.

    Gruß,
    carola :)
     
  4. wegus

    wegus MacUser Mitglied

    Beiträge:
    15.041
    Zustimmungen:
    1.316
    MacUser seit:
    13.09.2004
    was für ein CMS ist denn das? :kopfkratz:

    Welchen FireFox verwendest Du?

    Die Konsole findest Du im Menü unter Extras->Javascript Konsole!


    Javascript und Java heißten fatalerweise ähnlich sind aber grundverschiedene Dinge. Es gibt auch ein paar Java-basierende CMS, deswegen wäre ein link zum CMS hilfreich!
     
  5. CarolaK

    CarolaK Thread Starter MacUser Mitglied

    Beiträge:
    42
    Zustimmungen:
    1
    MacUser seit:
    07.06.2006
    Ich verwende Firefox 1.5.04.

    Ich weiß nicht viel über das CMS, genau nennt es sich CMS NPS. Ist das hilfreich?

    Bei der Javascript Konsole spuckt er 'ne Menge Fehler aus.
    Z.B.
    Fehler: ',' oder '{' erwartet, aber 'html' gefunden. Regelsatz wegen ungültigem Selektor ignoriert.

    Fehler: Farbe erwartet, aber 'none' gefunden. Fehler beim Verarbeiten des Wertes für Eigenschaft 'background-color'. Deklaration ignoriert.

    Fehler: Fehler beim Verarbeiten des Wertes für Eigenschaft 'top'. Deklaration ignoriert.

    Fehler: Fehler beim Verarbeiten des Wertes für Eigenschaft 'left'. Deklaration ignoriert.

    Fehler: Fehler beim Verarbeiten des Wertes für Eigenschaft 'background-repeat'. Deklaration ignoriert.

    Fehler: Farbe erwartet, aber 'none' gefunden. Fehler beim Verarbeiten des Wertes für Eigenschaft 'background-color'. Deklaration ignoriert.

    Hilft auch das?

    carola :)
     
  6. wegus

    wegus MacUser Mitglied

    Beiträge:
    15.041
    Zustimmungen:
    1.316
    MacUser seit:
    13.09.2004
  7. CarolaK

    CarolaK Thread Starter MacUser Mitglied

    Beiträge:
    42
    Zustimmungen:
    1
    MacUser seit:
    07.06.2006
Die Seite wird geladen...

Diese Seite empfehlen