Probleme mit frameset und css

Dieses Thema im Forum "Web Page Design" wurde erstellt von maceis, 22.04.2004.

  1. maceis

    maceis Thread Starter MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    hallo zusammen

    ich habe einige Probleme mit framesets.

    So sieht meine Zeile aus:
    <frameset border=2 frameborder=1 bordercolor="#333333" rows=91px,* noresize>

    In Safari wird die bordercolor nicht angezeigt, die Farbe ist immer weiss (auch wenn ich textliche Farbbezeichnungen verwende oder das # weglasse).
    In Explorer wird die Farbe darkgrey als rot angezeigt (ok- dass kann ich durch die Codierung umgehen), was aber schlimmer ist, trotz noresize kann man den Frme in der Größe ändern.

    Tritt dieses Verhalten bei Euch auch auf ?
    Wie kann man das lösen ?

    Zusätzlich habe ich das Problem, dass im Explorer die Eigenschaft "background-color: grey;" bei hover-links ignoriert wird.
    So sieht mein Eintrag in der css-Datei aus:
    a:hover {
    color: red;
    background-color: grey;
    text-decoration: none;
    }

    Das "text-decoration: none;" wird korrekt ausgeführt
    Irgendwelche Hinweise ?

    Danke für die Hilfe im voraus.
     
  2. lengsel

    lengsel MacUser Mitglied

    Beiträge:
    4.627
    Zustimmungen:
    53
    MacUser seit:
    25.11.2003
    Vielleicht kennt Safari die Anweisung nicht?

    &nbsp;

    Die hover-(Farb)anweisung funktioniert (in den meisten Browsern) nur bei Links die man noch nicht besucht hat.

    Grüße,
    Flo
     
  3. maceis

    maceis Thread Starter MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    Re: Re: Probleme mit frameset und css

    &nbsp;
    zu 1: sieht fast so aus; ist aber unverständlich, da dies Standard CSS ist und Apple sich doch sooo damit brüstet, dass Safari coll css konform ist. :mad:

    zu 2: also der Explorer macht "background-color" auch bei nicht besuchten links nicht.
    die andere hover Anweisung wird aber seltsamerweise ausgeführt.

    Manchmal liegt der bei Dir beschrieben Effekt daran, dass für a:visited weiter unten eine Anweisung für color definiert wurde -> immer die letzte Definition in der css-Datei wird umgesetzt.
    Wenn man möchte, dass hover auch für besuchte Links ausgeführt wird, sollte man entweder für a:visited kein "color: " definieren, oder a:hover nach a:visited definieren.
    Im zweiten Fall wird die Farbe für a:visited angezeigt, solange man nicht mit der Maus darüber ist.
     
Die Seite wird geladen...