Problem Safari und Java Applet

Dieses Thema im Forum "Mac OS X Entwickler, Programmierer" wurde erstellt von simpl0r, 09.12.2005.

  1. simpl0r

    simpl0r Thread Starter MacUser Mitglied

    Beiträge:
    22
    Zustimmungen:
    0
    MacUser seit:
    01.11.2005
    Hallo zusammen,

    ich wollte heute zum ersten Mal ein Applet schreiben, aber habe Probleme mit Safari. Er will mein Applet einfach nicht ausführen. Stattdessen sehe ich das hässliche rote Kreuz. Ist das nur eine Einstellungssache oder liegt es am Code?! btw: bei den Safari Einstellungen hab ich Java aktiviert - daran sollte es nit liegen, zumal die Applets diverser Web-Seiten auch fehlerfrei dargestellt werden. Außerdem läuft der Code im appletviewer ja auch einwandfrei ...

    Hier der Code - vielleicht kann mir jemand sagen worans hängt:
    Code:
    /* <applet code="HelloWorld.class" width="300" height="100">
    </applet>
    */
    
    import javax.swing.*;
    
    public class HelloWorld extends JApplet {
        public void init() {
             JLabel label = new JLabel("A Hello World Applet", SwingConstants.CENTER);
             add(label);
        }
    }
    
    Vielen Dank für Eure Hilfe,
    Gruß simple
     
  2. oneOeight

    oneOeight MacUser Mitglied

    Beiträge:
    46.808
    Zustimmungen:
    3.633
    MacUser seit:
    23.11.2004
    wird wohl an den nicht richtigen einbetten mittels tags in das html liegen...
     
  3. simpl0r

    simpl0r Thread Starter MacUser Mitglied

    Beiträge:
    22
    Zustimmungen:
    0
    MacUser seit:
    01.11.2005
    naja. die html datei schaut im einfachsten fall so aus:
    Code:
    <html>
     
    <body>
    <applet code="HelloWorld.class" width="300" height="100">
    </applet>
    </body>
    
    </html>
    
     
  4. Kulfadir

    Kulfadir MacUser Mitglied

    Beiträge:
    816
    Zustimmungen:
    45
    MacUser seit:
    22.06.2005
    Um das Thema nochmal aufzugreifen, ich habe so ein ähnliches Problem.
    Das Java-Applet wird z.B in Firefox richtig angezeigt, jedoch in Safari erschein nur dieser "Legostein" mit dem Fragezeichen.
    Hab das Applet genau wie bei selfhtml beschrieben als object eingebunden.

    <html>
    <head>
    <title>Aufgabe 3</title>
    </head>
    <body>
    <object classid="java:Mondrian.class"
    codetype="application/java-vm" height="500" width="500">
    </object>
    </body>
    </html>

    Was hab ich falsch gemacht oder läuft bei mir falsch?
     
Die Seite wird geladen...

Diese Seite empfehlen