Problem mit Videokompression!!!

Dieses Thema im Forum "Digital Video" wurde erstellt von Jhonny Jumper, 07.09.2006.

  1. Jhonny Jumper

    Jhonny Jumper Thread Starter MacUser Mitglied

    Beiträge:
    156
    Zustimmungen:
    0
    MacUser seit:
    04.02.2005
    So hab folgendes Problem:

    Hab ein Film aus iMovie heraus exportiert, als Einstellung verwendete ich die ipod Eintellung aus dem Menü aus. Möchte das Video im Internet veröffentlichen und fand die Quali von der Einstellung am besten, Dateigröße ist auch kein Problem die Datei kann laut youtube.com 10 min lang und 100mb groß sein meine ist etwas über 20mb groß und auch nur knapp 4min lang. Dürfte also da dran nicht liegen. Hab die Datei dann hochgeladen und wollte sie mir dann später angucken. Nur war wohl nix, der Player spielt nur einzelne Szenenbilder ab und der Sound läuft weiter.

    Hab danach noch ne ander Kompression von dem ipod komprimierten Film erstellt und sie zu testzwecken hochgeladen. Sie funktioniert, doch mit der Qualität des Video bin ich absolut nicht zufrieden. Wo dran liegst?


    Evtl. an der Bildrate die bei der ipod Einstellung höher ist?

    Version 1: http://www.youtube.com/watch?v=maJL1OF0VUg
    Version 2: http://www.youtube.com/watch?v=wCqieqWmpIw


    Über Tips wär ich echt dankbar!

    Gruß, vom Chris
     
  2. k_munic

    k_munic MacUser Mitglied

    Beiträge:
    8.928
    Zustimmungen:
    1.101
    MacUser seit:
    23.07.2006
    könntest Du uns mal die settings im einzelnen posten?
    youtube möcht 320x240 (1/4tel NTSC), was ja für uns PALuser suboptimal ist... und liefert aus als .flv mit 30fps..

    dachte bei deinem ersten Bsp, Du hast Photos zu Musik gemacht...

    Ich teste mir seit einige Zeit auch'n Wolf (youtube wird meine aufregenden testfiles (Blick ausm Fenster, bewegtes Laub + rote Titel) lieben..;-) )... da ich noch mit QT6 hantiere, nutze ich gern mpeg4/encoding mit iSquint... je höher die bitrate (bei dem kleinen Format sind das wohl 500 - 700 b/sec), umso schöner. Noch schöner wäre wohl, wenn man direkt vom source (bei mir alles DV) zu flv wandelt, innerhalb der youtube specs...- hab nur ffmpeg, finde die Ergebisse nicht so berauschned, stottert, kann aber auch an meinem ollen Rechner liegen...

    also, mit welchem codec (denke h264?) und mit welcher bitrate haste die beiden gemacht? und von DV vermute ich? die Bildqualität ist bei der "Diashow" nämlich schon lekka...

    (falls Interesse: suche nach "codexx" ... die settings stehen im Text/Titel...)
     
  3. 2nd

    2nd MacUser Mitglied

    Beiträge:
    8.902
    Zustimmungen:
    242
    MacUser seit:
    25.07.2004
    @k_munich: Wie kommst Du auf 320x240 und NTSC? NTSC hat als 480i 720x480@30 fps. und nicht 1280x960px.

    Wie das Videoencoding bei Youtube im Einzelnen abläuft, kann ich nicht sagen, die haben sich sicherlich ihren eigenen Demon, der in den On2 Vp6 Codec konvertiert.

    Was aber generell ein Problem ist: Von einem Distributionsformat (H.264) in ein anderes (On2 Vp6 Flash Video) zu rechnen schafft keine Zufriedenheit. Meistens kommen die Encoder nicht mit der Interframes etc. klar und deswegen gibt das abgehackte Bilder.

    Am besten ist es, gleich aus dem NLE in das Zielformat umzuwandeln, in dem Fall in Flash Video.

    Ich habe mir gerade das Helpcenter bei YouTube angeschaut, im Prinzip steht da die Lösung:

    Auf diese MPEG4 Derivate wird der Kodier-Demon optimiert sein, also würde ich die Video vorher so vorbereiten. Theoretisch sollte das unabhängig von der Fernsehnorm sein, was YouTube draus macht.

    2nd
     
  4. Jhonny Jumper

    Jhonny Jumper Thread Starter MacUser Mitglied

    Beiträge:
    156
    Zustimmungen:
    0
    MacUser seit:
    04.02.2005
    da ich Quicktime Pro verwende gibts da halt ne Export variante die sich ipod (320x240) nennt die Quali davon ist einfach nur die beste ereiche mit keiner anderen Einstellung annähernd diese Qualität. Nur versteh nicht warum das bei YouTube nicht funzt mit dieser Einstellung erstellt Quicktime ein MPEG4 Video File.

    Zu dir k_munic: Bei der schlechten Variante hab ich den h264 Codec genommen nur die Quali entäuscht mich sehr viele Deatails verschwinden völlig im dunkel.

    Wenn ich direkt als FlashVideo exportier müsst es doch eigentlich gehen oder?
     
  5. Jhonny Jumper

    Jhonny Jumper Thread Starter MacUser Mitglied

    Beiträge:
    156
    Zustimmungen:
    0
    MacUser seit:
    04.02.2005
  6. k_munic

    k_munic MacUser Mitglied

    Beiträge:
    8.928
    Zustimmungen:
    1.101
    MacUser seit:
    23.07.2006
    hast Recht, aber 1280x960px wäre das achtfache meiner - falschen! - Auflösung ;), wurscht, bei mir im Kopp steht immer 640x480 = NTSC... pfalsch..

    Aber:
    Was Du da so gelassen aussprichst, ist eben genau die Krux: es macht wenig Sinn, von einem Deliveryformat nochmals umzucodieren... daher ja auch meine "verzweifelte" Suche nach DEM upload codec/Verfahren. Meine Möglichkeiten sind sehr begrenzt, hab zB kein Adobe Flash, kann also den von Dir genannten .flv codec nicht heimisch erzeugen... und das, was ich mit ffmpeg erzeuge, sieht wirklich nich schee aus....- (ruckelt zB)

    Auch wenn's ewig dauert hochzuladen: ein "anständige" kodiertes mpeg4 liefert bisher die besten Ergebnisse, trotz der Winzgröße muss man wohl deutlich mehr als 500kB/sec investieren...

    Wäre halt mal spannend, wenn jemand mit echtem, $$$ Adobe Flash, ein paar Testfiles encoded und hochladen würde... incl. settings natürlich. Und natürlich keine "Kunst"Videos (nix gg Dich Johnny! schön geworden, aber zum Testen ungeeignet), sondern wo man mal gucken kann: Details, Kanten, Artifakte im Dunklen, schnelle Bewegungen etc....-

    naja, die Pros interessieren sich für sowas nich...
    Wäre mal n Thema für die Fachzeitungen... ;)
     
Die Seite wird geladen...