Problem mit Installation, bitte um Hilfe

Diskutiere mit über: Problem mit Installation, bitte um Hilfe im Mac OS X - Unix & Terminal Forum

  1. Rich-motors

    Rich-motors Thread Starter MacUser Mitglied

    Beiträge:
    1
    Zustimmungen:
    0
    Registriert seit:
    26.02.2007
    Hallo,
    ich habe ein Problem ist eine Installation eines Programm (megatunix-0.9.8) auf OS 10.3

    Ich habe Darwinport installiert also ich habe die Datei entpackt und Installiert. Dann habe ich im Termimal Fenster folgende Befehle eiungegeben.

    sudo port -d selfupdate
    sudo port install gtkglext libglade2


    Hab den Mac gut 1 Stunde laufen gelassen und habe folgende Meldung bekommen.

    Richie-s-Computer:~ Richie$ sudo port install gtkglext libglade2
    ---> Fetching expat
    ---> Attempting to fetch expat-2.0.0.tar.gz from http://easynews.dl.sourceforge.net/expat
    ---> Verifying checksum(s) for expat
    ---> Extracting expat
    ---> Configuring expat
    ---> Building expat with target all
    ---> Staging expat into destroot
    ---> Installing expat 2.0.0_1
    ---> Activating expat 2.0.0_1
    ---> Cleaning expat
    ---> Fetching libiconv
    ---> Attempting to fetch libiconv-1.11.tar.gz from ftp://ftp.gnu.org/gnu/libiconv
    ---> Verifying checksum(s) for libiconv
    ---> Extracting libiconv
    ---> Configuring libiconv
    ---> Building libiconv with target all
    Error: Target com.apple.build returned: shell command "cd /opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_textproc_libiconv/work/libiconv-1.11 && make -f Makefile.devel" returned error 2
    Command output: gcc -O lib/genaliases.c -o genaliases
    ./genaliases > lib/aliases.gperf 3> canonical.sh 4> canonical_local.sh
    rm -f genaliases
    gperf -m 10 lib/aliases.gperf > tmp.h
    gperf: invalid option -- m
    Usage: gperf [-cCdDef[num]F<initializers>GhH<hashname>i<init>Ijk<keys>K<keyname>lL<language>nN<function name>ors<size>S<switches>tTvW<wordlistname>Z<class name>7] [input-file]
    Try `gperf --help' for more information.
    make: *** [lib/aliases.h] Error 1

    Error: The following dependencies failed to build: gtk2 atk glib2 gettext libiconv pkgconfig libpng zlib pango Xft2 fontconfig freetype xrender render cairo tiff jpeg
    Error: Status 1 encountered during processing.
    Richie-s-Computer:~ Richie$


    Ich verstehe das nicht!??
    Wenn ich dann versuche das Programm Megatunix
    mit

    ./configure --prefix=/opt/local
    make
    sudo make install


    zu installieren dann bekomme ich diese meldung:

    checking for GTK... checking for GTK... configure: error: Package requirements (gtk+-2.0 >= 2.4.0 gthread-2.0) were not met:

    Package gtk+-2.0 was not found in the pkg-config search path.
    Perhaps you should add the directory containing `gtk+-2.0.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'gtk+-2.0' found

    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.

    Alternatively, you may set the environment variables GTK_CFLAGS
    and GTK_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.

    Richie-s-Computer:~/megatunix-0.9.8 Richie$ make
    make: *** No targets specified and no makefile found. Stop.
    Richie-s-Computer:~/megatunix-0.9.8 Richie$ sudo make install
    Password:
    make: Nothing to be done for `install'.
    Richie-s-Computer:~/megatunix-0.9.8 Richie$


    Habe dann versuch gtk+-2.0.6 mit
    ./configure --prefix=/opt/local
    make
    sudo make install


    zu Installieren, da bekomme ich diese Meldung:

    checking for BASE_DEPENDENCIES... configure: error: Package requirements (glib-2.0 >= 2.12.0 atk >= 1.9.0 pango >= 1.12.0 cairo >= 1.2.0) were not met:

    Package glib-2.0 was not found in the pkg-config search path.
    Perhaps you should add the directory containing `glib-2.0.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'glib-2.0' found

    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.

    Alternatively, you may set the environment variables BASE_DEPENDENCIES_CFLAGS
    and BASE_DEPENDENCIES_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.

    Richie-s-Computer:~/gtk+-2.10.6 Richie$ make
    make: *** No targets specified and no makefile found. Stop.
    Richie-s-Computer:~/gtk+-2.10.6 Richie$ sudo make install
    make: Nothing to be done for `install'.
    Richie-s-Computer:~/gtk+-2.10.6 Richie$


    Habe dann versuch glib-2.12.9 mit
    ./configure --prefix=/opt/local
    make
    sudo make install


    zu installieren, da kam folgend Meldung:

    configure: error:
    *** You must have either have gettext support in your C library, or use the
    *** GNU gettext library. (http://www.gnu.org/software/gettext/gettext.html

    Richie-s-Computer:~/glib-2.12.9 Richie$ make
    make: *** No targets specified and no makefile found. Stop.
    Richie-s-Computer:~/glib-2.12.9 Richie$ sudo make install
    make: Nothing to be done for `install'.
    Richie-s-Computer:~/glib-2.12.9 Richie$


    Habe dann gettext-14.0.5 Installiert das hat funktioniert.
    Ich habe absolut keine Ahnung mehr was ich tun soll. Hab alle möglichen foren, Suchmaschienen usw abgeklappert aber nicht gefunden.
    Eine Anleitung zu Installieren des Programm hab ich gefunden die ist hier:

    http://www.msefi.com/viewtopic.php?t=25026

    aber die funktioniert nicht bei mir. warum?
    Kann es villeicht daran liegen das ich fink und Darwinport installiert habe oder ausversehen Darwinport 1.3.1-10.4 instaliert habe dann erst 1.3.1-10.3??
    Bitte dringend um Hilfe da ich mich kaum mit Mac auskenne.
     
  2. kiu

    kiu MacUser Mitglied

    Beiträge:
    601
    Zustimmungen:
    1
    Registriert seit:
    26.04.2004
    Hi,

    ich versuche grad libgphoto zu installieren.

    - ./configure ohne probleme
    - make ergibt "make: *** No targets specified and no makefile found. Stop."

    Muß ich in einem bestimmten Verzeichnis sein? Habe MacPorts 1.6 installiert.
    Im entpackten Verzeichnis liegen Makefile.am und Makefile.in, ist das richtig so oder fehlt noch etwas mit Makefile* ??

    Danke für Eure Gedanken

    kiu


    Packageinhalt:

    AUTHORS Makefile.in autom4te.cache configure libtool
    COPYING NEWS compile configure.ac ltmain.sh
    ChangeLog README config.guess depcomp m4m
    INSTALL aclocal.m4 config.log install-sh missing
    Makefile.am autogen.sh config.sub installcheck.mk src
     
    Zuletzt bearbeitet: 30.09.2008
  3. avalon

    avalon MacUser Mitglied

    Beiträge:
    24.795
    Zustimmungen:
    1.865
    Registriert seit:
    19.12.2003
    Warum lässt du nicht einfach die Finger von ominösen Tuning Tools, die kein Mensch braucht, vor allem nicht auf einem Mac. ;)
    http://megatunix.sourceforge.net/
     
  4. AgentMax

    AgentMax Super Moderator

    Beiträge:
    37.204
    Zustimmungen:
    4.052
    Registriert seit:
    03.08.2005
    Ich denke sein Problem hat sich seit dem 26-02-2007, 21:36 gelöst ;)
     
  5. avalon

    avalon MacUser Mitglied

    Beiträge:
    24.795
    Zustimmungen:
    1.865
    Registriert seit:
    19.12.2003
    @AgentMax

    :D Bin wohl etwas unaufmerksam zur späten (frühen) Stunde....
     
  6. kiu

    kiu MacUser Mitglied

    Beiträge:
    601
    Zustimmungen:
    1
    Registriert seit:
    26.04.2004
    hab ich auch grad gesehen, hihi.
    meine frage von oben hat sich auch schon erledigt. war n genereller gedankenansatz der fehlte, jetzt bin ich zum glück schon beim nächsten problem... das muß ich erstmal analysieren...
     
Die Seite wird geladen...
Ähnliche Themen - Problem Installation Hilfe Forum Datum
Problem bei der Ausführung von Perl Skripten über SSH Mac OS X - Unix & Terminal 22.10.2013
MacPorts Problem Mac OS X - Unix & Terminal 06.10.2013
XNEST funktioniert - aber Wirrwarr bei Zeichenkodierung / Keybord mapping Problem Mac OS X - Unix & Terminal 05.10.2013
Problem mit PostgreSQL und PostGIS Mac OS X - Unix & Terminal 09.09.2013
Problem bei Installation mittels Darwinport Mac OS X - Unix & Terminal 29.07.2006

Diese Seite empfehlen

Benutzerdefinierte Suche