Problem mit Forum!

Diskutiere mit über: Problem mit Forum! im Web-Programmierung Forum

  1. allesinmac

    allesinmac Thread Starter MacUser Mitglied

    Beiträge:
    113
    Zustimmungen:
    0
    Registriert seit:
    28.09.2003
    Hallo,

    ich habe gerade ein riesen Problem beim Installieren des Forums.

    Jedesmal wenn ich meine Datenbank-Daten eingeben hab, und ich drück auf speichern, kommt diese Fehlermeldung:

    Warning: Cannot add header information - headers already sent by (output started at /mnt/be2/03/833/00000002/htdocs/bo/_functions.php:4153) in /mnt/be2/03/833/00000002/htdocs/bo/install.php on line 2899



    Alle Rechte sind auf 777 gestellt!

    Weis jemand warum es nicht geht?
     
  2. Thommy

    Thommy MacUser Mitglied

    Beiträge:
    1.833
    Zustimmungen:
    0
    Registriert seit:
    23.06.2003
    die meldung bedeutet, das schon etwas ausgegeben wurde BEVOR irgendein header() befehl oder setcookie() folgt. d.h. alle header infos müssen am anfang sein. also z.b. kann ein cookie nicht innerhalb des files gesetzt werden. immer am anfang bevor irgendeine ausgabe an den Browser erfolgt.

    ob_start() löst dieses Problem, wenn du am anfang des files ob_start(); schreibst und am ende des files ob_clean(); dann wird das gesammte dokument gepuffert ausgeführt und erst nach ausführen des skript an den browser gesendet. d.h. dann kann überall eine header info ausgegeben werde.
     
  3. allesinmac

    allesinmac Thread Starter MacUser Mitglied

    Beiträge:
    113
    Zustimmungen:
    0
    Registriert seit:
    28.09.2003
     

    Das Forum ist ein "FertigForum". Da kann ich nix verstellen und wüsste auch gar nicht wo ich das einstellen müsste.
     
Die Seite wird geladen...
Ähnliche Themen - Problem Forum Forum Datum
XAMPP Problem mit Zugriffsrechte Web-Programmierung 30.04.2014
Syntax Problem PHP Variable an JS-Funktion Web-Programmierung 12.09.2013
Swiftmailer Problem mit der Danke-Seite Web-Programmierung 03.07.2013
PHP anfänger Problem Web-Programmierung 17.05.2013
Problem mit Klassen und protected... Web-Programmierung 04.03.2013

Diese Seite empfehlen

Benutzerdefinierte Suche