[PROBLEM!] Datei mit bestimmter Endung mit bestimmten Programm öffnen

Dieses Thema im Forum "Mac OS X" wurde erstellt von r3i_weN, 08.05.2006.

  1. r3i_weN

    r3i_weN Thread Starter MacUser Mitglied

    Beiträge:
    8
    Zustimmungen:
    0
    MacUser seit:
    05.02.2006
    Hallo Macuser!

    Ich habe folgendes Problem: Ich schreibe sehr viel Ada-Code für die Uni (nein, das ist noch nicht das Hauptproblem :D ) und möchte daher alle Dateien, die mit .adb oder .ads enden mit meinem geliebten vim (Habe diesen vim for MacOSX) öffnen.
    Ich gehe dazu in die Eigenschaften einer .adb-Datei und wähle bei "Öffnen mit" den Vim aus. Standardmäßig steht dort TextEdit. Ob ich "Immer mit diesem Programm öffnen" auswähle oder nicht beinflusst das Verhalten übrigens nicht.
    Anschließend wähle ich "Alle ändern" aus und bestätige die Nachfrage ob ich alle Vim-Dokumente mit Vim öffnen will ("Diese Änderung betrifft alle Vim-Dokumente mit dem Suffix ".adb"" steht da extra noch!) mit "Fortfahren".
    Und jetzt kommt das Problem: Sobald ich auf Fortfahren klicke, steht bei "Öffnen mit" wieder TextEdit drin. Ich kann das so oft machen, wie ich will, immer das gleiche Resultat. Bei einem Kollegen verhält es sich genau gleich.
    Deswegen wollte ich fragen, ob jemand das Problem und vor allem auch ne Lösung dafür kennt?

    MfG
    r3i_weN

    --Edit:
    Zuvor stand statt TextEdit immer XCode drin, da passierte genau das selbe. Als ich dann verzweifelt XCode gelöscht hab, gings mit TextEdit weiter... nur als Ergänzung, falls das helfen sollte.
     
  2. Markus87

    Markus87 MacUser Mitglied

    Beiträge:
    1.966
    Zustimmungen:
    57
    MacUser seit:
    23.07.2004
    Wie ich es kenne, musst Du zuerst eine Datei mit der gewünschten Endung auswählen. Danach gehst Du unter Informationen und suchst das Programm heraus mit dem die Dateien geöffnet werden sollen. Zum Schluss noch auf Alle ändern drück und das sollte es gewesen sein.
     
  3. r3i_weN

    r3i_weN Thread Starter MacUser Mitglied

    Beiträge:
    8
    Zustimmungen:
    0
    MacUser seit:
    05.02.2006
    Hast du meinen Beitrag durchgelesen? Genau so habe ich es gemacht, aber so tuts nicht.
    Deswegen suche ich ja nach ner anderen Methode wie ich das evtl. einstellen könnte (Config-Datei oder sowas)
     
  4. Markus87

    Markus87 MacUser Mitglied

    Beiträge:
    1.966
    Zustimmungen:
    57
    MacUser seit:
    23.07.2004
    Entschuldige! War gestern wohl etwas müde. ;)
     
  5. Lars²

    Lars² MacUser Mitglied

    Beiträge:
    187
    Zustimmungen:
    2
    MacUser seit:
    31.12.2005
    Schonmal die Rechte repariert? Hilft doch immer dann wenn nichts anderes mehr hilft.
     
  6. r3i_weN

    r3i_weN Thread Starter MacUser Mitglied

    Beiträge:
    8
    Zustimmungen:
    0
    MacUser seit:
    05.02.2006
    Hilft leider auch nicht.
     
  7. NvOndarza

    NvOndarza MacUser Mitglied

    Beiträge:
    231
    Zustimmungen:
    0
    MacUser seit:
    23.11.2004
    Vielleicht musst du für die Aktion administrator rechte haben?
     
  8. r3i_weN

    r3i_weN Thread Starter MacUser Mitglied

    Beiträge:
    8
    Zustimmungen:
    0
    MacUser seit:
    05.02.2006
    Hab ich, aber es geht trotzdem nicht.
     
  9. eMac_man

    eMac_man MacUser Mitglied

    Beiträge:
    32.956
    Zustimmungen:
    2.891
    MacUser seit:
    08.10.2003
    Hallo und guten Morgen!
    Vielleicht bringt es ja was, mit "Onyx" bspw. die Programmzuordnung zurückzusetzen. Diese Option findest Du im Programm "Onyx" im Register "Optimierung".
    Gruss
    der eMac_man
     
  10. r3i_weN

    r3i_weN Thread Starter MacUser Mitglied

    Beiträge:
    8
    Zustimmungen:
    0
    MacUser seit:
    05.02.2006
    Danke für den Tipp, aber auch das funktioniert leider nicht :/
     
Die Seite wird geladen...

Diese Seite empfehlen