Preloader funktioniert nicht, Flash MX 6

Diskutiere mit über: Preloader funktioniert nicht, Flash MX 6 im Flash and Actionscript Forum

  1. Fantômas

    Fantômas Thread Starter Gast

    Hi,
    ich habe einen Preloader vor einen Flash-Film geschaltet, aber er
    funktioniert scheinbar nicht.
    Im Internet lädt er nicht bzw. läuft nicht weiter...

    Im ersten frame habe ich einen Loop mit »Bitte warten - der Film wird geladen...« platziert.
    Der Frame mit dem Label »start« markiert den Anfang des Films.

    Der Flash-Film selbst ist interaktiv, daher habe ich mit verschiedenen
    Unterfilmen auf der Timeline gearbeitet und spreche diese mit der tell target-Funktion an.
    Ich weiss, dies ist nicht der eleganteste Weg, entspricht aber am ehesten meinem
    Kenntnisstand als »Ab-und-zu-Flasher« :teeth:

    Arbeite noch mit Flash MX 6.0, kann wer helfen?
    Thx
    Ollo

    Der Code ist:


    if (_framesloaded=_totalframes) {
    gotoAndPlay("start");
    } else {
    gotoAndPlay(1);
    }
     
  2. 2nd

    2nd MacUser Mitglied

    Beiträge:
    8.902
    Zustimmungen:
    242
    Registriert seit:
    25.07.2004
    Oh my god, das ist ja mal richtig 0ldsch00l :D

    Das Label hast Du gesetzt, also den Frame benannt? Das Script liegt auf dem 2. Frame? "Start" kommt dahinter? Vielleich kannst Du mal die FLA Datei hier anhängen, Du kannst ja die relevanten Sachen rausnehmen und nur ein Gerippe hier posten :)

    2nd
     
  3. Fantômas

    Fantômas Thread Starter Gast

    Hi 2nd,
    irgendwie wusste ich vorher, dass ich mich damit bei Euch lächerlich mache... :D
    Du hast ja recht!
    Ich benutze Flash sehr selten, ab und zu mal ein paar Internetbanner und alle
    Jubeljahre mal eine Präsentation so wie diese hier.

    Aber - ich bin auch lernfähig, habe mich nämlich in der Zwischenzeit umgeschaut und ein Preloader-Tutorial gefunden, das sogar ich verstehe! :cool:

    Jetzt FUNKTIONIERT'S!

    Danke nochmal fürs Feedback!
     
  4. 2nd

    2nd MacUser Mitglied

    Beiträge:
    8.902
    Zustimmungen:
    242
    Registriert seit:
    25.07.2004
    Du machst Dich nicht lächerlich. Die Seite sieht gut aus! Vor allem dafür, dass Du völlig tiefstapelst :) Meine ich wirklich ernst!

    2nd
     
  5. Fantômas

    Fantômas Thread Starter Gast

    Oh... :faint:
    Danke... :)

    Ich hab' nun mal einen »Ich-kann-kein-Actionscript«-Minderwertigkeitskomplex...

    Aber ich arbeite dran, wie man heute gesehen hat...
     
Die Seite wird geladen...
Ähnliche Themen - Preloader funktioniert Flash Forum Datum
Scrollbar funktioniert erst beim 2. Laden?!? Flash and Actionscript 07.06.2009
txeff funktioniert nicht richtig... Flash and Actionscript 24.04.2009
Problem mit Preloader + Page laggt Flash and Actionscript 17.07.2008
Simpler PreLoader Flash and Actionscript 01.05.2004
Flash Preloader fängt erst bei 20% an????? Flash and Actionscript 09.09.2003

Diese Seite empfehlen

Benutzerdefinierte Suche