phpmyadmin nimmt kein root pw

Dieses Thema im Forum "Mac OS X - Unix & Terminal" wurde erstellt von mikeIV, 03.01.2004.

  1. mikeIV

    mikeIV Thread Starter MacUser Mitglied

    Beiträge:
    269
    Zustimmungen:
    0
    MacUser seit:
    19.08.2003
    Hallo ich hab mir mal mysql/apache/php installiert im os x. mysql läuft perfekt. ich kann auch aus der shell mit dem root user connecten. aber sobald ich das über phpmyadmin probiere meint er immer das der login oder pw falsch sind.

    auth ist über http

    $cfg['Servers'][$i]['auth_type'] = 'http'; // Authentication method (config, http or cookie based)?

    weis da jemand was es da haben könnte?
     
  2. Woulion

    Woulion MacUser Mitglied

    Beiträge:
    1.310
    Zustimmungen:
    0
    MacUser seit:
    06.06.2002
    Hi

    Du weisst ja sicher, das der root in mySQL ein anderer als der root im OS ist und in mySQL per default dem root-Account kein Password zugeordnet ist.

    HTH

    W
     
  3. mikeIV

    mikeIV Thread Starter MacUser Mitglied

    Beiträge:
    269
    Zustimmungen:
    0
    MacUser seit:
    19.08.2003
    sicher weis ich das ;)

    also meine erkenntnisse bis jetzt nach stunden des herumbasteln.

    1. mysql läuft
    2. es sind div. user angelegt die auf verschiedene tables zugriff haben (soll meine websites lokal simulieren)
    3. wenn ich eine meiner webseiten über http://localhost aufrufe greifen diese user ohne probleme auf die db und lesen den content brav aus
    4. wenn ich über den terminal "mysql -uuser -ppassword" mache komme ich auch ohne probleme rauf.

    einzig und allein übers phpmyadmin geht es nicht. was ich aber gemerkt habe ist das ich mich als mike (so heist auch der user mit dem ich angemeldet bin) ohne passwort connecten kann, jedoch jeder user denmn ich angelegt habe funktioniert hier nicht. es gibt auserdem keinen user mike denn ich mit mysql angelegt habe. strange?

    ich hab ja schon auf div. systemen apache/mysql/php zum laufen gebracht aber das hier stellt mich vor ein rätsel.
     
Die Seite wird geladen...
Ähnliche Themen - phpmyadmin nimmt kein
  1. oldhell
    Antworten:
    0
    Aufrufe:
    712
    oldhell
    28.02.2015
  2. dasasa
    Antworten:
    4
    Aufrufe:
    2.111
    dasasa
    15.12.2013
  3. pucicu
    Antworten:
    7
    Aufrufe:
    2.468
    pucicu
    25.10.2011
  4. sbreit
    Antworten:
    4
    Aufrufe:
    1.288
    sbreit
    15.12.2006
  5. bellringer
    Antworten:
    3
    Aufrufe:
    522
    bellringer
    08.05.2006