phpbb2 <-> umlaute <-> kodierung ?

Dieses Thema im Forum "Web-Programmierung" wurde erstellt von misterbecks, 14.06.2005.

  1. misterbecks

    misterbecks Thread Starter MacUser Mitglied

    Beiträge:
    2.159
    Zustimmungen:
    16
    MacUser seit:
    06.11.2004
    Ich versuche gerade ein paar Sachen in einem phpbb2-Forum umzugestalten, aber leider erreiche ich mit keiner Kodierung, dass die Umlaute dargestellt werden. Ich benuzte im Moment SubEthaEdit und vorher TacoHtml.

    Was mache ich falsch und/oder wie kann ich das Problem beheben?
     
  2. msslovi0

    msslovi0 MacUser Mitglied

    Beiträge:
    2.713
    Zustimmungen:
    115
    MacUser seit:
    20.03.2005
    Mit Entitäten bist du immer auf der sicheren Seite (also &auml; für ä, &ouml; für ö usw.).

    Ansonsten: SubEthaEdit arbeitet standardmäßig mit Mac OS Lateinisch. Für einen Linux- oder Windowsserver muss das nach iso-8859-1 konvertiert werden. Also Format -> Dateikodierung -> Westeuropäisch (ISO Latin 1) -> Neu interpretieren. Das ergibt dann im Browser die richtige Umlautdarstellung. Wenn du das Dokument allerdings erneut öffnest, hast du Zeichensalat (ˆ‰¸fl anstatt aöüß), da SubEthaEdit wieder mit Mac OS Lateinisch öffnet.

    Matt
     
  3. misterbecks

    misterbecks Thread Starter MacUser Mitglied

    Beiträge:
    2.159
    Zustimmungen:
    16
    MacUser seit:
    06.11.2004
    Genau dieser Schritt hat gefehlt, vielen Dank. Ich hatte das File nach der neuen Kodierung immer konvertiert....
     
Die Seite wird geladen...
Ähnliche Themen - phpbb2 umlaute kodierung
  1. mad dog
    Antworten:
    8
    Aufrufe:
    1.156
    Labrar
    25.02.2013
  2. Galanos
    Antworten:
    13
    Aufrufe:
    5.146
    Galanos
    22.02.2010
  3. HerrVorragend
    Antworten:
    11
    Aufrufe:
    5.476
    balufreak
    29.07.2008
  4. StephanSch
    Antworten:
    4
    Aufrufe:
    1.659
    StephanSch
    14.04.2008
  5. patrick1983
    Antworten:
    0
    Aufrufe:
    455
    patrick1983
    27.12.2004