PHP Version 4.3.10 – Einbinden/Aktivieren der GD-Bibliothek?

Dieses Thema im Forum "Web-Programmierung" wurde erstellt von SirJoker, 24.08.2006.

  1. SirJoker

    SirJoker Thread Starter MacUser Mitglied

    Beiträge:
    422
    Zustimmungen:
    0
    MacUser seit:
    29.10.2004
    Hi,

    nach meinem Verständnis ist in der oben genannten PHP Version die GD-Bibliothek enthalten aber noch nicht aktiviert.

    Wie krieg ich die aktiviert? Die php.ini hab ich schon durch und nix gefunden (Außer Aktivierung für Win, was mir ja nicht so viel hilft;) ).

    Ich möchte eigentlich im Moment noch nicht PHP auf neueste Version bringen. Dann muss ich ja wieder alle möglichen Einstellungen vornehmen (phpMyAdmin, mysql..) Da hab ich jetzt kein Bock drauf...
     
  2. wegus

    wegus MacUser Mitglied

    Beiträge:
    15.045
    Zustimmungen:
    1.318
    MacUser seit:
    13.09.2004
    ob die gdlib dabei ist oder nicht wird bei der Compilierung mit dem switch --with-gd festgelegt!

    der Befehl phpinfo() zeigt dann auch eine eigene gd-Sektion an. Ob features in php statisch enthalten sind, geht nicht unbedingt immer aus der VersionsNr. hervor!
     
  3. SirJoker

    SirJoker Thread Starter MacUser Mitglied

    Beiträge:
    422
    Zustimmungen:
    0
    MacUser seit:
    29.10.2004
    Junge bist Du schnell...:D

    Also phpinfo() zeigt mir nix an. Meine PHP-Version ist die Standart-Version von MacOSX 10.2.

    Dann führt wohl kein Weg an dem Upgrade auf PHP 5 vorbei oder kann ich gdlib nachrüsten? Ich vermute aber das PHP-Upgrate nicht so kompliziert wäre. Vom kompilieren hab ich null Ahnung...
     
  4. wegus

    wegus MacUser Mitglied

    Beiträge:
    15.045
    Zustimmungen:
    1.318
    MacUser seit:
    13.09.2004
    nimm die Pakete von entropy.ch!
    Da ist alles Wesentliche drinn, die php.ini liegt an neuer Stelle ( /usr/local/php/...) und Du kannst die ini somit Schritt für Schritt anpassen. Neu compilieren ist an sich ganz einfach, bis Du aber alle nötigen Sources für ein PHP auf dem Rechner hast dauerts...

    EDIT: bin nicht schnell, war nur gerade online :)
     
  5. SirJoker

    SirJoker Thread Starter MacUser Mitglied

    Beiträge:
    422
    Zustimmungen:
    0
    MacUser seit:
    29.10.2004
    OK, werde ich mir PHP von dort in neuseter Version holen.

    Die Seite entropy.ch ist im Moment nicht zu erreichen...

    EDIT: Ach ja: DANKE :D
     
  6. wegus

    wegus MacUser Mitglied

    Beiträge:
    15.045
    Zustimmungen:
    1.318
    MacUser seit:
    13.09.2004
    das gibt mir noch ne kurze Chance:

    Der Download von entropy.ch ist sehr groß! Der Grund: Du bekommst die wichtigsten Bibliotheken und ein aktuelles PEAR gleich mitinstalliert! Also nicht wundern, des paßt scho ;)
     
  7. SirJoker

    SirJoker Thread Starter MacUser Mitglied

    Beiträge:
    422
    Zustimmungen:
    0
    MacUser seit:
    29.10.2004
    Moins Wegus,

    hat schon alles geklappt. Bin über Umwege noch auf die Seite von entropy.ch gekommen (www.entropy.ch funzt bis heute nicht...).

    GD-Bibliothek ist drin...nur mit meinen PHP-Künsten bezüglich einer Programmierung einer Bilder-Datenbank haperts noch ein bissl..:rolleyes:

    Aber dat werde ich schon hinbekommen...;)

    (Und falls nicht, ich weiß ja an wen ich mich wenden muss...
    :D )

    Danke nochmal
     
Die Seite wird geladen...
Ähnliche Themen - PHP Version –
  1. alex1000
    Antworten:
    5
    Aufrufe:
    159
    pmau
    26.08.2016
  2. mad dog
    Antworten:
    19
    Aufrufe:
    2.085
    MacEnroe
    14.08.2015
  3. 404
    Antworten:
    0
    Aufrufe:
    483
  4. Akeno
    Antworten:
    5
    Aufrufe:
    1.189
    Akeno
    12.09.2014
  5. macboehni
    Antworten:
    2
    Aufrufe:
    933
    macboehni
    24.01.2014