PHP nach Softwareupdate kaputt!

Dieses Thema im Forum "Web-Programmierung" wurde erstellt von MacErik, 26.09.2004.

  1. MacErik

    MacErik Thread Starter MacUser Mitglied

    Beiträge:
    632
    Zustimmungen:
    12
    MacUser seit:
    06.09.2002
    Hallo zusammen,
    ich habe gestern System-Updates eingespielt:
    "Security Update 2004-08-09" (1.0)
    "Java 1.4.2 Update 2" (1.4.2 Update 2)
    "Security Update 2004-09-07" (1.1)
    "Mac OS X Update" (10.3.5)
    Seitdem funktioniert PHP auf dem lokalen Webserver nicht mehr. Dateien mit der Endung .php werden heruntergeladen und nicht angezeigt.
    Wenn ich im Terminal "tail /var/log/httpd/error_log" eingebe bekomme ich: "Apache/1.3.29 (Darwin) DAV/1.0.3 PHP/4.3.2 mod_perl/1.26 configured -- resuming normal operations".
    Also eigentlich alles OK. Weiß vielleicht jemand Rat?
    Danke
    Erik
     
  2. cordney*

    cordney* MacUser Mitglied

    Beiträge:
    755
    Zustimmungen:
    24
    MacUser seit:
    22.04.2003
    Ich denke, dass es eher etwas mit Deinem Browser zu tun hat. Ohne installiertes PHP zeigt er in Deinem Browser-Fenster nämlich nur den Quelltext der .php-Dateien, weil der Parser fehlt.

    Wie das zu beheben geht kann ich Dir leider auch nicht sagen. Bei mir funzt alles reibungslos.
     
  3. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    mach doch mal bitte folgendes im Terminal und poste die Ausgabe:
    printf 'HEAD / HTTP/1.0\n\n' | nc -w 10 localhost 80 | grep Server
     
  4. wegus

    wegus MacUser Mitglied

    Beiträge:
    15.045
    Zustimmungen:
    1.318
    MacUser seit:
    13.09.2004
    Da ist wohl ungefragt die httpd.conf überschrieben worden! Apache gibt php als Textdateien wieder, solange er nicht durch folgende Zeile:

    application/x-httpd-php phtml pht php

    veranlasst wird PHP mit der Auswertung zu beauftragen. Zusätzlich muß PHP mit einer LoadModule und einer AddModule-Anweisung in httpd.conf aktiviert worden sein. Schau mal nach, sicher gibt es ein backup Deiner alten httpd.conf! Ist aber schon dreist, daß ein update das überschreibt!
     
  5. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    @wegus
    die Vermutung ist berechtigt, aber ich glaub da noch nicht so recht dran.
    Ich habe hier auch nen lokalen WebServer laufen, aber bei mir wurde von den Updates die httpd.conf nicht überschrieben.
     
  6. MacErik

    MacErik Thread Starter MacUser Mitglied

    Beiträge:
    632
    Zustimmungen:
    12
    MacUser seit:
    06.09.2002
    @maceis:
    Die Ausgabe ist folgende:
    Server: Apache/1.3.29 (Darwin) DAV/1.0.3 PHP/4.3.2 mod_perl/1.26

    @alle:
    PHP scheint wohl zu laufen. Richtig komisch finde ich ja, dass die Dateien nicht als Text angezeigt werden, sondern der Browser versucht sie herunterzuladen.
     
  7. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    in diesem Fall, vermute ich, dass tatsächlich ein Fehler in der httpd.conf vorliegt.
    was sagt
    httpd -t
    ?
    Welche Einträge hast Du im error_log und im access_log, wenn Du eine php-Datei aufrufst?
    Welche Endung verwendest Du für php-Dateien ?
    Wie sehen die Einträge in der httpd.conf hinsichtlich php aus ?

    Noch ne Frage am Rande:
    Wozu hast Du perl aktiv ? AFAIK verwendet man i. d. R. entweder php oder perl.
     
  8. MacErik

    MacErik Thread Starter MacUser Mitglied

    Beiträge:
    632
    Zustimmungen:
    12
    MacUser seit:
    06.09.2002
    Hallo,
    "httpd -t" bringt ein herrliches
    Syntax OK
    Im error_log und access_log ist nichts Ungewöhnliches zu sehen.
    Die php-Einträge in der httpd.conf lauten:

    LoadModule php4_module libexec/httpd/libphp4.so

    AddModule mod_php4.c

    AddHandler server-parsed .php

    <IfModule mod_4.c>
    # If php is turned on, we repsect .php and .phps files.
    AddType application/x-httpd-php .php
    AddType application/x-httpd-php-source .phps

    # Since most users will want index.php to work we
    # also automatically enable index.php
    <IfModule mod_dir.c>
    DirectoryIndex index.html index.php
    </IfModule>
    </IfModule>

    Meine php-Dateien enden mit .php.
    Perl habe ich übrigens installiert, weil ich bislang eigentlich alles damit gemacht habe. Aber seit ein paar Wochen versuche ich mit auch an MySQL und PHP. Daher läuft (oder lief) momentan beides.

    Gruß
    Erik
     
  9. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    entferne mal diese Zeile:
    AddHandler server-parsed .php
    und starte den Webserver neu.

    Dann müsste es wieder funktionieren ;)
     
  10. MacErik

    MacErik Thread Starter MacUser Mitglied

    Beiträge:
    632
    Zustimmungen:
    12
    MacUser seit:
    06.09.2002
    Hat leider nix gebracht. Das Verhalten ist exakt das gleiche!
    Ich habe jetzt mal auf die httpd.conf.default zurückgesattelt. Das da kein php geht ist ja klar, aber der browser versucht immer noch die .php Datei runterzuladen und zeigt nicht den Quelltext an!
    Das verstehe ich nicht!
    Erik
     
Die Seite wird geladen...
Ähnliche Themen - PHP nach Softwareupdate
  1. alex1000
    Antworten:
    5
    Aufrufe:
    159
    pmau
    26.08.2016
  2. mad dog
    Antworten:
    19
    Aufrufe:
    2.085
    MacEnroe
    14.08.2015
  3. platti
    Antworten:
    5
    Aufrufe:
    845
    platti
    22.01.2007
  4. Alidey
    Antworten:
    15
    Aufrufe:
    840
    Alexpowers
    10.11.2005
  5. der Stefan
    Antworten:
    4
    Aufrufe:
    947
    Theremin
    22.10.2004