Personal Websharing / 403 forbidden

Diskutiere mit über: Personal Websharing / 403 forbidden im Mac OS X Forum

  1. Malcolm

    Malcolm Thread Starter MacUser Mitglied

    Beiträge:
    511
    Zustimmungen:
    0
    Registriert seit:
    03.01.2004
    Ich hab Personal Websharing aktiviert um meinen Rechner als Testserver zu nutzen bevor ich komplette Sites online stelle.
    Nun musste ich feststellen das wen ich http://localhost/~malcolm/ test die "403 forbidden" Meldung kommt.
    Was kann da sein?
     
  2. iLover

    iLover Banned

    Beiträge:
    322
    Zustimmungen:
    0
    Registriert seit:
    13.03.2005
    nur allein den webserver über die systemeinstellungen>sharing zu aktivieren, macht noch keinen lauffähigen, sicheren und akzeptabelen webserver ...

    vor dem start mußt du die konfigurations-dateien des servers auf optimale werte setzen, die den betrieb (wenn auch nur zum test) ernsthaft ermöglichen ...

    dazu zählen:

    /etc/httpd/httpd.conf

    /etc/httpd/users/deinname

    /dein-webroot-verzeichnis/.htaccess

    es sind vorwiegend die zugriffsrechte in der .conf (verbote und gebote), sowie der daten und verzeichnisse (chmod) zu setzen.

    werte werden stets in spitze klammern gesetzt und müssen wie HTML einen anfang und ein ende darstellen.

    <Directory>
    Options -Indexes
    AllowOverride All
    </Directory>

    feste werte werden einfach notiert und nur durch ein tab oder leerzeichen von bedeutung und wert getrennt. der wert wird vorzugsweise in anführungszeichen gesetzt. nicht geltende werte werden mit einer route am anfang ausgeschaltet.

    DocumentRoot "/Library/WebServer/Documents"

    oder

    # DocumentRoot "/Library/WebServer/Documents"


    was es dabei alles noch zu bedenken gibt, welche werte wann gebraucht werden und was man noch so beachten muß, das lernt man nicht über einen beitrag in diesem forum. du solltest dich also selbst ein wenig mit dieser gesamten geschichte befassen, wenn du erfolgreich sein willst.

    ein gut und komfortabel eingestellter webserver ist das a und o um webprojekte in html, cgi und php + mysql anzeigen und ablaufen zu lassen. nur mal eben den webserver einschalten und gucken ob da zufällig was passiert - ist nicht.

    das bedienungsfreudige einschalten des webservers über die systemeinstellung>sharing täuscht hier leider regelrecht über die qualvolle manuelle einrichtung hinweg. das eine hat wirklich nichts mit dem anderen zu tun ...
     
  3. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    Registriert seit:
    24.09.2003
    Das sollte so klappen (und zwar ohne Änderung in der Konfiguration).
    Wie sieht es aus, wenn Du 'localhost' durch '127.0.0.1' ersetzt.
    Sollte zwar keinen Unterschied machen, aber testen kannst Du es mal.

    Außerdem kannst Du mal checken (posten), was in '/var/log/httpd/error_log' für Fehlermeldungen erscheinen und welche Rechte bei '~/Sites/' gesetzt sind.
     
  4. Malcolm

    Malcolm Thread Starter MacUser Mitglied

    Beiträge:
    511
    Zustimmungen:
    0
    Registriert seit:
    03.01.2004
    Du willst mir doch nicht erzählen das ein normaler user noch in der .htaccess und der httpconf rumfummeln muss. Da würde die Option "Personal WebSharing aktivieren" absolut null sinn machen.

    Ich brauch auch keinen sicheren Webserver da eh keiner drauf kommt weil vorher der Router alles abfängt.

    Die Dateirechte sind in Ordnung. Der normale Webserver funktioniert auch problemlos...nur ist es mir lästig immer alles erst nach Library/... zu kopieren.
     
  5. Malcolm

    Malcolm Thread Starter MacUser Mitglied

    Beiträge:
    511
    Zustimmungen:
    0
    Registriert seit:
    03.01.2004
    [Thu Apr 14 20:18:21 2005] [error] [client 127.0.0.1] (13)Permission denied: access to /~Malcolm/Soundgarden failed because search permissions are missing on a component of the path


    Checks nicht...bin mir sicher da ging damals mal.
     
  6. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    Registriert seit:
    24.09.2003
    Es ist anscheinend ein Rechteproblem.

    Alle Dateien die Du über den Webserver aufrufen möchtest, benötigen mindesten die Rechte -r--r--r--
    Alle Verzeichnisse in denen Dateien liegen benötigen -r-xr-xr-x.
    Sieht so aus, als ob das für den Ordner '~Malcolm/Soundgarden' nicht zutrifft.

    Falls Du mit der Änderung von Rechten nicht klar kommst, melde Dich noch mal.
     
  7. iLover

    iLover Banned

    Beiträge:
    322
    Zustimmungen:
    0
    Registriert seit:
    13.03.2005
    @Malcolm

    wenn du meinst ...

    zumindest hätte ich den fehler bei mir bereits gefunden ...

    erzählen will ich dir hier gar nichts, nur wenn du die einzelnen zusammenhänge nicht verstehst (verstehen willst), was nützt dir ein webserver wenn du damit nicht umgehen kannst?

    wenn man nicht weiß, daß sich ein eintrag in der datei /etc/httpd/users/du befinden muß, der da lautet:

    <Directory "/Users/du/Sites/">
    Options -Indexes
    AllowOverride All
    Order Deny,Allow
    Deny from All
    Allow from 192.168
    Allow from 127.0
    Allow from localhost
    </Directory>

    und weiteres ...

    ... dann kann man eben einen webserver nicht so ohne weiteres bedienen und muß sich dazu vorher eben einiges wissen aneignen.

    hast du überhaupt einen index bestimmt? den DirectoryIndex? da muß angegeben werden, was für eine startdatei im normalfall oder im notfall immer unbedingt geladen werden muß. überprüfe also ob du eines davon angegeben hast, die datei aber vielleicht nicht in deinem webroot liegt, ganz einfach. für den webserver ist das ein 401-fehler.
     
    Zuletzt bearbeitet: 14.04.2005
  8. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    Registriert seit:
    24.09.2003
    So eng würde ich das nicht sehen.
    Der Webserver ist von Apple so vorkonfiguriert, dass auch nicht-Spezialisten damit arbeiten können.
    Die von Dir genannten Einstellungen sind definitiv nicht zwingend erforderlich.
    Natürlich hat man mit wachsendem Fachwissen auch mehr Möglichkeiten, aber um statische Webseiten zu betrachten genügt es, diese im Sites-Ordner zu speichern und die Rechte entsprechend zu setzen (Lesen für alle bei Dateien, Lesen und Auflisten für alle bei Verzeichnissen)

    Das ist in mehrerlei Hinsichten falsch.
    Vielleicht solltest Du Dir auch noch ein wenig Wissen aneignen :D.
     
    Zuletzt bearbeitet: 14.04.2005
  9. iLover

    iLover Banned

    Beiträge:
    322
    Zustimmungen:
    0
    Registriert seit:
    13.03.2005
    @maceis

    nun das auch noch ...

    wenn ich angebe, daß

    DirectoryIndex index.html index.htm,

    dann wird entweder die erste oder zweite datei geladen, unbedingt. ist aber keine von beiden vorhanden, kann der server diese nicht laden und der zugriff wird aus sicherheitsgründen verweigert, weil ja

    Options -Indexes (Index anzeigen verboten)

    das macht dann Fehler 401 oder von mir aus 403, was ist da jetzt falsch dran? und dann noch aus mehrerlei hinsicht?
     
    Zuletzt bearbeitet: 14.04.2005
  10. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    Registriert seit:
    24.09.2003
    Das ist Deine persönliche Einstellung, die von der Standardkonfiguration abweicht.
    Die von Dir als zwingend angegebenen Änderungen sind definitiv nicht erforderlich. Im Grunde ist keinerlei Fachwissen über Webserver erforderlich um das zu erreichen, was der OP im Augenblick wohl möchte.
    Muss nicht; in der Defaultkonfiguration von Apple steht 'Options Indexes'
    Mit Notfall hat das nichts zu tun; das ist eine Komfortfunktion.
    In der Standarkonfiguration ist das bereits der Fall.
    Die muss zur Benutzung nicht im DocumentRoot sondern im aufgerufenen Verzeichnis liegen. Abgesehen davon, kann sie auch fehlen.
    401 ist ein "Unauthorized"
     
    Zuletzt bearbeitet: 14.04.2005
Die Seite wird geladen...
Ähnliche Themen - Personal Websharing forbidden Forum Datum
Personal Backup X4 trotz Time Machine behalten Mac OS X 17.10.2007
Personal Web Sharing Mac OS X 05.12.2006
Personal File Sharing will nur in eine Richtung. Mac OS X 18.09.2006
Personal Web Sharing ohne Forwarding Mac OS X 07.02.2006
personal websharing lässt sich nicht aktivieren Mac OS X 26.03.2004

Diese Seite empfehlen

Benutzerdefinierte Suche