Personal Web Sharing lässt sich nicht starten

Dieses Thema im Forum "Web-Programmierung" wurde erstellt von Augustiner, 10.10.2006.

  1. Augustiner

    Augustiner Thread Starter MacUser Mitglied

    Beiträge:
    133
    Zustimmungen:
    0
    MacUser seit:
    25.10.2004
    Hallo zusammen,
    versuche gerade vergeblichst PHP / MySQL / MyAdmin auf meinem Panther zu installieren. Wollte mich dabei an das Tutorial von Entropy halten.
    Jedoch scheitere ich schon bei dem simplen Schritt "Personal Websharing aktivieren". Jedesmal wenn ich das versuche, dann kommt nur "Personal Web Sharing wird gestart" und danach nichts mehr. Gehe ich dann wieder aus den Systemeinstellungen raus und wieder rein ist der Button wieder auf off gesetzt.

    Jemand eine Ahnung was da falsch laufen könnte?

    Gruß
    Augustiner
     
  2. wegus

    wegus MacUser Mitglied

    Beiträge:
    15.039
    Zustimmungen:
    1.316
    MacUser seit:
    13.09.2004
    Ja das ist ärgerlich, bei Fehlern beendet die GUI kommentarlos den Web-Server, dabei gibt es durchaus Fehlermeldungen!

    Mach mal ein Terminal auf und tue das von Hand, was der Haken bei personal Websharing auch nur tut. Starte den Server also aus dem Terminal zu Fuß:

    Code:
    apachectl start
    danach wird es eine/mehrere Fehlermeldungen geben, die poste bitte hier wieder. Dann kann man weitersehen was da passiert ( oder eben auch nicht).
     
  3. Augustiner

    Augustiner Thread Starter MacUser Mitglied

    Beiträge:
    133
    Zustimmungen:
    0
    MacUser seit:
    25.10.2004
    Das kommt dann:

    Code:
    localhost:~ KenCortez$ apachectl start
    Processing config directory: /private/etc/httpd/users/*.conf
     Processing config file: /private/etc/httpd/users/+entropy-php.conf
    Syntax error on line 8 of /private/etc/httpd/users/+entropy-php.conf:
    Cannot load /usr/local/php5/libphp5.so into server: (reason unknown)
    /usr/sbin/apachectl start: httpd could not be started
     
  4. wegus

    wegus MacUser Mitglied

    Beiträge:
    15.039
    Zustimmungen:
    1.316
    MacUser seit:
    13.09.2004
    dann zeig doch mal Zeile 8 aus der

    /private/etc/httpd/users/+entropy-php.conf:

    und prüf mal ob es die Datei

    /usr/local/php5/libphp5.so

    auch wirklich gibt!
     
  5. Augustiner

    Augustiner Thread Starter MacUser Mitglied

    Beiträge:
    133
    Zustimmungen:
    0
    MacUser seit:
    25.10.2004
    Also zu erst ist entropy-php.conf bei mir ein Alias (weiß nicht ob das so sein sollte).
    Das Orginal liegt in usr/local/php5.

    Hier der Inhalt:
    Code:
    #
    # Additional PHP Apache directives,
    # part of the entropy.ch PHP package for Mac OS X
    # 
    # For more information, go to http://www.entropy.ch/software/macosx/php/
    #
    
    LoadModule php5_module        /usr/local/php5/libphp5.so
    
    <IfDefine !APACHE2>
    AddModule mod_php5.c
    </IfDefine>
    
    <IfModule mod_php5.c>
    
        AddType application/x-httpd-php .php
        AddType application/x-httpd-php-source .phps
    
        <IfModule mod_dir.c>
            DirectoryIndex index.html index.php
        </IfModule>
    
    </IfModule>
    usr/local/php5/libphp5.so existiert jedenfalls
     
  6. wegus

    wegus MacUser Mitglied

    Beiträge:
    15.039
    Zustimmungen:
    1.316
    MacUser seit:
    13.09.2004
    Also gibt es diese Datei tatsächlich:

    /private/etc/httpd/users/+entropy-php.conf:

    Bei mir sind da nämlich nur die user eingetragen! Der include für das entropy-Zeugs erfoglt bei mir ind er /private/etc/httpd/httpd.conf direkt.

    LoadModule php5_module /usr/local/php5/libphp5.so

    sieht für mich auch normal aus!

    Da fällt mir nur noch ein, daß der Apache ziemlich empfindlich ist was Linebreaks angeht. Er erwartet diese LINUX-like und nicht MAC-like! Am besten Du schaust Dir die

    /private/etc/httpd/users/+entropy-php.conf:

    Datei mal mit dem vi an, der kann diese auch zwischen Win/Mac/Linux wechseln! Ich vermute der Syntaxfehler kommt aus einem Mac-Linefeed! Sprich der Inhalt der Datei ist o.k., die Whitespaces jedoch nicht.
     
  7. Jakob

    Jakob MacUser Mitglied

    Beiträge:
    1.067
    Zustimmungen:
    21
    MacUser seit:
    05.01.2004
    …und alle, bei denen sich bei „vi“ die Nackenhaare aufstellen bzw. nicht wissen, was es ist, können z.B. TextWrangler nutzen. Der hat im Speichern-Dialog ein Button „Options…“ über den sich ganz leicht Encoding und Linebreak-Art einstellen lässt.
    Nix für ungut wegus ;)
     
  8. wegus

    wegus MacUser Mitglied

    Beiträge:
    15.039
    Zustimmungen:
    1.316
    MacUser seit:
    13.09.2004
    ...der war sogar sehr gut Jakob :)
    ich nutze Textwrangler nämlich auch, aber das Feature ist mir bisher geflissentlich entgangen ( man sollte wohl nicht immer per APFEL+S speichern :p )
     
  9. Augustiner

    Augustiner Thread Starter MacUser Mitglied

    Beiträge:
    133
    Zustimmungen:
    0
    MacUser seit:
    25.10.2004
    Ok super!
    Sowohl der Web Server läuft als auch PHP4 ..
    Kann ich auch PHP5 für Panther installieren?

    (Derweil dank ich schonmal für eure Hilfe :))
     
  10. Jakob

    Jakob MacUser Mitglied

    Beiträge:
    1.067
    Zustimmungen:
    21
    MacUser seit:
    05.01.2004
Die Seite wird geladen...

Diese Seite empfehlen