Partition freigeben

Dieses Thema im Forum "Mac OS X" wurde erstellt von muellermanfred, 02.01.2006.

  1. muellermanfred

    muellermanfred Thread Starter Gast

    Moin.

    Mein Problem:
    Ich möchte einen Rechner (G4/450 AGP, 10.4.3) als Fileserver benutzen und scheitere gerade an den Zugriffsrechten.

    Ich habe zwei Partitionen angelegt, eine für System und Programme und eine nur für Arbeitsdaten. Die Systempartition ist so eingestellt:

    Eigentümer: System: Lesen & Schreiben
    Gruppe: admin: Lesen & Schreiben
    Andere: Nur Lesen

    Dementsprechend ist diese Partition für Standarduser über's Netzwerk nicht sichtbar. Soweit okay.

    Die Datenpartition hat folgende Rechte:

    Eigentümer: System: Lesen & Schreiben
    Gruppe: admin: Lesen & Schreiben
    Andere: Lesen & Schreiben

    Der Standarduser sieht beim Netzwerkzugriff zwei Volumes: seinen Benutzerordner auf der Systempartition und die Datenpartition. Soweit okay.

    Nicht okay: Während der Zugriff auf den Benutzerordner problemlos ist, sieht er beim Öffnen der Datenpartition nur einen Briefkastenordner. Nicht okay.

    Frage:
    Was muß ich einstellen, damit die User die Datenpartition ganz normal sehen und auch darauf zugreifen können?

    Für jeden Hinweis dankt

    Manfred
     
  2. muellermanfred

    muellermanfred Thread Starter Gast

    share points

    So ...

    Weiterrecherchiert und gelernt, dass sowas mit dem normalen OS X gar nicht geht.

    Stattdessen bin ich auf das Hilfsprogramm SharePoints gestoßen. Der erste Versuch hat nicht viel gebracht - wahrscheinlich hab ich's noch nicht richtig verstanden ...

    Manfred
     
  3. mactie

    mactie MacUser Mitglied

    Beiträge:
    689
    Zustimmungen:
    0
    MacUser seit:
    01.06.2005
    das interessiert mich auch!

    Ich habe SharePoints schon im Einsatz. Ist recht gut + enfach. Probier doch mal ein bischen damit herum.

    Ich habe es aber auch noch nicht ganz verstanden. Allerdings war da eine (glaube ich) recht ausführliche Aneitung dabei. Wenn ich (nach den Prüfungen) mal mehr Zeit habe (haha), dann lese ich sie vielleicht mal durch.
     
  4. muellermanfred

    muellermanfred Thread Starter Gast

    sharepoints Anleitung

    Moin.

    Klappt immer noch nicht - hat es zwischendurch, aber dann nicht mehr. Weiss noch nicht genau, warum.

    Die Anleitung ist leicht verständlich. Im prinzip ist es ja nichts anderes als das alte benutzer & Gruppen-Ding, was wir von Classic kennen.

    Im Hintergrund steuert SharePoints den NetInfo Manager fern - eigentlich kann man alle benötigten Einstellungen auch von Hand vornehmen, aber da reicht ja schon ein vertipper und nichts funktioniert ...
    Mehr Infos dazu: http://www.thinkmacosx.ch

    Ich mach mal weiter ...

    Manfred
     
    Zuletzt von einem Moderator bearbeitet: 02.01.2006
  5. muellermanfred

    muellermanfred Thread Starter Gast

    aha ...

    Moin.

    So, jetzt funktionierts. Halbwegs.

    Es lag an den Zugriffsrechten. SharePoints schreibt die für die erste Ebene neu und da kam es vor, dass ich als Standarduser das Volume zweimal gesehen habe, beide Male als Briefkasten.

    Eigentlich will ich, dass jeder im Anmeldedialog nur das sieht, was er auch benutzen darf, aber das klappt noch nicht. Im Augenblick steht die Partition so da:
    Eigentümer: System: Lesen & Schreiben
    Gruppe: admin: Lesen & Schreiben
    Jeder: Lesen & Schreiben

    In SharePoints hab ich das nicht angetastet und dann geht's.

    Nun sehe ich den Volumenamen (dahinter der Briefkastenordner) und den Namen der Freigabe - da gibt es dann den gewünschten Zugriff. Das langt mal für's erste, aber perfekt ist es nicht.

    Sobald ich versuche, den Zugriff feiner einzustellen, hakt es. Ich glaube aber, dass ich nur mehr Sorgfalt an den Tag legen muss. Das Programm an sich ist ja banane-einfach.

    Manfred
     
  6. muellermanfred

    muellermanfred Thread Starter Gast

    smb-user

    Moin.

    Nun zum Eingemachten:
    Das Freischalten von Usern für's Windows-Sharing gestaltet sich etwas komplizierter. Die ursprünglich als Mitbenutzer angelegten, dann gelöschten und per SharePoints neu angelegten Windows-Sharing-User funktionieren tadellos. Die danach nur über SharePoints angelegten User erhalten trotz identischer Einstellungen keinen Zugriff - "crendentials conflict with existing credentials" blabla ...

    Per NetInfo-Manager hab ich die User verglichen. Die zuerst beschriebenen hatten unter "authentication_authority" den Wert ";ShadowHash;HASHLIST:<SALTED-SHA1,SMB-NT,SMB-LAN-MANAGER>", die neu angelegten lediglich den Eintrag ";ShadowHash;". Tja, per Milchmädchenrechnung hab ich gedacht: ergänze letztere um das fehlende und alles wird gut, aber das hat nicht funktioniert ...

    Die ersten User wiesen im NetInfo-Eintrag übrigens noch das (natürlich längst gelöschte) zugewiesene User-Bildchen auf ... eventuell muss ich nun jeden neuen Windows-Sharing-User erstmal als Mitbenutzer anlegen, in SharePoints einstellen und anschliessend aus dem system wieder löschen ... kompliziert ...

    Irgendjemand ne bessere Idee?

    Manfred
     
  7. muellermanfred

    muellermanfred Thread Starter Gast

    smb-user2

    Moin.

    Jetzt hab ich mich selbst verwirrt: Die Windows-User mussten in den Systemeinstellungen natürlich noch für's Windows-Sharing freigegeben werden. Das hat den netInfo-Eintrag vollständig gemacht. Funktioniert aber trotzdem nicht und nun kann ich keinen Unterschied feststellen zwischen den ersten Windows-usern, die funktionieren und jenen, die nicht funktionieren ...

    Die Tatsache, dass ein FileSharing-User vorher ein Mitbenutzer war, der dann gelöscht wurde, hat übrigens keine Auswirkung auf das Problem.

    Hm, nun muss ich den Unterschied finden ... Irgendwer ne idee?

    Manfred
     
  8. muellermanfred

    muellermanfred Thread Starter Gast

    das netz ist schuld

    Moin.

    Das Rätsel ist gelöst, oder besser: Ich weiß, wo die Ursache liegt, aber ich kann nichts dran ändern ...

    Alle funktionierenden Windows-User hängen im selben Teilnetz, alle nicht funktionierenden jenseits davon. Letztere sehen zwar die Volumen, die freigegeben sind, aber die Anmeldung wird nicht akzeptiert (siehe die "credentials" von oben).

    Leider habe ich auf die Netzwerkarchitektur null Einfluss und bin auch kein Samba-Experte - im jenseitigen Teilnetz hängt nämlich ein Windows-Server, der die Authentifizierung neuer User von aussen annimmt, ohne konfiguriert worden zu sein ... sowas bräuchte ich auch ...

    Möh.

    Manfred
     
  9. muellermanfred

    muellermanfred Thread Starter Gast

    hrmpf!

    Moin!

    Na, da brat mir doch einer was:

    Jetzt geht's doch und alle vorgesehenen Windows-User im Büro, egal in welchem Teilnetz, und auch die in England, welche natürlich in einem ganz anderen Netzwerkabschnitt hängen, sind jetzt per SharePoints an meinen kleinen Fileserver angeschlossen. Nur einer nicht und dem seine Dose werf ich gleich aus dem Fenster und stell ihm einen alten G4 hin (aber das darf ich nicht und deshalb laß ich's bleiben ...).

    Ende der Geschichte:
    SharePoints ist ne feine Sache, die Freigabe von Platten, Partitionen und Ordnern kein Problem. Nur die Feinjustierung der Rechte find ich lästig und für technische Laien wie mich nicht gut durchschaubar ... Aber da kann SharePoints nix dazu, das ist ja Systemsache.

    Vielen Dank für's Mitlesen!

    Manfred
     
  10. mactie

    mactie MacUser Mitglied

    Beiträge:
    689
    Zustimmungen:
    0
    MacUser seit:
    01.06.2005
    Gerngeschehen! War schon ganz interessant, aber ich habe nicht wirklich viel verstanden. Na ja wie auch immer. Glückwünsche, dass es jetzt klappt!
     
Die Seite wird geladen...

Diese Seite empfehlen