Parallels - Apache

Diskutiere mit über: Parallels - Apache im Windows auf dem Mac Forum

  1. kisi

    kisi Thread Starter MacUser Mitglied

    Beiträge:
    29
    Zustimmungen:
    0
    Registriert seit:
    29.10.2006
    Hallo!
    Ich habe Paralles installiert. Dies läuft auch wunderbar. Jetzt habe ich den Apache webserver installiert, damit ich lokal vernünftig programmieren kann. Ich habe beim OSX eine Partition "DATEN". Diese hat das Dateisystem fat32. Auf dieser befinden sich auch meine ganzen Websites. Die Daten Partition habe ich beim Windows XP als Netzlaufwerk verbunden. Ich möchte nun den Apache so einstellen, dass er das Netzlaufwerk E: als DocumentRoot für meine Websites hernimmt. Wenn den DocumentRoot allerdings in der httpd.conf ändere, so schtürzt der Apache immer ab.

    Hier das Error log.:

    [Fri Nov 17 03:30:12 2006] [notice] Apache/2.2.3 (Win32) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8d mod_autoindex_color PHP/5.1.6 configured -- resuming normal operations
    [Fri Nov 17 03:30:12 2006] [notice] Server built: Sep 30 2006 21:24:06
    [Fri Nov 17 03:30:12 2006] [notice] Parent: Created child process 2520
    [Fri Nov 17 03:30:14 2006] [notice] Child 2520: Child process is running
    [Fri Nov 17 03:30:14 2006] [notice] Child 2520: Acquired the start mutex.
    [Fri Nov 17 03:30:14 2006] [notice] Child 2520: Starting 250 worker threads.
    [Fri Nov 17 03:30:14 2006] [notice] Child 2520: Starting thread to listen on port 443.
    [Fri Nov 17 03:30:14 2006] [notice] Child 2520: Starting thread to listen on port 80.
    [Fri Nov 17 03:30:33 2006] [error] [client 127.0.0.1] client denied by server configuration: E:/websites/
    [Fri Nov 17 03:30:41 2006] [notice] Parent: Received shutdown signal -- Shutting down the server.
    [Fri Nov 17 03:30:41 2006] [notice] Child 2520: Exit event signaled. Child process is ending.
    [Fri Nov 17 03:30:42 2006] [notice] Child 2520: Released the start mutex
    [Fri Nov 17 03:30:43 2006] [notice] Child 2520: Waiting for 250 worker threads to exit.
    [Fri Nov 17 03:30:43 2006] [notice] Child 2520: All worker threads have exited.
    [Fri Nov 17 03:30:43 2006] [notice] Child 2520: Child process is exiting
    [Fri Nov 17 03:30:43 2006] [notice] Parent: Child process exited successfully.
    [Tue Nov 21 23:55:00 2006] [notice] Apache/2.2.3 (Win32) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8d mod_autoindex_color PHP/5.1.6 configured -- resuming normal operations
    [Tue Nov 21 23:55:00 2006] [notice] Server built: Sep 30 2006 21:24:06
    [Tue Nov 21 23:55:00 2006] [notice] Parent: Created child process 2612
    [Tue Nov 21 23:55:02 2006] [notice] Child 2612: Child process is running
    [Tue Nov 21 23:55:02 2006] [notice] Child 2612: Acquired the start mutex.
    [Tue Nov 21 23:55:02 2006] [notice] Child 2612: Starting 250 worker threads.
    [Tue Nov 21 23:55:02 2006] [notice] Child 2612: Starting thread to listen on port 443.
    [Tue Nov 21 23:55:02 2006] [notice] Child 2612: Starting thread to listen on port 80.
     
  2. rm -r *

    rm -r * MacUser Mitglied

    Beiträge:
    2.368
    Zustimmungen:
    156
    Registriert seit:
    22.05.2006
    Steht denn in Deiner Config auch im Entsprechenden Abschnitt:
    Allow from 127.0.0.1
    ?

    Poste doch mal einfach den XML-Block wo Du E:/websites
    als DocumentRoot eingetragen hast.
     
  3. kisi

    kisi Thread Starter MacUser Mitglied

    Beiträge:
    29
    Zustimmungen:
    0
    Registriert seit:
    29.10.2006
    Hier ein Auszug aus meiner httpd.conf


    #
    # ServerAdmin: Your address, where problems with the server should be
    # e-mailed. This address appears on some server-generated pages, such
    # as error documents. e.g. admin@your-domain.com
    #
    ServerAdmin admin@localhost

    #
    # ServerName gives the name and port that the server uses to identify itself.
    # This can often be determined automatically, but we recommend you specify
    # it explicitly to prevent problems during startup.
    #
    # If your host doesn't have a registered DNS name, enter its IP address here.
    #
    ServerName localhost:80

    #
    # DocumentRoot: The directory out of which you will serve your
    # documents. By default, all requests are taken from this directory, but
    # symbolic links and aliases may be used to point to other locations.
    #
    DocumentRoot "C:/Programme/xampp/htdocs"
    #DocumentRoot "file://///.PSF/Untitled/websites"
    #DocumentRoot "\\.PSF\Untitled\websites"
    #DocumentRoot "E:/websites"
    #
    # Each directory to which Apache has access can be configured with respect
    # to which services and features are allowed and/or disabled in that
    # directory (and its subdirectories).
    #
    # First, we configure the "default" to be a very restrictive set of
    # features.
    #
    <Directory />
    Options FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
    </Directory>

    #
    # Note that from this point forward you must specifically allow
    # particular features to be enabled - so if something's not working as
    # you might expect, make sure that you have specifically enabled it
    # below.
    #

    #
    # This should be changed to whatever you set DocumentRoot to.
    #
    <Directory "C:/Programme/xampp/htdocs">
    #<Directory "file://///.PSF/Untitled/websites/">
    #<Directory "\\.PSF\Untitled\websites">
    #<Directory "E:/websitess">
    #
    # Possible values for the Options directive are "None", "All",
    # or any combination of:
    # Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
    #
    # Note that "MultiViews" must be named *explicitly* --- "Options All"
    # doesn't give it to you.
    #
    # The Options directive is both complicated and important. Please see
    # http://httpd.apache.org/docs/2.2/mod/core.html#options
    # for more information.
    #
    Options Indexes FollowSymLinks Includes ExecCGI

    #
    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    # Options FileInfo AuthConfig Limit
    #
    AllowOverride All

    #
    # Controls who can get stuff from this server.
    #
    Order allow,deny
    Allow from all

    </Directory>



    Ich habe jetzt allerdings ein paar beiträge gesehen, dass ich vom Parallels auch auf den Apache Server unter dem OSX zugreifen kann. Dies wäre nämlich noch besser. Kann mir jemand sagen, was für Einstellungen ich dazu durchführen muss?
     
  4. rm -r *

    rm -r * MacUser Mitglied

    Beiträge:
    2.368
    Zustimmungen:
    156
    Registriert seit:
    22.05.2006
    Die Frage klingt jetzt doof, aber das im zweiten Eintrag "E:/websitess" anstatt "E:/websites" steht, hast Du gesehen ?

    Manchmal sieht man ja den Wald vor lauter Bäumen nicht. ;-)
     
  5. ThaHammer

    ThaHammer MacUser Mitglied

    Beiträge:
    3.276
    Zustimmungen:
    13
    Registriert seit:
    01.06.2004
    Warum installierst Du überhaupt Apache unter Windoof? Läuft doch schon unter OS X. Machst Du das wegen dem IE? Ich nicht, das Problem löse ich indem ich per Parallels die Seite anschaue, unter OS X das CSS anpasse und auf den Server spule.
     
  6. kisi

    kisi Thread Starter MacUser Mitglied

    Beiträge:
    29
    Zustimmungen:
    0
    Registriert seit:
    29.10.2006
    Ja, das mache ich wegen dem IE, und den anderen Windoof Browsern.
    Wie kann ich mir ansonsten die Seite in Parallels anschauen (local) wenn der Großteil meiner Seiten php verwendet, und diese Dateien zwangsläufig geparst werden müssen?
     
  7. tigion

    tigion MacUser Mitglied

    Beiträge:
    1.087
    Zustimmungen:
    48
    Registriert seit:
    21.06.2006
    Kannst du nicht unter OS X local einen Apache laufen lassen, z.B. mit Mamp, und in Parallels dann im IE die Webseite anschauen ... ?
     
  8. rm -r *

    rm -r * MacUser Mitglied

    Beiträge:
    2.368
    Zustimmungen:
    156
    Registriert seit:
    22.05.2006
    Du kannst doch vom Windows in Paralells über die IP-Adresse Deines Mac OS X auf den Apache zugreifen, der da läuft.
    Das ist ja kein Problem.

    IP-Mac: 192.168.0.1
    IP-Win: 192.168.0.2

    Dann gibst Du in Windows in die Adresszeile des Browsers die 192.168.0.1 ein.
    Denk aber dran in den Sytemeinstellungen den Port 80 freizugeben.
     
  9. kisi

    kisi Thread Starter MacUser Mitglied

    Beiträge:
    29
    Zustimmungen:
    0
    Registriert seit:
    29.10.2006
    Hallo!
    Wenn ich beim IE in die Adressleiste 192.168.0.1 eingebe, dann kommt die Fehlermeldung "Die Suchseite konnte nicht gefunden werden".
    Der Apache Webserver läuft aber unterm OSX. Personal Websharing ist aktiviert. Muss noch irgendwo Einstellungen vornehmen? Sorry, aber ich habe erst seit Kurzem einen Mac
     
  10. kisi

    kisi Thread Starter MacUser Mitglied

    Beiträge:
    29
    Zustimmungen:
    0
    Registriert seit:
    29.10.2006
    Hallo!
    Wenn ich beim IE in die Adressleiste 192.168.0.1 eingebe, dann kommt die Fehlermeldung "Die Suchseite konnte nicht gefunden werden".
    Der Apache Webserver läuft aber unterm OSX. Personal Websharing ist aktiviert. Muss noch irgendwo Einstellungen vornehmen? Sorry, aber ich habe erst seit Kurzem einen Mac
     
Die Seite wird geladen...

Diese Seite empfehlen

Benutzerdefinierte Suche