OpenSuSE 10 auf iMac G3 400MHz

Diskutiere mit über: OpenSuSE 10 auf iMac G3 400MHz im Linux auf dem Mac Forum

  1. wolfmac

    wolfmac Thread Starter MacUser Mitglied

    Beiträge:
    15
    Zustimmungen:
    0
    Registriert seit:
    02.04.2005
    Hallo

    ich habe OpenSuSE 10 auf meinem alten iMac G3 400MHz zum laufen bekommen :)

    Alles läuft soweit gut, nur mit dem Monitor habe ich ein Problem. Das ganze Bild ist ca. 4cm zu weit nach Links verschoben. Das ist zu viel um es mit YaST/SAX2 zu korrigieren.
    Irgend eine Monitoreinstellung muß falsch sein. Kann mir einer weiterhelfen!

    Vielen Dank mal.

    Wolfmac
     
  2. xena2

    xena2 MacUser Mitglied

    Beiträge:
    259
    Zustimmungen:
    1
    Registriert seit:
    26.10.2003
    Hi
    Und am Monitor kannst Du nicht nachregeln?

    Xenja
     
  3. wolfmac

    wolfmac Thread Starter MacUser Mitglied

    Beiträge:
    15
    Zustimmungen:
    0
    Registriert seit:
    02.04.2005
    am alten iMac G3 400MHz gibt es keine Regler für den eingebauten Monitor.
     
  4. mad-mayhem

    mad-mayhem MacUser Mitglied

    Beiträge:
    751
    Zustimmungen:
    28
    Registriert seit:
    03.08.2005
    versuch evtl. die X config per Hand neu zu machen ohne Yast.
    müsste unter /etc/X11/xorg.conf sein wenn opensuse X.org benutzt.
    wenn es jedoch Xfree86 benutzt .. vergessen sorry.
    oder tip in die Shell mal xorg.conf oder ähnliches ein. wie zb. xorg-config oder so hab keinen linux rechner mehr
     
  5. wolfmac

    wolfmac Thread Starter MacUser Mitglied

    Beiträge:
    15
    Zustimmungen:
    0
    Registriert seit:
    02.04.2005
    also die xorg.conf gibts:

    # /.../
    # SaX generated X11 config file
    # Created on: 2005-10-21T21:02:28+0200.
    #
    # Version: 7.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2002
    #
    # Automatically generated by [ISaX] (7.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #
    Section "Files"
    FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/local"
    FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/Type1"
    FontPath "/usr/X11R6/lib/X11/fonts/URW"
    FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
    FontPath "/usr/X11R6/lib/X11/fonts/PEX"
    FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
    FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
    FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
    FontPath "/usr/X11R6/lib/X11/fonts/truetype"
    FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/CID"
    FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
    FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/xtest"
    FontPath "/opt/kde3/share/fonts"
    InputDevices "/dev/ttyS0"
    InputDevices "/dev/ttyS1"
    InputDevices "/dev/ttyS2"
    InputDevices "/dev/ttyS3"
    InputDevices "/dev/ttyS4"
    InputDevices "/dev/ttyS5"
    InputDevices "/dev/ttyS6"
    InputDevices "/dev/ttyS7"
    InputDevices "/dev/ttyS8"
    InputDevices "/dev/psaux"
    InputDevices "/dev/logibm"
    InputDevices "/dev/sunmouse"
    InputDevices "/dev/atibm"
    InputDevices "/dev/amigamouse"
    InputDevices "/dev/atarimouse"
    InputDevices "/dev/inportbm"
    InputDevices "/dev/gpmdata"
    InputDevices "/dev/mouse"
    InputDevices "/dev/usbmouse"
    InputDevices "/dev/adbmouse"
    InputDevices "/dev/input/mice"
    InputDevices "/dev/input/event0"
    InputDevices "/dev/pointer0"
    InputDevices "/dev/pointer1"
    InputDevices "/dev/pointer2"
    InputDevices "/dev/pointer3"
    EndSection

    Section "ServerFlags"
    Option "AllowMouseOpenFail"
    EndSection

    Section "Module"
    Load "freetype"
    Load "type1"
    Load "dbe"
    Load "glx"
    Load "extmod"
    Load "v4l"
    EndSection

    Section "InputDevice"
    Driver "kbd"
    Identifier "Keyboard[0]"
    Option "Protocol" "Standard"
    Option "XkbLayout" "de"
    Option "XkbModel" "macintosh"
    Option "XkbRules" "xfree86"
    Option "XkbVariant" "nodeadkeys"
    EndSection

    Section "InputDevice"
    Driver "mouse"
    Identifier "Mouse[1]"
    Option "Buttons" "7"
    Option "Device" "/dev/input/mice"
    Option "Name" "Topro USB Mouse"
    Option "Protocol" "explorerps/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "Monitor"
    DisplaySize 300 230
    HorizSync 30-60
    Identifier "Monitor[0]"
    ModelName "APPLE MONITOR"
    VendorName "APP"
    VertRefresh 50-75
    UseModes "Modes[0]"
    EndSection

    Section "Modes"
    Identifier "Modes[0]"
    Modeline "1024x768" 79.52 1024 1080 1192 1360 768 769 772 801
    Modeline "800x600" 47.53 800 840 920 1040 600 601 604 626
    Modeline "800x600" 40.19 800 832 912 1024 600 601 604 623
    Modeline "768x576" 43.52 768 800 880 992 576 577 580 601
    Modeline "768x576" 37.37 768 800 880 992 576 577 580 598
    Modeline "640x480" 29.84 640 664 728 816 480 481 484 501
    Modeline "640x480" 25.10 640 656 720 800 480 481 484 498
    EndSection

    Section "Screen"
    DefaultDepth 16
    SubSection "Display"
    Depth 15
    Modes "1024x768" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1024x768" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1024x768" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 32
    Modes "1024x768" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1024x768" "800x600" "768x576" "640x480"
    EndSubSection
    Device "Device[0]"
    Identifier "Screen[0]"
    Monitor "Monitor[0]"
    EndSection

    Section "Device"
    BoardName "Rage 128 RL"
    BusID "0:16:0"
    Driver "r128"
    Identifier "Device[0]"
    Screen 0
    VendorName "ATI"
    EndSection

    Section "ServerLayout"
    Identifier "Layout[all]"
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    Option "Clone" "off"
    Option "Xinerama" "off"
    Screen "Screen[0]"
    EndSection

    Section "DRI"
    Group "video"
    Mode 0660
    EndSection

    Section "Extensions"
    EndSection

    was muß ich daran ändern um mein Problem zu beheben?
     
  6. mad-mayhem

    mad-mayhem MacUser Mitglied

    Beiträge:
    751
    Zustimmungen:
    28
    Registriert seit:
    03.08.2005
    die datei darfst du nicht editieren versuch eine neue mit xorg-config(in der konsole eintippen) oder dergleichen (hab den genauen befehl vergessen) zu machen ist nur der X server nicht richtig oder alles?
     
  7. wolfmac

    wolfmac Thread Starter MacUser Mitglied

    Beiträge:
    15
    Zustimmungen:
    0
    Registriert seit:
    02.04.2005
    bei der Bildzentrierung über yast/sax2 kann ich mit den Pfeilen nur 2-3 mal klicken, dann ist schluß. Das bringt mir das Bild aber nur 0,5cm nach rechts.

    Habe inzwischen einen unzureichenden Umweg gefunden. Ich starte zuerst OSX/OS9 und schieber dort das Bild 4 cm nach rechts. Dann starte ich SuSE und das Bild stimmt.
     
Die Seite wird geladen...
Ähnliche Themen - OpenSuSE auf iMac Forum Datum
OpenSuse auf IMac Linux auf dem Mac 01.03.2010
openSUSE 11.0 auf Macbook / VMware Fusion Linux auf dem Mac 01.07.2008
opensuse auf iBook Linux auf dem Mac 27.05.2008
OpenSuse 10.2 auf PowerBook G4 -> WLAN working? Linux auf dem Mac 29.04.2007

Diese Seite empfehlen

Benutzerdefinierte Suche