OpenOffice bzw.XDarwin

Diskutiere mit über: OpenOffice bzw.XDarwin im Mac OS X - Unix & Terminal Forum

  1. ernesto

    ernesto Thread Starter MacUser Mitglied

    Beiträge:
    1.375
    Zustimmungen:
    9
    Registriert seit:
    19.02.2003
    habs mir geholt:
    http://shop.store.yahoo.com/microlinkcomputers/pog41gighzti.html


    Ich hatte bisher im Büro einen PC, natürlich mit OpenOffice.
    Jetzt ersetzt der neue den PC und mein altes G3 Wallstreet.

    Was mich am XDarwin stört, sind 2 "xterm" und ein "login" Fenster.......
    Hab bisher nix gefunden, um die zu vermeiden.

    Stört mich ähnlich wie die popups.........

    Ansonsten find ich das OO-X richtig süß und um Welten besser als das angebliche "Original".......
     
    Zuletzt von einem Moderator bearbeitet: 24.10.2015
  2. Christen

    Christen MacUser Mitglied

    Beiträge:
    843
    Zustimmungen:
    0
    Registriert seit:
    07.01.2003
    Hi, ernesto

    Wer XDarwin verwendet empfehle ich Oroborosx. Einfach in das "Programm"-Verzeichnis kopieren und zuerst starten.
    Hier zum downloaden: http://oroborosx.sourceforge.net/OroborOSX-v0.9.tar.gz
    Das erlaubt übrigens auch das Kopieren aus X11 Umgebungen.

    Dann unter OroborOSX "Erweitert/Startmeldungen unterdrücken" anklicken, erleichtert einem den Einsatz von XDarwin erheblich.

    Dann noch im Starter "Start OpenOffice.org/Preferences../Preferred XWindow Server" OroborOSX ankllicken.

    Fertig!
     
  3. ernesto

    ernesto Thread Starter MacUser Mitglied

    Beiträge:
    1.375
    Zustimmungen:
    9
    Registriert seit:
    19.02.2003
    orobor

    Hab den Orobor installiert...
    Jetzt sind z.B. die Menütexte, die Orden und Dateinamen im Fenster "offnen" in weißer Schrift (!) also unsichtbar, sofern nicht markiert......
    Außerdem ist die Schrift äußerst rudimentär "bepixelt" und oft schlecht erkennbar.

    Läßt sich das einstellen bzw. ändern??

    Daß die diversen Fenster jetzt die bunten knöpfe oben links haben ist gut!!
     
  4. ernesto

    ernesto Thread Starter MacUser Mitglied

    Beiträge:
    1.375
    Zustimmungen:
    9
    Registriert seit:
    19.02.2003
    die miserable Schriftanzeige

    ließ mich den Orobor löschen.
    Und jetzt hab ich kein OO mehr. Startet nicht mehr.
     
  5. Christen

    Christen MacUser Mitglied

    Beiträge:
    843
    Zustimmungen:
    0
    Registriert seit:
    07.01.2003
    Die 1.0.3 Version mit XDarwin und Orobor funktioniert bei mir ohne Probleme.
    Bei der 1.1.x Version von OpenOffice.org habe ich das Problem nach einer gewissen Zeit auch und bis jetzt noch nicht lösen können.
    Mit X11 sollte es aber auch mit der 1.1.x Version keine Probleme geben.
     
  6. twjb

    twjb MacUser Mitglied

    Beiträge:
    355
    Zustimmungen:
    8
    Registriert seit:
    14.10.2003
     

    Hi ernesto!
    Öffne mal die Datei "/etc/X11/xinit/xinitrc". Dort stehen am Schluss die Programme, die mit dem XServer gestartet werden sollen. Einfach die entsprechenden Zeilen auskommentieren oder löschen, schon bist du die "pop-ups" los.

    Gruß
    Tobi
     
  7. Maveric

    Maveric MacUser Mitglied

    Beiträge:
    462
    Zustimmungen:
    0
    Registriert seit:
    22.03.2004
    @all
    Windowmanager sind immer eine Frage des persönlichen Geschmackes. Ich hab hier Enlightenment, wenn es schnell gehen muss mit dem Laden von OOo und XDarwin. Von seiner Bedienbarkeit bin ich recht angetan und wenn man weiß welche Konfigurationsdateien oder Menüs verwendet werden müssen um ihn
    anzupassen macht er richtig Spaß.

    Für Linuxfeeling und/oder lange Sessions, sprich wenn ich was in OOo schreib und dafür Browser und Co offen haben muss um hin und her zu kopieren etc., hab ich gnome samt Metacity Windowmanager installiert. Metacity ist nicht ganz so komfortabel konfigurierbar dafür halt besser in gnome eingebunden.

    Das Problem dürfte bei diesen WMs aber sein, dass sie nicht wie OS X aussehen und auch keinen Hehl draus machen, es sind reine Unixdesktops und sie haben zwar Themen mit denen sie wie ein Aqua aussehen können und das auch täuschend ähnlich, nur das ist Konfigurationsarbeit über die Kommandozeile teilweise und viele manpages lesen.

    @ernesto
    Ich werde nicht so ganz schlau aus deinen Beiträgen:
    Was für ein OS X hast Du? XDarwin oder X11?
    Wenn XDarwin welche Version und vor allem welches OOo?
    Bei der 1.0.3 war XDarwin in 4.3.0 dabei und der ist neben Apples X11 noch immer der empfehlenswerteste.

    @all
    Das Orobor Problem kann daran liegen, das StartOOo einfach nicht für OS X 10.3 gedacht ist und Terry fieberhaft an einer neuen Version arbeitet die in die endgültige 1.1.1 rein soll. Ich hab es selber rausgefunden und glaub ich irgendwo auch mal geschrieben, es gibt Tage da funzt StartOOo und es gibt Tage da geht gar nix. Es liegt aller Wahrscheinlichkeit nach an bestimmten Aurufroutinenen für X11 die sich bei 10.3 geändert haben und je nachdem wie es "gelaunt" ist scheint 10.3 sich mal dran zu stören, mal nicht.

    Da ich aktuell kein OroborOSX habe kann ich leider nicht weiterhelfen. Er sollte aber wenn StartOOo nicht verwendet wird mit der 1.1.1 und XDarwin 4.3.0 zusammenarbeiten.

    Halt eines weiß ich noch. OroborOSX hat sein eigenes Konfigurationsmenü und ne eigene xinit irgendwo im Paket drin, sprich alles was der Anwender in seiner xinit oder XDarwin einstellt wird von OroborOSX ignoriert, so war es jedenfalls noch bei der 0.8.5. Es hat mich nämlich damals irgendwas wahnsinnig gemacht und ich hatte es in meiner .xinitrc im Home abgeschalten und in XDarwin auch aber trotzdem noch in OroborOSX während blackbox und Co sich richtig verhielten.

    Das Startscript der 1.1.1 TechPreview funzt astrein, so lange X11 von Apple verwendet wird. Daran das es auch XDarwin erkennt arbeite ich gerade mit einem anderen aus dem Mac Porting Team. Da das neue StartOOo Script als Basis für das provisorische Script in der Techpreview diente, denk ich mal das die Probleme in den Griff zu bekommen sind und die finale 1.1.1 ein Starscript hat welches X11/ XDarwin und OOo 1.1.1 erkennt und die jeweilige Kombination startet.

    Wo es die Techpreview gibt steht hier http://www.macuser.de/forum/showthread.php?s=&postid=239390 im Forum.

    Gruß
    Eric Hoch
    de.OpenOffice.org Teammitglied.
     
    Zuletzt von einem Moderator bearbeitet: 02.03.2016
  8. Christen

    Christen MacUser Mitglied

    Beiträge:
    843
    Zustimmungen:
    0
    Registriert seit:
    07.01.2003
    In der Tat liegt das Problem beim Programm "Start OpenOffice.org"

    Lösung:
    Unter OroborOX (oder auch XDarwin) in einem XTerm-Fenster folgendes eingeben:
    "cd OpenOffice.org1.1.1" (wobei dies der Name des Order ist (hier im Benutzer-Verzeichnis, ansonsten z.B. "cd /Applications/OpenOffice.org1.0.3/program/), in welcher OpenOffice installiert wurde)
    dann noch:
    "./soffice"
     
    Zuletzt bearbeitet: 03.04.2004
  9. ernesto

    ernesto Thread Starter MacUser Mitglied

    Beiträge:
    1.375
    Zustimmungen:
    9
    Registriert seit:
    19.02.2003
    Re: Re: OpenOffice bzw.XDarwin

     

    hallo Jungs,
    momentan tut alles ohne Orobor.
    Ich werd Deinen Tip ausprobieren und ich denke, dann wars das, was noch fehlte.
    Ansosnten bleibt mir nur:

    mal wieder VIEEELEN Dank an alle!!!

    Gruß aus Brasilien
    ernesto
     
  10. ernesto

    ernesto Thread Starter MacUser Mitglied

    Beiträge:
    1.375
    Zustimmungen:
    9
    Registriert seit:
    19.02.2003
    Re: Re: OpenOffice bzw.XDarwin

     


    Hi twjb,
    kannste mir auch sagen, wo ich die Datei finde??

    Mag sein, das macht Unterschied, ich habe OX 10.2.8
     
Die Seite wird geladen...
Ähnliche Themen - OpenOffice bzw XDarwin Forum Datum
Xdarwin Mac OS X - Unix & Terminal 14.07.2006
OpenOffice 2.0 schriftproblem Mac OS X - Unix & Terminal 07.12.2005
anmeldung manuell bzw uid ändern? Mac OS X - Unix & Terminal 21.03.2005
OpenOffice (Permissions u.a.) Mac OS X - Unix & Terminal 10.01.2004

Diese Seite empfehlen

Benutzerdefinierte Suche