open_basedir Problem

Dieses Thema im Forum "Mac OS X Server, Serverdienste" wurde erstellt von made, 27.06.2006.

  1. made

    made Thread Starter MacUser Mitglied

    Beiträge:
    97
    Zustimmungen:
    1
    MacUser seit:
    06.07.2005
    Hallo,

    ich hab folgendes Problem, hab auf einem 10.4er Server ein paar Webseiten laufen, jetzt möchte ich gerne, dass da keine der anderen ins Gehege kommen kann und wollte den PHP Zugriff mittels open_basedir einschränken, hab also in die vom Server Admin angelegte Datei in /etc/httpd/sites/0001_meine_ip_80_domain.de.conf die Zeile php_admin_value open_basedir /Users/test/ eingefügt, dann dort rein eine phpinfo() Datei, Apache neu gestartet, die phpinfo aufgerufen und bei open_basedir steht no value.

    Kann mir jemand sagen, was ich falsch mache, ich steh grade auf dem Schlauch.

    Danke

    Marc
     
  2. m-schmidt

    m-schmidt MacUser Mitglied

    Beiträge:
    364
    Zustimmungen:
    1
    MacUser seit:
    18.01.2006
    hmm, also ich kenne mich mit einem mac osx server jetzt nicht direkt aus (nur mit Linux Systemen), deswegen erstmal die Frage: Läuft da ein ganz normaler Apache drauf? Wenn ja, würd ich als nächstes mal die Frage stellen, ob du den schon neu gestartet hast, damit die neue Config eingelesen wird (falls das nötig ist).

    Wenn das nix hilft, wäre mal interessant, was in dieser sites/0001_ ... Datei sonst noch so alles drin steht. Denn letztlicht muss ja der open_basedir Parameter zum Virtual Host und ich bin mir jetzt nicht sicher (weil ich wie gesagt, nicht weiß wie der Mac OSX Server die ganzen Config-Files strukturiert) ob genau dieser in der Datei definiert wird, wo du die Parameter reingeschrieben hast.
     
  3. made

    made Thread Starter MacUser Mitglied

    Beiträge:
    97
    Zustimmungen:
    1
    MacUser seit:
    06.07.2005
    Hallo,

    auf dem Sever läuft der Apache 1.3.33 und ja, den hab ich auch neu gestartet, in der Datei, die das Konfigurationstool für jeden vHost anlegt und die von der httpd.conf aufgerufen wird, ist folgender Eintrag:

    Code:
    <VirtualHost IP:PORT>
    	ServerName SERNAME
    	ServerAdmin SERVERNAME
    	DocumentRoot "/Users/test/Sites"
    	DirectoryIndex "index.html" "index.php"
    	CustomLog "/var/log/httpd/access_log" "%{PC-Remote-Addr}i %l %u %t \"%r\" %>s %b"
    	ErrorLog "/var/log/httpd/error_log"
    	ErrorDocument 404 /index.html
    	<IfModule mod_ssl.c>
    		SSLEngine Off
    		SSLLog "/var/log/httpd/ssl_engine_log"
    		SSLCertificateFile "/etc/certificates/Default.crt"
    		SSLCertificateKeyFile "/etc/certificates/Default.key"
    		SSLCipherSuite "ALL:!ADH:RC4+RSA:+HIGH:+MEDIUM:+LOW:!SSLv2:+EXP:+eNULL"
    	</IfModule>
    	<IfModule mod_dav.c>
    		DAVLockDB "/var/run/davlocks/.davlock100"
    		DAVMinTimeout 600
    	</IfModule>
    	<Directory "/Users/test/Sites">
    		Options All -Indexes -ExecCGI -Includes +MultiViews
    		<IfModule mod_dav.c>
    			DAV Off
    		</IfModule>
    		AllowOverride None
    	</Directory>
    	<IfModule mod_rewrite.c>
    		RewriteEngine On
    		RewriteCond %{REQUEST_METHOD} ^TRACE
    		RewriteRule .* - [F]
    	</IfModule>
    	<IfModule mod_alias.c>
    	</IfModule>
    	LogLevel warn
    	php_admin_flag safe_mode On
    	php_admin_value open_basedir /Users/test/
    </VirtualHost>
    Danke

    Marc
     
  4. m-schmidt

    m-schmidt MacUser Mitglied

    Beiträge:
    364
    Zustimmungen:
    1
    MacUser seit:
    18.01.2006
    gut, also bei meinem linux-server schaut das auch in etwa so aus. Unterschied ist jedoch, dass das der safe_mode außerhalb des virtual host definiert ist. Das ist ja auch wichtig so, denn alle virtual hosts müssen ja vom safe mode betroffen sein, damit das Ganze Sinn macht und den vhosts wird dann explizit gesagt, wo sie "arbeiten" dürfen. Also versuch doch mal das "php_admin_flag safe_mode On" in die allgemeinde server-config (evtl. httpd.conf) zu schreiben.
     
  5. made

    made Thread Starter MacUser Mitglied

    Beiträge:
    97
    Zustimmungen:
    1
    MacUser seit:
    06.07.2005
    Hab den Safe Mode komplett raus genommen, bringt aber auch keine Besserung
     
Die Seite wird geladen...

Diese Seite empfehlen