Open Office hat Problem mit Schrift bei PPT Präsentation

Dieses Thema im Forum "Office Software" wurde erstellt von Scyx, 14.06.2004.

  1. Scyx

    Scyx Thread Starter MacUser Mitglied

    Beiträge:
    133
    Zustimmungen:
    0
    MacUser seit:
    26.02.2004
    Open Office hat Problem mit Sonderzeichen bei PPT Präsentation

    Hallo!

    Ich hab das Problem, dass mathematische Sonderzeichen wie z.B. das Summenzeichzen oder Pfeile garnicht angezeigt werden. Kann mir bitte einer sagen, was ich das zusätzlich installieren muss, ein Plug-In oder was?
    Bei Open Office 1.1.0 auf meinem Linux Rechner stellt er alles bis auf "kleines Omega" und "kleines Theta" ordentlich dar... Aber ob das was zu sagen hat... :)


    P.S. Die Darstellung ist insgesamt komisch beim iBook. Obwohl's doch eigentlich die gleichen Schrifttypen (hauptsächlich Arial) vorkommen, passt das nicht so toll.


    Gruß

    Scyx
     
    Zuletzt bearbeitet: 14.06.2004
  2. Maveric

    Maveric MacUser Mitglied

    Beiträge:
    462
    Zustimmungen:
    0
    MacUser seit:
    22.03.2004
    Das ist ein eigentlich schon sehr lange behobenes Problem, welches in erster Linie von einer defekten OpenSymbol Schriftart hauptverantworlich verursacht wurde.

    Selbst der Fehler unter Linux sollte in der 1.1.0 nicht mehr auftauchen. Hast du hier vielleicht ein Update von 1.0.x auf 1.1.0 gemacht? Das ging damals noch nicht so gut und hat daher leider ein paar Fehler, die in 1.1.x eigentlich behoben sind, eben nicht behoben weil die entsprechenden Dateien nicht upgedatet wurden. Es geht dabei hauptsächlich um benutzerspezifische Daten und bei den Formeln spielt eine Schrifartendatei dabei eine Rolle die zu den persönlichen Daten gehört. Auch ein einfach in das alte Verzeichnis installiertes 1.1.0 kann sich so verhalten.

    Daher würde ich unter Linux einfach die 1.1.0 in ein ganz neu angelegtes Verzeichnis zu installieren und zu schauen, ob der Fehler dann noch immer auftaucht. Wenn ja dann wende dich bitte an die Usersmailingliste des deutschen OOo Projektes. Informationen zur Liste und zur Anmeldeprozedur findest du hier. Bitte meld dich wirklich, denn dieser Fehler wäre möglicherweise ein Grund die kommende Version 1.1.2 genauer zu prüfen und deren Erscheinen zu stoppen, denn Darstellungsprobleme bei Formeln sollten wirklich nicht mehr auftauchen.

    Wenn du allerdings eine Debian oder sonstige nicht offizielle OOo Version verwendest (auch die von SuSE ist nicht identisch mit der offiziell von uns angebotenen), dann wende dich auch direkt an den Hersteller der Distribution bzw. probiere erstmal die offizielle Version aus.

    Zurück zum eigentlichen Mac Problem:
    Wie erwähnt ist dieses Problem schon lange behoben und sollte nicht mehr auftauchen. Ich bräuchte aber ein paar mehr Informationen um konkreter Helfen zu können.

    1. Welches X verwendest du? Apple's X11 oder Xfree86/XDarwin und wenn XDarwin, welche Version. Empfohlen für Xfree86 wird jeder Build ab 4.3.0 bis hoch zu 4.3.99.901. Die finale 4.4.0 von Xfree86/XDarwin funktioniert nicht mit OpenOffice.org und zeigt genau das von dir beschriebene Verhalten.

    2. Welche Version von OpenOffice.org für Mac OS X verwendest du denn? Die 1.0.3?

    Wenn ja dann lade dir bitte mal die neueste Technology Preview herunter. Diese Version ist, auch wenn der Name anderes vermuten läßt, komplett eingedeutscht und läuft nur unter Panther mit jedem X, egal ob Apple's X11 oder Xfree86 in geeigneter Version und basiert auf dem Code der kommenden 1.1.2. Neuerungen gegenüber der alten 1.0.3 und früheren Technologypreviews findest du im Laufe des Tages hier im Archiv der Usersmailingliste. Die Installation läuft vollständig und nativ unter Aqua und kommt sich nicht mit eventuelle schon installierten Vorversionen von OOo in die Quere. Zumindest hat sie hier auf meinem Mac die bereits installierte 1.0.3 nicht beschädigt.

    Das mit den Schriften die identisch sind stimmt so auch nicht. Da Darwin, der Kern von OS X, nur Unixschrifarten mitbringt, bringt das installierte X11 seine eigenen Schriften mit, die aber wiederum nur dem Namen nach die gleichen wie die unter Windows sind, typographisch liegen Welten zwischen der Times die X11 mitbringt und der jenigen TTF Times New Roman, die man gemeinhin kennt. Daher hat die Technology Preview im Menü Datei->Autopilot->Schriftarten aus dem Internet herunterladen ein Makrodokument mit dem sich der Anwender die gewünschten Windowsschrifarten und ein paar mehr Unixschriftarten die OOo verwerten kann herunterladen kann. Sehr empfehlenswert.

    Ich hoffe dir trotz der Länge meines Beitrages wenigstens ein wenig geholfen zu haben.

    Gruß
    Eric Hoch
    de.OpenOffice.org Teammitglied
     
  3. Scyx

    Scyx Thread Starter MacUser Mitglied

    Beiträge:
    133
    Zustimmungen:
    0
    MacUser seit:
    26.02.2004
    Hab mir jetzt das Technology preview besorgt und installiert, dann nach der Anleitung weitere Schriftarten installiert. Die Darstellung ist im großen und ganzen ganz schön, nur fehlen immer noch die mathematischen Zeichen wie Pfeil, Summenzeichen.

    Kannst Du mir was dazu sagen Maveric? Kann sein, dass Du es in deinem Beitrag geschrieben hast, weis mich bitte darauf hin, das habe ich dann vermutlich überlesen ;D

    Danke aber auf jeden Fall mal für die bisherige Antwort

    Gruß

    Cedric
     
  4. Maveric

    Maveric MacUser Mitglied

    Beiträge:
    462
    Zustimmungen:
    0
    MacUser seit:
    22.03.2004
     

    Das sollte nicht mehr passieren und passiert auch bei mir nicht. Schickst du mir bitte mal das Dokument per privater Mail an die hier in meinem Profil angegebene Emailadresse? Ich will mir das mal anschauen, denn ich konnte den Fehler gestern absolut nicht reproduzieren, von daher wäre vielleicht ne kleine Anleitung, wie du zu dem Fehler kommst auch nicht schlecht.

    Wenn der Fehler wirklich existiert, dann wäre das ein Showstopper der die 1.1.x Final für Mac OS X aufhalten würde. Daher bitte, bitte meld dich auf der Users Mailingliste
    des deutschen OOo Projektes oder schick direkt ne Email an developer at de PUNKT openoffice PUNKT org (Worte durch Zeichen ersetzen und Leerzeichen weglassen).

    Gleiches gilt für das Linuxssystem, auch da darf, soll, ja muss der Fehler sogar nicht vorhanden sein. Wir sind gerade dabei der 1.1.2 grünes Licht zu geben und das darf mit dem Fehler, falls es wirklich einer ist, eigentlich nicht passieren.

    Und nochmal die Frage:
    Welches X setzt du ein? Apple's X11 oder Xfree86? Das kann entscheidend sein.
     
  5. Scyx

    Scyx Thread Starter MacUser Mitglied

    Beiträge:
    133
    Zustimmungen:
    0
    MacUser seit:
    26.02.2004
    Stimmt, sollte ich hier mal noch für die Zukunft schreiben :)
    Ich benutze X11 von Apple.
     
  6. Christen

    Christen MacUser Mitglied

    Beiträge:
    843
    Zustimmungen:
    0
    MacUser seit:
    07.01.2003
    Hi Scyx,

    Es kommt sehr darauf an welche Schriftart man verwendet.
    In der aktuellen Version 1.1.x, unter Panther/X11, in einem Textdokument und Präsentationsdokument (PPT?) finde ich sowohl "Summenzeichen" als auch Pfeilzeichen.
    Und zwar unter "Einfügen/Sonderzeichen".
    Es könnte also auch an den übers Internet installierten Schriften liegen.
    Auch müsste man wissen bei welcher Schrift es Unterschiede zu anderen Betriebsystemen gibt. Bei welcher/n Schrift/en tritt das Problem auf?

    Gruss

    Chris
     
  7. Scyx

    Scyx Thread Starter MacUser Mitglied

    Beiträge:
    133
    Zustimmungen:
    0
    MacUser seit:
    26.02.2004
    Hab mal die Formel angekuckt, wenn ich doppelt drauf klicke, öffnet sich ein weiteres Fenster in dem die Formel dann mit sämtlichen Zeichen richtig steht!
    Sogar die unter Linux nicht erscheinenden Zeichen werden dort korrekt dargestellt.
    @Christen: Wenn Du mir bitte sagst, wo ich die Schrift bei Formeln ändern kann, schaue ich gerne nach. Ich finde dafür leider keine Möglichkeit. Es scheint mir ausserdem, dass bei Formeln stets eine Standardschriftart verwendet wird.
    Hab sämtliche Schriften über die Funktion in OOo, bis auf die Asiatischen, aus'm I-Net installiert, Comic Sans MS ist da auch dabei.
    Aber wie gesagt, die Darstellung erfolgt korrekt, nur leider nicht in der eigentlichen Präsentation.
    Wäre schön, wenn's 'ne Möglichkeit gäbe das zum Laufen zu bringen, ohne dass ich sämtliche Formel kopieren und dann wieder einfügen muss.
    Zudem sind diese "einzelnen" Formeln (die ich durch Doppelklick erhalte) schreibgeschützt, ich kann sie nicht mal markieren oder kopieren.

    So wirklich schlau werd ich daraus leider nicht, denn er kann's ja richtig darstellen...

    gruß

    Scyx
     
  8. Christen

    Christen MacUser Mitglied

    Beiträge:
    843
    Zustimmungen:
    0
    MacUser seit:
    07.01.2003
    Die Schriften kannst du unter "Format/Schriftarten" ändern.
    Hab nun eine Testpräsentation unter OOo 1.1.1 mit der eingebeteten Testformel "1+1=2 rightarrow" erstellt und unter OOo 1.1.2 geöffnet. OpenOffice 1.1.2 stellt dabei alles richtig dar.
    Ansonsten versuch die Datei unter einem neuen Namen zu speichern, oder die Formel zu löschen und neu einzufügen.
     
  9. Scyx

    Scyx Thread Starter MacUser Mitglied

    Beiträge:
    133
    Zustimmungen:
    0
    MacUser seit:
    26.02.2004
    Tut mir furchtbar leid, aber unter dem Menüpunkt "Format" finde ich keine Schaltfläche namens "Schriftart".
    Oder suche ich an der falschen Stelle?

    Gruß

    Scyx
     
  10. Christen

    Christen MacUser Mitglied

    Beiträge:
    843
    Zustimmungen:
    0
    MacUser seit:
    07.01.2003
    Schiftarten im Formeleditor findet man unter:
    "Format/Schriftarten..." - "Format/Fonts..."

    In den anderen Dokumenten wie der Präsentation unter:
    "Format/Zeichen..." - "Format/Character..."
     
Die Seite wird geladen...