Netzwerk Mac-PC sehr langsam

Dieses Thema im Forum "Internet- und Netzwerk-Hardware" wurde erstellt von minos5000, 22.04.2004.

  1. minos5000

    minos5000 Thread Starter MacUser Mitglied

    Beiträge:
    165
    Zustimmungen:
    1
    MacUser seit:
    10.02.2004
    Hi,

    ich habe ein Problem, wenn ich mein iBook (OSx10.3.3) und meinen PC (XP2400+, VIA KT266A, Realtek Netzwerkarte) verbinden und Daten übertragen möchte. Dabei ist es egal in welche Richtung die Daten gesendet/geschickt werden, die Übertragungsrate liegt jeweils bei 100-150KB/s, was ich für eine 100MBit Verbindung doch für inakzeptabel halte.

    Auch der Versuch, die iBook Netzkarte manuell zu konfigurieren hat nicht geholfen.

    Anzumerken ist noch, daß vor ein paar Wochen die Verbindung einige Male in normaler Geschwindigkeit erfolgt ist, was allerdings nicht reproduzierbar war.


    Ich hoffe mir kann jmd bei dem Problem helfen.



    so long minos
     
  2. Homer

    Homer MacUser Mitglied

    Beiträge:
    1.242
    Zustimmungen:
    7
    MacUser seit:
    22.03.2003
    Was mir zuerst einfällt wäre ne Firewall auf Mac oder PC.

    Wie genau sind die beiden Rechner verbunden? Crosskabel oder über nen Switch/Hub?

    Homer
     
  3. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    hallo,

    bei Netzwerkproblemen ist es oft bzw so gut wie immer von Vorteil den Netzwerkverkehr zu analysieren während das Problem auftritt.
    Dies kann man unter Mac OS X am einfachsten durch das Kommando
    sudo tcpdump
    durchführen.

    Du kannst gerne die Ausgabe hier posten, damit man sich das mal ansehen kann.
    Mögliche Ursachen sind so oft schnell zu identifizieren.

    Interessant sind immer auch die Vorgehensweise und die Umgebung:
    Wie stellst Du die Verbindung her ()?
    Benutzt Du Namen oder IP Adressen ?
    Hast Du Arbeitsgruppe aufeinander abgestimmt?
    Wie sieht die physikalische Verbindung aus ?
    usw.

    Je mehr Info Du lieferst, um so größer sind die Erfolgsaussichten.

    @Homer
    btw:
    beim aktuellen iBook (und überhaupt allen neueren Macs) ist es egal, ob Du ein CrossOver oder StraightThroug Kabell verwendest.
    Die NIC verwendet autodetect
     
    Zuletzt bearbeitet: 22.04.2004
  4. docbirne

    docbirne MacUser Mitglied

    Beiträge:
    172
    Zustimmungen:
    0
    MacUser seit:
    21.08.2002
    als MacDepp in die Fragerunde reinhängen

    Hallo,

    ich möcht ja nicht unhöflich sein, aber ich scheitere schon am Aufbau einer Verbindung zw. ibook G3 600 10.3.3 und nem IBM-PC winxp prof.

    Kann mir jemand ne einfache Anleitung senden in der auch steht was für ein Netzwerkkabel ich brauche? (evtl. auch direkt an 01797350404@genion.de)

    Danke schon mal.

    docbirne
     
  5. Homer

    Homer MacUser Mitglied

    Beiträge:
    1.242
    Zustimmungen:
    7
    MacUser seit:
    22.03.2003
    Schau mal in meine Signatur...

    Homer
     
  6. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    Re: als MacDepp in die Fragerunde reinhängen

     

    wenn keine der verwendeten Netzwerkkarten autodetect unterstützt, und du die Karten ohne Hub/Switch verbindest, benötigst Du ein CrossoverKabel, mit autodetect ist es egal, welches Kabel du nimmst
    Zuerst testest Du dann die Physikalische Verbindung und die Zuordnung zum richtigen logischen Netz mit einem ping.
    Solange der nicht geht, kannste alles andere vergessen.
    Falls er nicht geht, sag uns das und poste die von Dir verwendeten Netzwerkeinstellungen (IP Adressen, Subnetzmasken)
    Dannach kannste ja ein
    sudo tcpdump
    machen und die Ausgaben hier posten.

    Wenn Du aber weiterhin nur im Stil: "Hilfe - es geht nicht!" schreibst, wird man Dir kaum helfen können.

    Außerdem empfehle ich Dir
    das
    und das
    zu lesen ;)
     
  7. minos5000

    minos5000 Thread Starter MacUser Mitglied

    Beiträge:
    165
    Zustimmungen:
    1
    MacUser seit:
    10.02.2004
    Ok,

    - verbunden sind die beiden über ein Crossover-Kabel
    - identifizieren tu ich die per IP-Adresse
    - Arbeitsgruppe?? Häh, gibt's das auch beim Mac??


    tcpdump hab ich auch einmal durchlaufen lassen, das ist dabei herausgekommen:

    Ich hoffe, daß ist aussagekräftig genug, hab nämlich keine Lust das Ding bis in alle Ewigkeit laufen zu lassen. Wie man sieht, ging das ja nicht allzu schnell vorwärts.

    Ich hab inwzischen auch mal versucht per ftp auf den Mac zuzugreifen, ging aber auch nicht schneller :-(


    so long
     
  8. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    hallo minos5000,

    Diese Zeilen tauchen immer wieder auf.
    Daraus entnehme ich, dass sich der Rechner mit der IP 192.168.0.77 sich die Mac-Adresse des Rechners 192.168.0.70 (wer was ist wissen wir ja leider immer noch nicht) nicht merken kann, obwohl dieser Sie bereitwillig zur Verfügung stellt.

    Probier mal ob die Verbindung nach
    sudo arp -s 192.168.0.70 00:0a:95:ef:93:c4
    schneller wird.

    Bitte mach vorher und nachher
    arp -a
    um zu kontrollieren, dass der Wert übernommen wurde.

    16:18:31.797528 IP 192.168.0.77.netbios-ns > 192.168.0.255.netbios-ns: NBT UDP PACKET(137): QUERY; REQUEST; BROADCAST
    das wiederholte Auftauchen dieser Zeile produziert deutet daraufhin, dass der rechner ...77 nich registriert wird.
    Hast Du an der Dose Netbios over TCP/IP an oder aus ?
    Wenn er mit Windows "reden" soll - na klar.
    Eingestellt wird Sie unter Programme > Dienstprogramme > Verzeichnisdienste > SMB.
    Sollte man aufeinander Abstimmen.

    Und dass es so extrem langsam geht, deutet daraufhin, dass Du in dieser Zeit keine Dateien übertragen hast (dann sieht man antürlich nix) und/oder evtl. ein Problem mit der physikalischen Verbindung

    Bitte Dein Vorgehen nicht noch ausführlicher beschreiben !!!
     
    Zuletzt bearbeitet: 22.04.2004
  9. minos5000

    minos5000 Thread Starter MacUser Mitglied

    Beiträge:
    165
    Zustimmungen:
    1
    MacUser seit:
    10.02.2004
    @ Vorgehen
    Der Mac hat die 70er und der PC die 77er Adresse, Windows-Sharing ist aktiviert, sonst nix.
    Wenn ich vom PC auf den Mac zugreifen will geb ich in die Adressleiste vom IExplorer "\\192.168.0.70" ein, dann kommt eine Aufforderung für Benutzernamen und Pwd und der Mac erscheint.
    Umgekehrt mach ich das über Samba mittels Apfel-K und "smb://192.168.0.77"

    NetBIOS hab ich beim PC aktiviert.


    Bisher hab ich vom PC auf den Mac immer nur per IExplorer zugegriffen, nie per Netzwerkumgebung. Hab jetzt aber das ganze per Arbeitsgruppe versucht und der Mac erscheint auch, nur nicht in der Gruppe die ich angegeben habe sondern immer nur in "Workgroup", keine Ahnung woran das liegt, an der Geschwindigkeit hat sich jedenfalls nichts geändert. Sollte eigentlich auch egal sein, wierum ich da zugreife.


    Das erstaunlich ist, daß bei einem Versuch eben die Richtung PC->Mac normal schnell war. Hier mal ein Stück vom Protokoll.

    Die anderer Richtung bleibt langsam:


    Der "arp" Befehl hat auch nicht Wirklich weitergholfen, er hat folgendes ausgespuckt:
    .. auf jeden Fall hat er den Wert nicht übernommen.



    so long
     
  10. Homer

    Homer MacUser Mitglied

    Beiträge:
    1.242
    Zustimmungen:
    7
    MacUser seit:
    22.03.2003
    Ob in der gleichen Arbeitsgruppe oder nicht hat absolut nix mit Geschwindigkeit bei der Datenübertragung zu tun...

    Homer
     
Die Seite wird geladen...