MYSQL Problem

Dieses Thema im Forum "Datenbanksysteme für das Web" wurde erstellt von ThaHammer, 18.11.2004.

  1. ThaHammer

    ThaHammer Thread Starter MacUser Mitglied

    Beiträge:
    3.276
    Zustimmungen:
    13
    MacUser seit:
    01.06.2004
    Gestern beim demonstrieren von MYSQL, Apache und PHP an meinem kleinen Pismo hatte ich auf einmal ein komisches Problem!
    Zuerst lief PHPMyAdmin noch einwandfrei, auf einmal verlangte MYSQL das Admin Login und Passwort, akzeptierte es aber nicht, obwohl es stimmte. Habe nachgeschaut in der conf Datei!
    Ich hatte nur von PhpMyAdmin nach Webmin gewechselt um was nachzuschauen. Das einzige was ich wirklich geändert habe, war eine php Datei die zu einem Shopsystem gehört, dort muß man das Login und Passwort eingeben. Das hatte ich geändert, ansonsten nichts.

    Allerdings hat er sich Gestern mal wieder beim Booten ins 10.3.6 dreimal verabschiedet, mußte also neustarten.

    Kann es sein das es MYSQL zerlegt hat? Die conf Datei mit Login und Passwort ist soweit OK.
     
  2. wegus

    wegus MacUser Mitglied

    Beiträge:
    15.039
    Zustimmungen:
    1.316
    MacUser seit:
    13.09.2004
    Frag doch mysql selbst:

    -Terminal öffnen

    >mysql -uroot -pDeinPasswort

    eingeben. Startet dann der mysql-Client ist zumindest mysql noch da und Dein root-Zugang korrekt. Solltest Du via phpmyadmin einen anderen account verwenden. Kannst Du den ebenfalls so testen, sofern er access für localhost hat.
     
  3. cilly

    cilly Gast

    Schon mal probiert, die Passwörter neu anzulegen?

    Falls du das Root-Passwort neu anlegen musst:

    How do I set a new password for the mysql root user after loosing it?
     
  4. ThaHammer

    ThaHammer Thread Starter MacUser Mitglied

    Beiträge:
    3.276
    Zustimmungen:
    13
    MacUser seit:
    01.06.2004
    mysql: command not found

    Aber das bringt er seit einem Update dauernd. Wie gebe ich ihm die Pfade zu MYSL/Bin wieder dauerhaft?
     
  5. cilly

    cilly Gast

    Nun, dann solltest du die Pfade wieder hinzufügen. Wenn du bash benützt, dann editiere:

    /etc/profile

    Bei mir sieht das so aus:

    cat /etc/profile
    Code:
    # System-wide .profile for sh(1)
     
     PATH="/bin:/sbin:/usr/bin:/usr/sbin"
     export PATH
     
     [ -r /etc/bashrc ] && source /etc/bashrc
     
     PATH="$PATH:/usr/local/bin:/usr/local/sbin"
     
     PATH="$PATH:/usr/X11R6/bin:/usr/X11R6/sbin"			   
     
     PATH="$PATH:/usr/local/mysql/bin:/usr/local/mysql/sbin"
     
     PATH="$PATH:/Developer/Tools"
     
     export ARCH=macosx
     
  6. wegus

    wegus MacUser Mitglied

    Beiträge:
    15.039
    Zustimmungen:
    1.316
    MacUser seit:
    13.09.2004
    Das gehört in die bash_profile in Deinem Home-Verzeichnis.
    Genau Syntax mußt Du Dir bitte suchen, gibts aber glaub ich hier auch im Forum.

    Fängt an mit "export PATH="...

    *AH cilly war schneller, die /etc/profile geht auch, ist dann auch gleich Systemweit für alle user*
     
    Zuletzt bearbeitet: 18.11.2004
  7. ThaHammer

    ThaHammer Thread Starter MacUser Mitglied

    Beiträge:
    3.276
    Zustimmungen:
    13
    MacUser seit:
    01.06.2004
    Danke! Jetzt findet er den Bin Pfad wieder! :)

    Trotzdem gehts noch nicht. Habe mysql neu installiert.
     
  8. cilly

    cilly Gast

  9. ThaHammer

    ThaHammer Thread Starter MacUser Mitglied

    Beiträge:
    3.276
    Zustimmungen:
    13
    MacUser seit:
    01.06.2004
    Das ist die Version!
     
  10. wegus

    wegus MacUser Mitglied

    Beiträge:
    15.039
    Zustimmungen:
    1.316
    MacUser seit:
    13.09.2004
    Was ist mit dem Login per Konsole ? Geht das ?
     
Die Seite wird geladen...

Diese Seite empfehlen