Mail URL Link Umbruch Bekomm die Krise Hilfe!!!

Dieses Thema im Forum "Mac OS X Apps" wurde erstellt von onkelhelmut, 13.04.2004.

  1. onkelhelmut

    onkelhelmut Thread Starter MacUser Mitglied

    Beiträge:
    311
    Zustimmungen:
    0
    Registriert seit:
    08.05.2003
    Hallo

    Ich habe folgendes Problem mit dem Programm Mail. Immer wenn ich eine überlange URL habe, die ich in meine Mail einfügen möchte, egal ob durch Apfel C und Apfel V oder durch Drag and Drop bricht das Programm Mail den Link um.

    Dies geschieht je nach Länge der Mail auch mehrfach. Allerdings wenn ich es richtig beobachtet habe ausschließlich nach einem Fragezeichen. Genauer gesagt, es fügt dann ein unnötiges Leerzeichen ein und bricht dann um, so das der Link kaputt ist.

    Wenn die Person an die ich die Mail geschickt habe auf den Link klickt, läßt sich somit die Seite nicht aufrufen, oder je nach URL nur die Hauptseite, wenn der Link dementsprechend gestaltet ist.

    Dieses Problem muß mit dem Programm Mail zusammenhängen, denn wenn ich Webmails schicke sowohl über GMX als auch über.mac tritt dieses Problem nicht auf. Es ist anscheinend zudem auch egal welcher Browser, welches Mailprogramm der Empfänger hat oder welches Webmailsystem der Empfänger meiner Mail benutzt.

    Dieses Problem tritt z.B. im Internet Explorer for Mac, Internet Explorer für Windows, Netscape 7.1 for Mac, Mozilla für Windows, bei GMX, bei web.de, bei .mac als Webmail, bei Eudora für Windows auf, um nur die gängisten Möglichkeiten aufzuzählen, welche Kombinationen die Empfänger meiner Emails benutzen.

    Lediglich wenn der Empfänger meiner Email auch das Programm Mail von Macintosh benutzt fügt das Programm Mail den Link wieder vollständig korrekt zusammen.


    Habe hier in den Foren und auch bei Google schon reichlich gesucht und nichts aber auch rein gar nichts zum Thema gefunden.

    Ist irgendjemand hier das Problem bekannt???


    Vorab vielen Dank für Lösungsvorschläge.


    Liebe Grüße aus dem Ruhrpott

    Onkelhelmut
     
  2. onkelhelmut

    onkelhelmut Thread Starter MacUser Mitglied

    Beiträge:
    311
    Zustimmungen:
    0
    Registriert seit:
    08.05.2003
    Nochmals Hallo!!!

    Fällt wirklich niemandem etwas zu dem Thema ein. Hatte noch niemand von euch auch das Problem.

    Wäre über jeden kleinsten Lösungsansatz sehr dankbar.


    Liebe Grüße aus dem Ruhrpott

    Onkelhelmut
     
  3. neptun

    neptun MacUser Mitglied

    Beiträge:
    2.013
    Zustimmungen:
    22
    Registriert seit:
    28.09.2003
    das Zauberwort heisst ...

    ... tinyurl!

    Hier werden lange Adressen in kurze verwandelt:
    http://tinyurl.com/

    Gruss, neptun
     
  4. onkelhelmut

    onkelhelmut Thread Starter MacUser Mitglied

    Beiträge:
    311
    Zustimmungen:
    0
    Registriert seit:
    08.05.2003
    URL Umbruch

    Hallo Neptun

    Vielen Dank für Deine Antwort. Sehr interessante Seite.

    Aber bei meinem Problem scheint sie nicht helfen zu können. Habe es mit mehreren dieser ? Leerzeichen Umbruch URLs probiert und nicht eine hat leider geklappt.

    Er zeigt dann nur diese Fehlermeldung an:

    Warning: mysql_pconnect(): Host 'gilby.com' is blocked because of many connection errors. Unblock with 'mysqladmin flush-hosts' in /home/sites/site15/web/db_connect.php on line 3

    Fatal error: Call to undefined function: mysqlerror() in /home/sites/site15/web/db_connect.php on line 3


    Frage:

    Kann man irgendetwas bei der Bedienung falsch machen, ich finde aber es ist eigentlich selbsterkärend.


    Habe einen Freund der Windows XP benutzt gebeten die gleichen URL s auszuprobieren bei ihm leider auch nur die gleichen Fehlermeldungen.

    Liebe Grüße aus dem Ruhrpott

    Onkelhelmut
     
  5. neptun

    neptun MacUser Mitglied

    Beiträge:
    2.013
    Zustimmungen:
    22
    Registriert seit:
    28.09.2003
    Au weia - "Vorführeffekt" nennt man dies!

    Mir geht es momentan genau gleich wie dir und deinem Freund von der Windows-Front, ich erhalte auch diese Fehlermeldung. Das war mir noch nie passiert.

    Der Server ist wohl Opfer seines eigenen Erfolges geworden: mehr Zugriffe als er verkraften kann.

    Probier vielleicht morgen noch einmal wenn die Amerikaner schlafen, dann wird es sicherlich klappen.

    Gruss, neptun
     
  6. onkelhelmut

    onkelhelmut Thread Starter MacUser Mitglied

    Beiträge:
    311
    Zustimmungen:
    0
    Registriert seit:
    08.05.2003
    Email Umbruch URL

    Hallo Neptun,

    Werde es morgen nochmal versuchen. Danke. Du bist Dir also sicher, daß es sich bei meinem geschilderten Problem nicht um ein spezielles Mail (also das Programm Mail) Problem handelt. Gibt es keine Möglichkeit durch eine Einstellung oder irgendwie anders dem Problem abzuhelfen???

    Liebe Grüße aus dem Ruhrpott

    Onkelhelmut

    Hat hier sonst wirklich niemand das Problem??? Bin für jede Hilfe dankbar.
     
  7. neptun

    neptun MacUser Mitglied

    Beiträge:
    2.013
    Zustimmungen:
    22
    Registriert seit:
    28.09.2003
    Seit ich diese tinyurl-Lösung entdeckt habe, passe ich nicht mehr auf, wo das Problem auftritt und wo nicht. Wenn ich eine URL zugeschickt bekomme, untersuche ich sie immer auf verdächtige Zeichen, die durch einen Umbruch entstanden sein könnten.

    Laut tinyurl-webseite scheinen ausser uns beiden noch andere deswegen genervt zu sein. Ausserdem muss man sich überlegen, dass sowohl das Mail-Programm des Absenders wie das des Empfängers richtig "ticken" müsste, damit die Übertragung perfekt ist; als Absender hat man also sowieso höchstens "halbe Kontrolle".

    Ich glaube mich erinnern zu können, dass ich das Problem auch einmal in diesem Forum hatte, als ich eine lange URL weiterreichen wollte.

    Gruss, neptun
     
  8. onkelhelmut

    onkelhelmut Thread Starter MacUser Mitglied

    Beiträge:
    311
    Zustimmungen:
    0
    Registriert seit:
    08.05.2003
    Hallo Neptun!!!

    Gebe Dir vollkommen ich habe als Absender nur die halbe Kontrolle. Nur trotz intensiver Suche hier im Forum, bei Google & Co. konnte ich nichts aber auch rein gar nichts zu dem Thema finden.

    Und auch aus dem Bekanntenkreis, egal ob Mac oder Windoofuser habe ich bisher von diesem Problem nicht gehört.

    Deswegen mein ausgiebiges Austesten vorm Posten, und alles aber alles deutete daraufhin das nur dann das Problem auftaucht wenn es sich um überlange Mails die mit dem Programm Mail verschickt werden und auch nur dann wenn ein ? darin auftaucht, denn dann macht er wohl ein unnötiges Leerzeichen dazu.

    Daher meine Vermutung das ein Problem des Programmes Mail sein müßte.

    Werde morgen auf jeden Fall nochmal Tiny URL austesten und auch die Webseite mir intensiv anschauen.

    Nochmals Danke

    Onkelhelmut


    Hat sonst hier niemand das Problem??? Bitte melden bin für jede Hilfe dankbar.
     
  9. norbi

    norbi MacUser Mitglied

    Beiträge:
    3.506
    Zustimmungen:
    22
    Registriert seit:
    14.01.2003
    Das Problem hängt mit dem "Format" von E-Mails zusammen. Beim Versenden wird der Textbody auf 76 Zeichen/Zeile "beschnitten". Beim Empfänger werden die Texte "so gut wie möglich" wieder zusammengesetzt, allerdings eben nicht perfekt (genauer kann ich's auch nicht beschreiben, ist schon ein Weilchen her).

    Ist zwar nicht unbedingt eine Lösung, aber die 76-Zeichen-Grenze zu kennen, könnte ggf. hilfreich sein.

    No.
     
  10. onkelhelmut

    onkelhelmut Thread Starter MacUser Mitglied

    Beiträge:
    311
    Zustimmungen:
    0
    Registriert seit:
    08.05.2003
    Vielen Dank, Norbi

    aber könntest Du versuchen, mir das vielleicht doch noch etwas genauer erklären?Oder hat man da irgentwie Einfluß drauf, kann man da irgentwie was einstellen, oder, oder oder?????

    Onkelhelmut
     
Die Seite wird geladen...

Diese Seite empfehlen