macbook isight funktioniert nicht

Dieses Thema im Forum "MacBook" wurde erstellt von Moerle, 18.07.2006.

  1. Moerle

    Moerle Thread Starter MacUser Mitglied

    Beiträge:
    211
    Zustimmungen:
    1
    Registriert seit:
    09.02.2004
    nabend! ich versuche meine kamera zu benutzen und dann meldet die kiste, dass ich fotobooth nicht benutzen kann, weil die kamera von einem anderen programm benutzt wird, obwohl ich nüscht anderes offen habe :mad: was mache ich falsch? hat einer nen tipp? ach ja, ich benutze 10.4.7 grüssli
     
  2. norbi

    norbi MacUser Mitglied

    Beiträge:
    3.506
    Zustimmungen:
    22
    Registriert seit:
    14.01.2003
    Hattest Du vorher iChat verwendet?
    Starte mal neu, starte kein Programm außer PhotoBooth. Geht's dann?

    No.
     
  3. Moerle

    Moerle Thread Starter MacUser Mitglied

    Beiträge:
    211
    Zustimmungen:
    1
    Registriert seit:
    09.02.2004
    nee. habs vorher nicht benutzt. jetzt hab ich einfach trotzdem mal neu gestartet - wieder kein zugriff:(
     
  4. macnext

    macnext MacUser Mitglied

    Beiträge:
    82
    Zustimmungen:
    0
    Registriert seit:
    26.01.2004
    Habe das gleiche Problem! Irgendwelche Lösungen? Hat jemand mit Apple gesprochen?
     
  5. m@cbooker

    m@cbooker MacUser Mitglied

    Beiträge:
    6
    Zustimmungen:
    0
    Registriert seit:
    21.07.2006
    Habe ebenfalls das gleiche Problem. Die integrierte isight in meinem MBP funktioniert nur sporadisch - d.h. manchmal wird sie erkannt und kann dann durch photobooth oder ichat aktiviert werden. Oft (viel zu oft) kommt aber eine Fehlermeldung, dass ein anderes Programm bereits auf die Kamera zugreift bzw. diese nicht angeschlossen ist. Und das selbst direkt nach einem Systemstart. Im Systemprofiler fehlt dann der entsprechende Eintrag unter "USB-Hochgeschwindigkeitsbus".

    PMU-Reset, PRAM etc. hab ich alles schon ausprobiert. Letzte Aktion war eine komplette Neuinstallation vom OS, zu der mir der nette Apple-Supportler geraten hat. Auch die Aktion war leider nicht erfolgreich. Der Fehler besteht weiterhin. Ach ja, OS X 10.4.7 (war aber auch schon bei 10.4.6 fehlerbehaftet).

    FAZIT: Hardwaredefekt - da hilft nur Umtausch bzw. Reparatur :(

    Gruß

    m@cbooker
     
  6. macnext

    macnext MacUser Mitglied

    Beiträge:
    82
    Zustimmungen:
    0
    Registriert seit:
    26.01.2004
  7. fabs

    fabs MacUser Mitglied

    Beiträge:
    247
    Zustimmungen:
    1
    Registriert seit:
    19.06.2005
    Ist zwar von einem ibook G4, aber die sollte wohl auch passen, oder?
     

    Anhänge:

  8. macnext

    macnext MacUser Mitglied

    Beiträge:
    82
    Zustimmungen:
    0
    Registriert seit:
    26.01.2004
    Danke, erstmal. Mal schauen ob's funktioniert
     
  9. m@cbooker

    m@cbooker MacUser Mitglied

    Beiträge:
    6
    Zustimmungen:
    0
    Registriert seit:
    21.07.2006
    Leider Fehlanzeige

    Um mich mal wieder in die Diskussion einzuklinken: habe soeben in dem Verzeichnis nach dem File gesucht und bin auch fündig geworden. Ach ja, nebenher sei erwähnt, dass die Kamera mal wieder ihren Dienst verweigert - trotzdem ist die Kernel-Extension da... :rolleyes: bei mir hilft die Lösung leider nicht. Also doch zur Reparatur mit dem Book :(
     
  10. a_viol

    a_viol MacUser Mitglied

    Beiträge:
    5
    Zustimmungen:
    0
    Registriert seit:
    19.10.2006
    Ich schlage mich nun schon mehrere Wochen mit dem selben Problem herum und habe bisher nur einen Lösungsansatz gefunden, der sich vernünftig anhört und wohl funktioniert, allerdings scheint das ganze sehr schwierig zu sein.

    hier der Originaltext:
    -------------------------------------------------------------------------------------
    Mit Unterstützung von Ronald S. Bultje, einem Linux-Entwickler, der u.a. die Treiber für die USB iSights in Linux entwickelt hat, habe ich meine iSight wieder zum Leben erweckt.

    Benötigte Zutaten:
    - ein Linux, z.B. eine Ubuntu Live-CD
    - linux-uvc-0.1.0-c.tar.gz von http://people.freedesktop.org/~rbultje/
    - libusb-dev und C-Compiler auf besagtem Linux oder anderem Rechner
    - Eine Änderung im Source des Tools "extract" aus linux-uvc-0.1.0-c:

    In extract.c in der Funktion probe_dev in Z. 118 den Wert 0x05ac durch 0x04b4 und in Z. 119 den Wert 0x8300 durch 0x8613 ersetzen und "make" aufrufen. Das ersetzt die USB vendor/device-ID durch die, die die iSight im System Profiler nun hatte.

    Dann extract starten mit: ./extract AppleUSBVideoSupport

    AppleUSBVideoSupport ist der Treiber für die iSight aus OS X, der findet sich auf der OS X-Partition unter /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBVideoSupport.kext/Contents/MacOS

    Aus dem Treiber extrahiert extract (was sonst) die Firmware und schreibt sie wieder in den Controller der iSight. Danach erscheint die iSight unter Linux mit lsusb wieder als Vendor 0x05ac (Apple) und Device 0x8501 (iSight). Auch unter OS X erscheint die iSight jetzt wieder korrekt im System Profiler und funktioniert mit PhotoBooth und iChat.

    Das ist keine wirklich triviale Lösung, aber sie funktioniert bei mir. Ich habe bisher noch nicht von anderen Macs mit diesem Problem gehört. Falls es häufiger auftreten sollte, würde ich mich auch evtl. überzeugen lassen, eine bootfähige Linux-CD zu basteln, die die iSight-Firmware wieder restauriert.

    Wie immer - alle Angaben ohne Gewähr...
    ---------------------------------------------------------------------------------------

    soo.. alles klar oder?

    Für alle die jetzt genauso blöd wie ich dasitzen wäre es evtl. eine gute Idee den Typ, der das verfasst hat anzuschreiben um ihn dazu zu bewegen, die CD
    für "Dummies" zu erstellen. Ich hab ihm schon mal ne message geschickt.

    Hier der Link zum Original threat:
    http://www.macuser.de/forum/showthread.php?t=203758
     
Die Seite wird geladen...

Diese Seite empfehlen