localhost - Forbidden

Diskutiere mit über: localhost - Forbidden im Mac OS X Forum

  1. R.Carlos

    R.Carlos Thread Starter MacUser Mitglied

    Beiträge:
    65
    Zustimmungen:
    0
    Registriert seit:
    24.10.2003
    Hallo,
    ich habe folgendes Problem und weiß überhaupt nicht mehr weiter.
    also ich habe ich habe von www.entropy.ch PHP5 Version runtergeladen und instaliert. Habe eine PHP-Testdatei in den Websites Ordner gelegt und über http://localhost/~user/phpinfo.php aufgerufen. Dort bekomme ich auch alle gewünschten angaben über PHP Version 5.0.3. Auch andere PHP Dateinen werden einwandfrei angezeigt. Gebe ich jedoch http://localhost/~user/ ein um eine Übersicht des Ordners zu erhalten bekomme ich die Meldung...Forbidden
    You don't have permission to access /~marios/ on this server. Wie kann das sein? Hab ich da irgendwas falsch gemacht?
    Wäre für jede Hilfe dankbar.

    Vielen Dank schon mal im Voraus
    Gruß
    R.Carlos
     
  2. master_p

    master_p MacUser Mitglied

    Beiträge:
    1.065
    Zustimmungen:
    23
    Registriert seit:
    31.01.2005
    Falsch gemacht nicht direkt, aber das DirectoryListing im Apache ist anscheinend ausgeschaltet und verbietet eben genau das, das auflisten des Verzeichnisses. Sowas ist bei den meisten Webservern deaktiviert, damit niemand direkten Zugriff auf ein kompletten Verzeichnis hat.

    Ich glaube (da müsstest Du aber nochmal genauer googlen), dass das in der Apache Datei geändert werden muss.
     
  3. foo

    foo MacUser Mitglied

    Beiträge:
    51
    Zustimmungen:
    0
    Registriert seit:
    28.02.2005
    such in deiner httpd.conf (koennte in /etc/httpd liegen, bin mir nicht sicher. habe den standard-apache nicht mehr) nach:
    Code:
    <Directory /home/*/Sites>
    ...
    </Directory>
    und stell sicher, dass innerhalb dieses <Directory>..</Directory> folgendes steht
    Code:
    Options Indexes
    dann noch apache neu starten, und gut ist.
     
  4. R.Carlos

    R.Carlos Thread Starter MacUser Mitglied

    Beiträge:
    65
    Zustimmungen:
    0
    Registriert seit:
    24.10.2003
    Hi,
    vielen Dank schon mal für die Antworten.
    @foo

    Ich habe mal in der Httpd.conf mal nachgeschaut. Ich denke den Eintrag den du meinst ist dieser. Aber der sieht ganz anders aus, als du ihn beschrieben hast. Wüsste jetzt nicht wirklich was ich machen sollte :-(
    Schau mal hier...

    #<Directory /Users/*/Sites>
    # AllowOverride FileInfo AuthConfig Limit
    # Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
    # <Limit GET POST OPTIONS PROPFIND>
    # Order allow,deny
    # Allow from all
    # </Limit>
    # <LimitExcept GET POST OPTIONS PROPFIND>
    # Order deny,allow
    # Deny from all
    # </LimitExcept>
    #</Directory>
     
  5. foo

    foo MacUser Mitglied

    Beiträge:
    51
    Zustimmungen:
    0
    Registriert seit:
    28.02.2005
    ja das ist der. entferne einfach alle #. alles in einer zeile nach # wird ignoriert, ist ein kommentar.
    wenn die kommentarzeichen weg sind, funktioniert es fast sicher.
     
  6. R.Carlos

    R.Carlos Thread Starter MacUser Mitglied

    Beiträge:
    65
    Zustimmungen:
    0
    Registriert seit:
    24.10.2003
    Wow...prima. Hat geklappt.
    Danke dir foo...


    Gruß
    R.Carlos
     
Die Seite wird geladen...
Ähnliche Themen - localhost Forbidden Forum Datum
Mamp localhost root passwort ändern Mac OS X 16.01.2012
[SNOW LEOPARD] localhost-Freigabe Mac OS X 11.06.2011
Freigaben localhost im Finder Mac OS X 09.10.2010
Postscript drucken via localhost Mac OS X 22.12.2009
"localhost/~ich" kommt 403 forbidden Mac OS X 07.12.2005

Diese Seite empfehlen

Benutzerdefinierte Suche