LaTeX

Dieses Thema im Forum "Utilities und Treiber" wurde erstellt von MacErik, 15.12.2002.

  1. MacErik

    MacErik Thread Starter MacUser Mitglied

    631
    12
    06.09.2002
    Moin zusammen.
    Ich bin gerade dabei mich mit LaTeX zu beschäftigen und eigentlich ganz begeistert. Nur habe ich das Problem, dass ich keine deutsche Silbentrennung hinbekomme. Und ein deutscher Text, der nach englischen Musten getrennt wird sieht ganz schön doof aus!
    Ich habe
    \usepackage[ngerman]{babel}
    eingegeben und bekomme immer die Meldung:
    Package babel Warning: No hyphenation patterns were loaded for
    (babel) the language `ngerman'
    (babel) I will use the patterns loaded for \language=0 instead.
    Vielleicht weiß ja jemand von euch weiter.
    Erik
     
  2. mj

    mj MacUser Mitglied

    5.342
    229
    19.11.2002
    babel? Davon hab ich noch nie gehört ;)
    Welches TeX verwendest du denn, es gibt für Macintosh ja verschiedene. OzTeX oder CMacTex?
     
  3. MacErik

    MacErik Thread Starter MacUser Mitglied

    631
    12
    06.09.2002
    Ich verwende teTeX und TeXShop unter OS 10.2.2.
     
  4. tasha

    tasha MacUser Mitglied

    3.676
    38
    06.08.2002
    Hi,

    also ich lade die Silbentrennung immer über
    \usepackage{ngerman}
    Deine Variante sollte aber auch funktionieren, kommt aufs gleiche raus. Ich suche mal, wo babel sein sollte. Vielleicht fehlt dir einfach die Definition der neudeutschen Silbentrennung? Sollte aber bei einer TeTeX-Standardinstallation dabei sein. Versuch mal meine Variante oder das Paket german.

    Außerdem solltest du noch
    \usepackage[applemac]{inputenc}

    laden (Mac-Tastaturbelegung), um Probleme mit einigen Zeichen zu verhindern und Umlaute direkt einzugeben.

    \usepackage[T1]{fontenc}
    ist auch ratsam, es sind Zeichensätze, in denen Umlaute etc. vorhanden sind und nicht zusammengesetzt werden müssen (TeTeX-Paket cm-super nötig, z. B. über i-Installer installieren)

    @D'Espice:
    Diese Fehlermeldung hat nichts mit dem verwendeten Editor zu tun. Das ist ja das schöne an LaTeX.
     
  5. tasha

    tasha MacUser Mitglied

    3.676
    38
    06.08.2002
    So, ich hab mal bissi gesucht. Du brauchst im Ordner /Library/teTeX/share/texmf/tex/generic/babel
    die Dateien
    ngermanb.ldf und ngermanb.sty
    (und natürlich babel.sty, das ebendiese aufruft ;))

    Die globale Option ngerman, die ich vorhin geschrieben hatte ruft auch babel auf.
     
  6. MacErik

    MacErik Thread Starter MacUser Mitglied

    631
    12
    06.09.2002
    Die Dateien sind alles da, nur das sie im Verzeichnis /usr/local/teTeX/... liegen. Das sollte aber keinen Unterschied machen.
    Wenn ich \usepackage{ngerman} benutze bekomme ich sofort eine Fehlermeldung.
     
  7. tasha

    tasha MacUser Mitglied

    3.676
    38
    06.08.2002
    Hmm, könnte sein, dass LaTeX die Files nicht findet, bei mir ist in /Library eine Verknüpfung auf /usr/local/teTeX

    Schau dir dazu am besten mal die Datei
    README.howtexfindsfiles
    z. B. in /usr/local/teTeX an.

    Die Fehlermeldung bei \usepackage{ngerman} sollte verschwinden, wenn du die .aux und .log Dateien, die zu deinem Dokument gehören löscht. Dann sollte die gleiche Fehlermeldung wie bei \usepackage[ngerman]{babel} kommen.
     
  8. mj

    mj MacUser Mitglied

    5.342
    229
    19.11.2002
    Hmm...

    \usepackage[T1]{fontenc}

    Dies verursacht bei mir eine Fehlermeldung, ich benutze OzTeX auf meinem PowerBook 1400 unter OS 8.6 weshalb ich die Umlaute derzeit während dem tippen immer noch normal eingeben und anschließend per Search&Replace ersetze... was für Voraussetzungen müssen denn gegeben sein damit obiges funzt? Ich schau heute nochmal die genaue Fehlermeldung nach, hab sie grade nicht im Kopf.
     
  9. tasha

    tasha MacUser Mitglied

    3.676
    38
    06.08.2002
    @D'Espice

    Nein, bei den T1-Fonts sind die Umlaute für die Ausgabe vorhanden. Hat mit der Eingabe nichts zu tun. Bei der Standardkodierung werden die Umlaute für die Ausgabe aus verschiedenen Zeichen zusammengesetzt, z. B. "ä" aus einem "a" mit zwei Pünktchen drüber. Bei T1-Fonts ist das "ä" ein vordefiniertes Zeichen.

    Bei der teTeX-Standardinstallation sind die Computer-Modern-Fonts nicht in T1-Codierung dabei, man muss sie über das Paket "CM Super for TeX installieren. Wie es sich allerdings bei deiner TeX-Distribution für OS 8.6 verhält, kann ich dir mangels eigener Erfahrung nicht sagen. Ich hab auf der Homepage gesehen, dass OzTeX nicht nur ein Editor ist, sondern auch die TeX-Implementierung, deshalb schlag ich vor, wühl dich mal durch die Doku.

    Um Umlaute eingeben zu können, brauchst du
    \usepackage{german} bzw ngerman (german.sty oder ngerman.sty muss dazu vorhanden sein, für Trennung, deutsche Kolumnentitel etc.)

    und
    \usepackage[applemac]{inputencoding}

    wodurch TeX erfährt, dass das Dokument auf einem Mac geschrieben wurde und die Codierung entsprechend interpretiert. Wenn es dann immer noch nicht klappt, melde dich noch mal.
     
  10. MacErik

    MacErik Thread Starter MacUser Mitglied

    631
    12
    06.09.2002
    Ich komme irgendwie immer noch nicht weiter. Bei mir geht alles (Umlaute, deutsche Kolumnentitel und Bildunterschriften, Literaturverzeichnis) nur eben die Trennungen nicht. Deshalb möchte eigentlich teTeX über den i-installer nochmal neu installieren. Muss ich dafür irgendetwas deinstallieren, oder kann ich einfach drüberbügeln?
     
Die Seite wird geladen...
Ähnliche Themen - LaTeX
  1. HiTek
    Antworten:
    9
    Aufrufe:
    5.511
    Jevil
    21.03.2007
  2. Thanuviel
    Antworten:
    3
    Aufrufe:
    2.571
    MichaelK
    26.09.2005
  3. mini
    Antworten:
    2
    Aufrufe:
    839
    mini
    09.11.2004
  4. mini
    Antworten:
    10
    Aufrufe:
    3.469
    neptun
    16.01.2005
  5. bonehammer
    Antworten:
    19
    Aufrufe:
    14.834

Diese Seite empfehlen