LaTeX: custombib, natbib, bst-files

Dieses Thema im Forum "Office Software" wurde erstellt von Chrihsssih, 20.07.2006.

  1. Chrihsssih

    Chrihsssih Thread Starter MacUser Mitglied

    Beiträge:
    103
    Zustimmungen:
    1
    MacUser seit:
    20.05.2006
    Hallo Forum!

    Ich bin LaTeX- und Mac-Neuling und hab ein paar Fragen an Euch:

    1. Ich schreibe meine Abschlussarbeit mit LaTeX und muss dabei eine bestimmte Zitierweise einhalten. Also habe mich mir mit custombib eine (hoffentlich) entsprechende .bst-Datei erzeugt. Allerdings kann ich das Verzeichnis, in das ich sie legen muss, nicht finden. Ich dachte, sie muss in library/tetex/share/texmf/bibtex/bst. Dieses bst-Verzeichnis gibt es bei mir aber nicht, ich kann es auch nicht anlegen, da ich auf den gesamten tetex-Ordner nicht schreibend zugreifen kann. Ich hab gedacht, ich könnte nach dem entsprechenden Ordner dann einfach suchen, indem ich bei spotlight z.B. nach geralpha suche (ist ja auch ein bst-file), aber das findet er nicht. Was mache ich denn falsch?

    2. Um Autor-Jahr-Zitate zu verwenden benutze ich natbib. Das klappt auch, allerdings wäre es super, wenn der Autor immer in Kapitälchen gesetzt wäre. Kann man einstellen, dass er das automatisch macht?

    3. Ich darf nicht mit Verlag zitieren, Bibtex meldet mir aber immer einen Fehler, wenn ich den Verlag nicht angebe. Wie kann ich das umgehen?

    4. Ich suche eine Literaturdatenbank, die sowohl mit LaTeX als auch mit Mellel und MS Office for Mac läuft. Gibt´s so was? Im Moment benutze ich Bibdesk. Ist JabRef mit den beiden Programmen kompatibel?

    Wäre wirklich toll, wenn mir jemand helfen könnte!

    Chrissi
     
  2. Hallo Chrissi,

    ich glaube, Du machst Dir das Leben unnötig schwer. Ich weiß zwar nicht, in welchen Fach Du Deine Abschlußarbeit schreibst, aber ich würde es mal mit Jurabib versuchen, bevor Du Dir selber eine bst-Datei bastelst. Dieses Paket ist zitiertechnisch eine eierlegende Wollmilchsau.

    Kurzes Beispiel, wie man die Autoren in Kapitälchen setzt:

    ...
    \usepackage[authorformat=smallcaps]{jurabib}
    ...

    Die Doku dazu findest Du unter teTeX/texmf.tetex/doc/latex/jurabib. Wenn Du Dateien in Deiner TeX-Distribution suchst, geht das tatsächlich nicht unter spotlight, sondern: Finder -> Macintosh HD -> Library -> teTeX Ordner öffnen. In diesem Fenster kannst Du dann oben in dem kleinen Suchfenster nach Deinen Dateien suchen. Zu den Datenbanken kann ich Dir leider keine Auskunft geben, weil ich beide Programme nicht verwende. Gut wäre auch, wenn Du ein Minimalbeispiel posten würdest, denn sonst kann man kaum auf Deine Fragen, wie z.B. Deine dritte, antworten.

    Grüße, Ludwig
     
    Zuletzt von einem Moderator bearbeitet: 20.07.2006
  3. dehose

    dehose unregistriert

    Beiträge:
    5.208
    Zustimmungen:
    492
    MacUser seit:
    05.03.2004
    Les mal hier meinen Beitrag am Ende durch, vielleicht hilft er dir.
    http://www.macuser.de/forum/showthread.php?t=186403

    Evtl. musst du den Ordner einfach erstellen oder die Rechte ändern (mittels Apfel+I, dann unten auf den Eigentümer auf dich ändern)
     
  4. peterg

    peterg MacUser Mitglied

    Beiträge:
    2.752
    Zustimmungen:
    184
    MacUser seit:
    02.03.2005
    Hallo,

    zu 1. und 2. kann ich leider nix sagen. Das Verzeichnis ist bei mir einfach da und ich darf exakt in das bst-Verzeichnis schreiben. In jurabib wird das Problem der Kapitälchen durch Parameter beim Einbinden des Paketes gelöst:

    % Paket für korrekte Zitate
    \usepackage[%
    citefull=first, % Das erste Zitat wird mit vollständigem
    % bibliographischen Eintrag gem. Literaturverzeichnis angegeben
    authorformat=smallcaps, % Der Autor wird in Kapitälchen gesetzt
    titleformat=italic, % Der Titel wird kursiv gesetzt.
    titleformat=colonsep, % Doppelpunkt zwischen Autor und Titel.
    ibidem=strict, % Steuerung von Wiederholungszitaten
    commabeforerest, % Komma nach bibliographischen Angaben und Rest
    % dotafter=bibentry, % Punkt nach Eintrag im Literaturverzeichnis; funkt nicht
    ]{jurabib}

    Das Beispiel sieht dumm aus. Sende Dir gern meine Vorlagen-Datei...

    Das sollte in der Dokumentation zu natbib stehen.

    Zu 3: bei mir meckert BibTex nichts an. Wie gibts Du den Verlag denn an?

    Zu 4: zum Beispiel Bookends (Word = Word für den Mac). Das Programm erlaubt den Export im BibTeX-Format. JabRef arbeitet m.W. nur mit einem Programm, dass BibTeX verarbeiten kann. Das können weder Mellel noch Word.

    Jetzt stellt sich die Frage, wieviel Zeit Du verwenden willst ;-)

    Gruß
    Peter
     
  5. Chrihsssih

    Chrihsssih Thread Starter MacUser Mitglied

    Beiträge:
    103
    Zustimmungen:
    1
    MacUser seit:
    20.05.2006
    Hallo!

    Vielen Dank für die vielen Antworten. Das 1. Problem hab ich jetzt zunächst mal dadurch gelöst, dass ich die .bst-Datei ins Projektverzeichnis gelegt habe. Für den Rest muss ich nochmal etwas rumprobieren. Danke für den Tipp mit jurabib, das werde ich direkt mal ausprobieren, falls es noch Probleme gibt. Auch danke für den Tipp mit bookends, ich dachte bis jetzt, das kann nur mit Word und Mellel zusammenarbeiten. Muss ich mich noch mal etwas genauer informieren.

    Allerdings hab ich noch ein neues weiteres Problem: ich benutze "inputenc" für die Anführungszeichen. Das funktioniert aber nicht, wenn meine Zitate z. B. mit i oder e beginnen, dann macht er mir statt "i automatisch ein i mit zwei Punkten drauf. Im Moment hab ich das Problem gelöst, indem ich Autovervollständigen in TexShop aktiviert hab, dann macht er mir statt Anführungszeichen die entsprechenden Apostrophe und ersetzt außerdem ä automatisch durch \"a usw. Kann ich das auch anders lösen? Ist mir so nämlich etwas zu unübersichtlich.

    Chrissi
     
  6. dpr

    dpr MacUser Mitglied

    Beiträge:
    519
    Zustimmungen:
    0
    MacUser seit:
    04.04.2006
    Das Stichwort heißt BSTINPUTS. Leg Dir Deine bst in irgendein Verzeichnis und laß BSTINPUTS drauf zeigen:

    Code:
    setenv BSTINPUTS :/Users/ichbins/bstinput//
    
    oder
    Code:
    export BSTINPUTS=:/Users/ichbins/bstinput//
    
    Schau mal hier: http://www.cs.stir.ac.uk/~kjt/software/latex/showbst.html

    Gruß, Denny
     
  7. peterg

    peterg MacUser Mitglied

    Beiträge:
    2.752
    Zustimmungen:
    184
    MacUser seit:
    02.03.2005
    mit welchem Zeichensatz verwendest Du inputenc?
     
  8. Chrihsssih

    Chrihsssih Thread Starter MacUser Mitglied

    Beiträge:
    103
    Zustimmungen:
    1
    MacUser seit:
    20.05.2006
    Hallo!

    Nochmal vielen Dank für die vielen Antworten!

    @dpr: Muss ich gleich mal ausprobieren.

    @peterq: habe in Texshop Iso Latin 1 eingestellt und als optionales Argument ansinew.

    Mein mit custombib erzeugtes bst-File funktioniert übrigens mittlerweile (aus dem Projektverzeichnis raus), habe aber nur noch ein Problem: Wie muss ich mehrere Autoren bei Bibdesk eingeben, so dass Bibtex diese einzeln erkennt? Am besten sollte Bibtex dann sogar noch Nachnamen von Vornamen unterscheiden können, damit die Nachnamen immer in Kapitälchen erscheinen. Bei einem Autor funktioniert das, aber bei mehreren Autoren schmeißt´s mir immer Nachnamen und Vornamen wild durcheinander.

    Chrissi
     
  9. peterg

    peterg MacUser Mitglied

    Beiträge:
    2.752
    Zustimmungen:
    184
    MacUser seit:
    02.03.2005
    Was die Anführungszeichen betrifft, so müssen wir wohl auf die LaTeX-Gurus aus dem Forum warten. Ich arbeite mit Latin1 in TexShop und Latin9 als Parameter von inputenc. Damit funktioniert das meiste - die Anführungszeichen gebe ich allerdings mit \glqq und \grqq ein (mit geschweiften Klammern nach \grqq wenn danach ein Leerzeichen folgt). Finde ich nicht schön - habe mich aber daran gewöhnt.

    Was das Problem mit dem Literaturverzeichnis betrifft - das dürfte an den Einstellungen in LaTeX liegen. Benutzt Du inzwischen jurabib? Das erzeugt bei mir genau passende Ergebnisse. Zitiere jedoch auch mit Autor, Kurztitel bzw. kompletter Literaturangabe - wie in den Geisteswissenschaften in Deutschland üblich.

    Peter
     
  10. peterg

    peterg MacUser Mitglied

    Beiträge:
    2.752
    Zustimmungen:
    184
    MacUser seit:
    02.03.2005
    Hi,

    da unsere LaTeX-Profis bei dem Wetter wohl etwas besseres zu tun haben, hier die Informationen, die ich zum Thema Sonderzeichen ermittelt habe:

    In den Einstellungen von TeXShop stellst Du ein, in welchem Zeichensatz Du die Quelldatei speichern möchtest. Als Parameter von inputenc teilst Du TeX mit, in welchem Zeichensatz die folgende Quelldatei kodiert ist. Es macht Sinn, dieselben Einstellungen zu verwenden. Ich nutze Latin9 - das entspricht Latin1 mit dem Eurosymbol. Damit sollten meine Quelldateien auch unter Windows gut lesbar sein.

    Damit sind einige, aber nicht alle Sonderzeichen direkt eingebbar. In der Kombination inputenc und babel mit dem Parameter german bzw. ngerman sind dann verschiedene weitere Zeichen verfügbar. Die Gänsefüsschen leider nur mit den beschriebenen Befehlen \qlqq und \grqq bzw. mit "´ und "'.

    Mir ist nicht bekannt, dass TeXShop oder iTeX hier die Möglichkeit bieten, die Zeichen entsprechend umzusetzen.

    Es bleibt also nur die - für das Lesen des Quelltextes - ungewohnte Eingabeweise.

    Quelle: Thorsten Zilm: LaTeX. Das Einsteigerseminar. Bonn (bhv) 2003, S. 59 ff.

    Gruß
    Peter
     
Die Seite wird geladen...

Diese Seite empfehlen