Langsamer Localhost ... aber nur mit Safari.

Dieses Thema im Forum "Mac OS X Apps" wurde erstellt von polyesterday, 18.09.2006.

  1. polyesterday

    polyesterday Thread Starter MacUser Mitglied

    Beiträge:
    227
    Zustimmungen:
    0
    MacUser seit:
    18.12.2002
    Servus.

    Folgendes Problem:
    Safari benötigt unglaublich lange für Anfragen an den "Localhost". Firefox und Opera hingegen haben keine Probleme.

    Hintergrund:
    Ich habe MediaWiki, PHP 5 und MySQL auf meinem iBook installiert (OSX 10.4.7, Apache 1.3.33). Wenn ich das Wiki über "localhost/~user/mediawiki/index.php/Hauptseite" starte, funktioniert dies ohne Probleme.
    Rufe ich die Seite jedoch über "localhost/~user/mediawiki/index.php" auf (und lasse den Zusatz "Hauptseite" weg), dann ändert sich die URL in "macintosh.lokal/~user/mediawiki/index.php/Hauptseite" und es dauert unglaublich lange (>1 Minute) bis die Seite geladen ist.

    Opera und Firefox haben nicht das geringste Problem wenn ich mit den beiden so verfahre wie oben angegeben.

    Das wäre ja auch alles garnicht so dramatisch, wenn MediaWiki nicht ständig über diese "macintosh.local"-Adresse gehen würde wenn ich einen neuen Eintrag mache. Dadurch ist die Arbeit mit MediaWiki im Zusammenspiel mit Safari eine Katastrophe.

    Ich bin gerade am verzweifeln. Hat irgendjemand eine Idee woran das liegen könnte bzw. wie ich Safari in den Allerwertesten treten könnte?
     
  2. nanya

    nanya MacUser Mitglied

    Beiträge:
    274
    Zustimmungen:
    2
    MacUser seit:
    08.04.2003
    Hi, ich erinnere mich, dass ich damals auch Probleme hatte (ob nur mit Safari, weiß ich jetzt nicht mehr), die ich umgehen konnte, indem ich statt localhost die IP geschrieben habe.
     
  3. polyesterday

    polyesterday Thread Starter MacUser Mitglied

    Beiträge:
    227
    Zustimmungen:
    0
    MacUser seit:
    18.12.2002
    Hm, habe soeben herausgefunden das dieses Problem/Phänomen nur besteht wenn ich online bin bzw. wenn ich mit meiner AirPortExpress-Station verbunden bin. Sehr seltsam ...
     
  4. mec

    mec MacUser Mitglied

    Beiträge:
    384
    Zustimmungen:
    1
    MacUser seit:
    17.12.2003
    Hi,
    habe auch Probleme mit http://localhost . Hab PHP5 und Apache2 installiert, aber sobald ich den Apache im Localhost testen will, kommt immer die Fehlermeldung "Safari kann die Seite „http://localhost/“ nicht öffnen, da Safari keine Verbindung zum Server „localhost“ aufbauen konnte."
    Versteh ich nicht.

    Was muss ich tun...?
    Gruß,
    mec
     
Die Seite wird geladen...
Ähnliche Themen - Langsamer Localhost aber
  1. Dark Rose
    Antworten:
    3
    Aufrufe:
    127
    Apfelwelt
    28.10.2016
  2. ihatewintel
    Antworten:
    10
    Aufrufe:
    357
    DoroS
    25.07.2016
  3. ShnikShnak
    Antworten:
    3
    Aufrufe:
    187
    Escorpio
    25.01.2016
  4. astor
    Antworten:
    6
    Aufrufe:
    373
    lisanet
    24.12.2015
  5. banana12
    Antworten:
    0
    Aufrufe:
    133
    banana12
    08.10.2015